aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-blockdiag
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-04-25 12:16:42 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-04-25 12:16:42 +0000
commit3f90bd7ccacb1a54ce7a5d9bbfc1fc29f9a87392 (patch)
tree71e86fb8e4d9e9cfa765ad9abf8344eb8a1c2650 /graphics/py-blockdiag
parente7829a606ff5e4c022150c3a30d2154f89e79b01 (diff)
downloadports-3f90bd7ccacb1a54ce7a5d9bbfc1fc29f9a87392.tar.gz
ports-3f90bd7ccacb1a54ce7a5d9bbfc1fc29f9a87392.zip
Notes
Diffstat (limited to 'graphics/py-blockdiag')
-rw-r--r--graphics/py-blockdiag/Makefile2
-rw-r--r--graphics/py-blockdiag/distinfo4
-rw-r--r--graphics/py-blockdiag/files/patch-bootstrap.py32
3 files changed, 24 insertions, 14 deletions
diff --git a/graphics/py-blockdiag/Makefile b/graphics/py-blockdiag/Makefile
index 0a25c2968c93..4791f6ad6973 100644
--- a/graphics/py-blockdiag/Makefile
+++ b/graphics/py-blockdiag/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= blockdiag
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.5
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/py-blockdiag/distinfo b/graphics/py-blockdiag/distinfo
index 32600f6a53cd..1f0907c80636 100644
--- a/graphics/py-blockdiag/distinfo
+++ b/graphics/py-blockdiag/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blockdiag-1.1.4.tar.gz) = 129aeae84ae4dacb32926ad942832ad517442703f6989b30542e2960313a7453
-SIZE (blockdiag-1.1.4.tar.gz) = 132351
+SHA256 (blockdiag-1.1.5.tar.gz) = 07818e570ad15eba86d54222fa6cc35851fb3470e8b522ce155fdf9ddfd7a922
+SIZE (blockdiag-1.1.5.tar.gz) = 133589
diff --git a/graphics/py-blockdiag/files/patch-bootstrap.py b/graphics/py-blockdiag/files/patch-bootstrap.py
index ec7240caac27..baa65a574b77 100644
--- a/graphics/py-blockdiag/files/patch-bootstrap.py
+++ b/graphics/py-blockdiag/files/patch-bootstrap.py
@@ -1,21 +1,31 @@
---- src/blockdiag/utils/bootstrap.py.orig 2011-12-16 20:04:27.000000000 +0900
-+++ src/blockdiag/utils/bootstrap.py 2011-12-29 11:15:27.000000000 +0900
-@@ -170,13 +170,7 @@
+--- src/blockdiag/utils/bootstrap.py.orig 2012-04-18 11:00:23.000000000 +0900
++++ src/blockdiag/utils/bootstrap.py 2012-04-23 11:34:13.000000000 +0900
+@@ -182,23 +182,7 @@
def detectfont(options):
-- fonts = ['c:/windows/fonts/VL-Gothic-Regular.ttf', # for Windows
-- 'c:/windows/fonts/msgothic.ttf', # for Windows
-- 'c:/windows/fonts/msgoth04.ttc', # for Windows
-- '/usr/share/fonts/truetype/ipafont/ipagp.ttf', # for Debian
-- '/usr/local/share/font-ipa/ipagp.otf', # for FreeBSD
-- '/Library/Fonts/Hiragino Sans GB W3.otf', # for MacOS
-- '/System/Library/Fonts/AppleGothic.ttf'] # for MacOS
+- fonts = [
+- # for Windows
+- 'c:/windows/fonts/VL-Gothic-Regular.ttf',
+- 'c:/windows/fonts/msgothic.ttf',
+- 'c:/windows/fonts/msgoth04.ttc',
+- # for Debian (squeeze)
+- '/usr/share/fonts/truetype/ipafont/ipagp.ttf',
+- '/usr/share/fonts/truetype/vlgothic/VL-PGothic-Regular.ttf',
+- # for Debian (wheezy)
+- '/usr/share/fonts/opentype/ipafont-gothic/ipagp.ttf',
+- '/usr/share/fonts/truetype/vlgothic/VL-PGothic-Regular.ttf',
+- # for MacOS
+- '/Library/Fonts/Hiragino Sans GB W3.otf', # for MacOS
+- '/System/Library/Fonts/AppleGothic.ttf', # for MacOS
+- # for FreeBSD
+- '/usr/local/share/font-ipa/ipagp.otf', # for FreeBSD
+- ]
+ ipafontpath = '%%LOCALBASE%%/share/font-ipa/ipagp.otf'
fontpath = None
if options.font:
-@@ -190,11 +184,8 @@
+@@ -212,11 +196,8 @@
raise RuntimeError(msg)
if fontpath is None: