aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cgkit
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2011-01-20 12:04:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2011-01-20 12:04:56 +0000
commiteff400078becf45a3aea6377516063b25172d0ad (patch)
tree9547ce588becc99a2ef89082b0a79c8020a69c89 /graphics/py-cgkit
parent6e25c5ae3b33ddcffc1ba0f80402fbb655dfad78 (diff)
downloadports-eff400078becf45a3aea6377516063b25172d0ad.tar.gz
ports-eff400078becf45a3aea6377516063b25172d0ad.zip
Notes
Diffstat (limited to 'graphics/py-cgkit')
-rw-r--r--graphics/py-cgkit/Makefile4
-rw-r--r--graphics/py-cgkit/files/patch-supportlib-include-slot.h45
2 files changed, 45 insertions, 4 deletions
diff --git a/graphics/py-cgkit/Makefile b/graphics/py-cgkit/Makefile
index a072f844a7d7..4da4322e92c3 100644
--- a/graphics/py-cgkit/Makefile
+++ b/graphics/py-cgkit/Makefile
@@ -42,10 +42,6 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/OpenGL:${PORTSDIR}/graphics/py-opengl \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.endif
-
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
diff --git a/graphics/py-cgkit/files/patch-supportlib-include-slot.h b/graphics/py-cgkit/files/patch-supportlib-include-slot.h
new file mode 100644
index 000000000000..1d1a368bcab4
--- /dev/null
+++ b/graphics/py-cgkit/files/patch-supportlib-include-slot.h
@@ -0,0 +1,45 @@
+--- supportlib/include/slot.h.orig 2011-01-20 12:26:58.000000000 +0100
++++ supportlib/include/slot.h 2011-01-20 12:29:40.000000000 +0100
+@@ -729,7 +729,7 @@
+ template<class T>
+ void Slot<T>::setController(ISlot* ctrl)
+ {
+- DEBUGINFO1(this, "Slot<T>::setController(0x%x)", (unsigned int)(ctrl));
++ DEBUGINFO1(this, "Slot<T>::setController(0x%x)", (uintptr_t)(ctrl));
+ // Check if this slot can take input connections (but allow setting 0
+ // as this can happen during destruction)
+ if ((flags & NO_INPUT_CONNECTIONS) && ctrl!=0)
+@@ -738,7 +738,7 @@
+ // If the new and old controller are the same, then there's nothing to do
+ if (controller==ctrl)
+ {
+- DEBUGINFO1(this, "Slot<T>::setController(0x%x) --- end (new==old)", (unsigned int)(ctrl));
++ DEBUGINFO1(this, "Slot<T>::setController(0x%x) --- end (new==old)", (uintptr_t)(ctrl));
+ return;
+ }
+
+@@ -774,13 +774,13 @@
+ ctrl->addDependent(this);
+ notifyDependents();
+ }
+- DEBUGINFO1(this, "Slot<T>::setController(0x%x) --- end", (unsigned int)(ctrl));
++ DEBUGINFO1(this, "Slot<T>::setController(0x%x) --- end", (uintptr_t)(ctrl));
+ }
+
+ template<class T>
+ void Slot<T>::addDependent(Dependent* d)
+ {
+- DEBUGINFO1(this, "Slot<T>::addDependent(0x%x)", (int)d);
++ DEBUGINFO1(this, "Slot<T>::addDependent(0x%x)", (intptr_t)d);
+
+ // Do nothing if the dependent was already added before
+ if (std::find(dependents.begin(), dependents.end(), d)!=dependents.end())
+@@ -793,7 +793,7 @@
+ template<class T>
+ void Slot<T>::removeDependent(Dependent* d)
+ {
+- DEBUGINFO1(this, "Slot<T>::removeDependent(0x%x)", (int)d);
++ DEBUGINFO1(this, "Slot<T>::removeDependent(0x%x)", (intptr_t)d);
+
+ // Remove the element (it is moved to the back)
+ std::vector<Dependent*>::iterator res = std::remove(dependents.begin(), dependents.end(), d);