aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-editobj
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-08 22:47:43 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-08 22:47:43 +0000
commit0597d49f62f4087907456d92b671e69b9560e073 (patch)
tree3621d03d7bbcea47a1f423d4e3d2ea7fc3767867 /graphics/py-editobj
parent873f264b3afa757317624c00132c9203961ec84c (diff)
downloadports-0597d49f62f4087907456d92b671e69b9560e073.tar.gz
ports-0597d49f62f4087907456d92b671e69b9560e073.zip
Notes
Diffstat (limited to 'graphics/py-editobj')
-rw-r--r--graphics/py-editobj/Makefile31
-rw-r--r--graphics/py-editobj/distinfo2
-rw-r--r--graphics/py-editobj/pkg-descr9
-rw-r--r--graphics/py-editobj/pkg-plist39
4 files changed, 81 insertions, 0 deletions
diff --git a/graphics/py-editobj/Makefile b/graphics/py-editobj/Makefile
new file mode 100644
index 000000000000..f04d2fb8ebc1
--- /dev/null
+++ b/graphics/py-editobj/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-editobj
+# Date created: 2005-10-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= editobj
+PORTVERSION= 0.5.6
+CATEGORIES= graphics python
+MASTER_SITES= http://download.gna.org/songwrite/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= EditObj-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= EditObj can create and display a Tkinter dialog box
+
+DIST_SUBDIR= python
+USE_GZIP= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+WRKSRC= ${WRKDIR}/EditObj-${PORTVERSION}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-editobj
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-editobj/distinfo b/graphics/py-editobj/distinfo
new file mode 100644
index 000000000000..93ec173a02bb
--- /dev/null
+++ b/graphics/py-editobj/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/EditObj-0.5.6.tar.gz) = a8e999353957cd9fa9f5a6d6fcd0e889
+SIZE (python/EditObj-0.5.6.tar.gz) = 39614
diff --git a/graphics/py-editobj/pkg-descr b/graphics/py-editobj/pkg-descr
new file mode 100644
index 000000000000..176db75c02be
--- /dev/null
+++ b/graphics/py-editobj/pkg-descr
@@ -0,0 +1,9 @@
+EditObj can create and display a Tkinter dialog
+box for editing any Python object (similarly to
+what Java call a Bean editor, but for Python object).
+EditObj is a usefull tool for writing (text or
+non-text) editors of all kinds, including GUI editor,
+3D editor,... It also includes a Python console
+(thanks to Ka-Ping Yee).
+
+WWW: http://home.gna.org/oomadness/en/editobj/index.html
diff --git a/graphics/py-editobj/pkg-plist b/graphics/py-editobj/pkg-plist
new file mode 100644
index 000000000000..5f38bf82ef91
--- /dev/null
+++ b/graphics/py-editobj/pkg-plist
@@ -0,0 +1,39 @@
+lib/%%PYTHON_VERSION%%/site-packages/editobj/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/cancel.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/console.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/custom.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/editor.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/eventobj.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/main.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/observe.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/treewidget.py
+lib/%%PYTHON_VERSION%%/site-packages/editobj/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/cancel.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/console.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/custom.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/editor.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/eventobj.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/main.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/observe.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/treewidget.pyc
+lib/%%PYTHON_VERSION%%/site-packages/editobj/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/cancel.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/console.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/custom.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/editor.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/eventobj.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/main.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/observe.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/treewidget.pyo
+lib/%%PYTHON_VERSION%%/site-packages/editobj/icons/folder.pgm
+lib/%%PYTHON_VERSION%%/site-packages/editobj/icons/minus.pgm
+lib/%%PYTHON_VERSION%%/site-packages/editobj/icons/openfolder.pgm
+lib/%%PYTHON_VERSION%%/site-packages/editobj/icons/plus.pgm
+lib/%%PYTHON_VERSION%%/site-packages/editobj/icons/python.pgm
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/test_observe.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/tree_demo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/tree_demo2.py
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/editobj/icons
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/editobj