aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-gchartwrapper
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-01-09 17:51:24 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-01-09 17:51:24 +0000
commitd89770a79a8130fc03f38fb9e2793f1930a562d0 (patch)
treee1c6d5a409d5ae1b1e8f03eed26c66d7035d3e45 /graphics/py-gchartwrapper
parent8eae5e3997636d0ead25e755c1816fadf2b4ddd2 (diff)
downloadports-d89770a79a8130fc03f38fb9e2793f1930a562d0.tar.gz
ports-d89770a79a8130fc03f38fb9e2793f1930a562d0.zip
Notes
Diffstat (limited to 'graphics/py-gchartwrapper')
-rw-r--r--graphics/py-gchartwrapper/Makefile41
-rw-r--r--graphics/py-gchartwrapper/distinfo6
-rw-r--r--graphics/py-gchartwrapper/pkg-descr9
-rw-r--r--graphics/py-gchartwrapper/pkg-plist148
4 files changed, 204 insertions, 0 deletions
diff --git a/graphics/py-gchartwrapper/Makefile b/graphics/py-gchartwrapper/Makefile
new file mode 100644
index 000000000000..029e6f01947c
--- /dev/null
+++ b/graphics/py-gchartwrapper/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gchartwrapper
+# Date created: 2009-01-09
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GChartWrapper
+PORTVERSION= 0.7
+#PORTREVISION= 0
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ LOCAL/nivit/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
+.if !defined(NOPORTDOCS) || !defined(NOPORTEXAMPLES)
+DISTFILES+= ${PORTNAME}-extras-${PORTVERSION}.tar.gz
+.endif
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Python Google Chart Wrapper
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>=1.1.6_2:${PORTSDIR}/graphics/py-imaging
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
+
+PROJECTHOST= google-chartwrapper
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} && cd ${WRKDIR}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR} && cd ${WRKDIR}/templating && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gchartwrapper/distinfo b/graphics/py-gchartwrapper/distinfo
new file mode 100644
index 000000000000..07ffc6a0aaf5
--- /dev/null
+++ b/graphics/py-gchartwrapper/distinfo
@@ -0,0 +1,6 @@
+MD5 (GChartWrapper-0.7.tar.gz) = e7da63117225f576ffa911009da0f07d
+SHA256 (GChartWrapper-0.7.tar.gz) = 11d38b8974c5ce34861f61a5b5d47cb3b3c03427cc7305db14f061e061929f74
+SIZE (GChartWrapper-0.7.tar.gz) = 24062
+MD5 (GChartWrapper-extras-0.7.tar.gz) = eee7e29ff810db7ed47878b3a1381a02
+SHA256 (GChartWrapper-extras-0.7.tar.gz) = cfeaf32458f0108ac5a3b1773d2993e33f4af1a5d61559216b6789e913c966f3
+SIZE (GChartWrapper-extras-0.7.tar.gz) = 205099
diff --git a/graphics/py-gchartwrapper/pkg-descr b/graphics/py-gchartwrapper/pkg-descr
new file mode 100644
index 000000000000..6cef834a2b03
--- /dev/null
+++ b/graphics/py-gchartwrapper/pkg-descr
@@ -0,0 +1,9 @@
+Python wrapper for the Google Chart API.
+
+The wrapper can render the URL of the Google chart, based on your parameters,
+or it can render an HTML img tag to insert into webpages on the fly.
+Made for dynamic python websites (Django,Zope,CGI,etc.) that need on the fly
+chart generation without any extra modules. Can also grab the PIL Image
+instance of the chart for manipulation
+
+WWW: http://code.google.com/p/google-chartwrapper/
diff --git a/graphics/py-gchartwrapper/pkg-plist b/graphics/py-gchartwrapper/pkg-plist
new file mode 100644
index 000000000000..bdedf3fbb79c
--- /dev/null
+++ b/graphics/py-gchartwrapper/pkg-plist
@@ -0,0 +1,148 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/GChartWrapper/GChart.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/GChart.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/GChart.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/__init__.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/__init__.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/__init__.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/__init__.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/__init__.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/__init__.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/__init__.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/__init__.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/__init__.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/charts.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/charts.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags/charts.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/constants.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/constants.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/constants.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/encoding.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/encoding.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/encoding.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/testing.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/testing.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/testing.pyo
+%%PYTHON_SITELIBDIR%%/GChartWrapper/tests.py
+%%PYTHON_SITELIBDIR%%/GChartWrapper/tests.pyc
+%%PYTHON_SITELIBDIR%%/GChartWrapper/tests.pyo
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Axes-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Bubble-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Dict-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.GChart-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.HorizontalBarGroup-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.HorizontalBarStack-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Line-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.LineXY-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Map-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Meter-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Note-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Pie-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Pie3D-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.PieC-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Pin-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.QRCode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Radar-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Scatter-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Sparkline-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Text-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.Venn-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.VerticalBarGroup-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.GChart'.VerticalBarStack-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.AttrNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.BubbleNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.ChartNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.FancyNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.GenericNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.NoteNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.PinNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.templatetags.charts.TextNode-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.views-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.charts.views-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.constants-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.constants-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.encoding-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.encoding-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.encoding.Encoder-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.jinja2-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.jinja2-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.jinja2.ChartExtension-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.mako-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.mako-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.testing-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.testing-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.testing.TestClass-class.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.tests-module.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.tests-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/GChartWrapper.tests.ChartsTest-class.html
+%%PORTDOCS%%%%DOCSDIR%%/UserDict.UserDict-class.html
+%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
+%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/crarr.png
+%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
+%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
+%%PORTDOCS%%%%DOCSDIR%%/exceptions.AssertionError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/frames.html
+%%PORTDOCS%%%%DOCSDIR%%/help.html
+%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/redirect.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.GChart'-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.charts-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.charts.templatetags-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.charts.templatetags.charts-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.charts.views-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.constants-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.encoding-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.jinja2-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.mako-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.testing-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-GChartWrapper.tests-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-everything.html
+%%PORTDOCS%%%%DOCSDIR%%/toc-urllib-module.html
+%%PORTDOCS%%%%DOCSDIR%%/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib-module.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib-pysrc.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.ContentTooShortError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.FancyURLopener-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.URLopener-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.addbase-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.addclosehook-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.addinfo-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.addinfourl-class.html
+%%PORTDOCS%%%%DOCSDIR%%/urllib.ftpwrapper-class.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cheetah_templates.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/__init__.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/manage.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/settings.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/.svn/all-wcprops
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/.svn/dir-prop-base
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/.svn/entries
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/.svn/format
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/.svn/text-base/example.html.svn-base
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/templates/example.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/urls.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/djangoproj/views.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jinja_templates.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mako_templates.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/djangoproj/templates/.svn/text-base
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/djangoproj/templates/.svn
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/djangoproj/templates
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/djangoproj
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/GChartWrapper/charts/templatetags
+@dirrm %%PYTHON_SITELIBDIR%%/GChartWrapper/charts
+@dirrm %%PYTHON_SITELIBDIR%%/GChartWrapper