aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-gd
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-12-22 13:11:19 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-12-22 13:11:19 +0000
commitfa59bd18c73a506c3ed2fe96b25811ca4b0b8ddd (patch)
tree6a64c0b2f633cab3688d4b1929cdbc9b959bc9a4 /graphics/py-gd
parent3a98a72ae61f35813cdf427a5408fec87a724181 (diff)
downloadports-fa59bd18c73a506c3ed2fe96b25811ca4b0b8ddd.tar.gz
ports-fa59bd18c73a506c3ed2fe96b25811ca4b0b8ddd.zip
Notes
Diffstat (limited to 'graphics/py-gd')
-rw-r--r--graphics/py-gd/Makefile44
-rw-r--r--graphics/py-gd/distinfo1
-rw-r--r--graphics/py-gd/pkg-comment1
-rw-r--r--graphics/py-gd/pkg-descr4
-rw-r--r--graphics/py-gd/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
new file mode 100644
index 000000000000..46aa621cc79c
--- /dev/null
+++ b/graphics/py-gd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: py-gd
+# Date created: 23 December 2001
+# Whom: Hye-Shik Chang <perky@fallin.lv>
+#
+# $FreeBSD$
+
+PORTNAME= gd
+PORTVERSION= 0.26
+CATEGORIES= graphics python
+MASTER_SITES= http://newcenturycomputers.net/projects/download.cgi/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= gdmodule-${PORTVERSION}
+
+MAINTAINER= perky@fallin.lv
+
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
+ ttf.4:${PORTSDIR}/print/freetype
+
+USE_PYTHON= yes
+EXCMD= /usr/bin/ex
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g} \
+ EXAMPLE_DIR=${EXAMPLE_DIR:S,^${PREFIX}/,,g}
+EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+.if !defined(WITHOUT_X11)
+USE_XPM= yes
+.endif
+
+post-patch:
+ ${EXCMD} -c 's,^\(gd.*\)$$,\1 -I${PREFIX}/include/gd,g|wq!' ${WRKSRC}/Setup
+.if defined(WITHOUT_X11)
+ ${EXCMD} -c 's,-lX11 -lXpm,,g|wq!' ${WRKSRC}/Setup
+.endif
+
+pre-build:
+ cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLE_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/gddemo.py ${EXAMPLE_DIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gd/distinfo b/graphics/py-gd/distinfo
new file mode 100644
index 000000000000..41a5d0ce2ae0
--- /dev/null
+++ b/graphics/py-gd/distinfo
@@ -0,0 +1 @@
+MD5 (gdmodule-0.26.tar.gz) = fc171fa4cab20a73b8c4d073c2f753f4
diff --git a/graphics/py-gd/pkg-comment b/graphics/py-gd/pkg-comment
new file mode 100644
index 000000000000..7f84f9399386
--- /dev/null
+++ b/graphics/py-gd/pkg-comment
@@ -0,0 +1 @@
+Python interface to the GD library
diff --git a/graphics/py-gd/pkg-descr b/graphics/py-gd/pkg-descr
new file mode 100644
index 000000000000..fcc5d586b11f
--- /dev/null
+++ b/graphics/py-gd/pkg-descr
@@ -0,0 +1,4 @@
+GD module is an interface to the GD library written by Thomas Bouttel.
+It has been extended in some ways from the original GD library.
+
+WWW: http://newcenturycomputers.net/projects/gdmodule.html
diff --git a/graphics/py-gd/pkg-plist b/graphics/py-gd/pkg-plist
new file mode 100644
index 000000000000..ec5ea608efd4
--- /dev/null
+++ b/graphics/py-gd/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/gdmodule.so
+%%PORTDOCS%%%%EXAMPLE_DIR%%/gddemo.py
+%%PORTDOCS%%@dirrm %%EXAMPLE_DIR%%