aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-gd
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
commit797bc0968f6c141c034212ff2d71f0d1f5e35194 (patch)
treeae9f52a6cc5a1541ffff20edd302bcbcb336a823 /graphics/py-gd
parent5fdaa85b0d76467676b8f9a6cb38497c8fb02688 (diff)
downloadports-797bc0968f6c141c034212ff2d71f0d1f5e35194.tar.gz
ports-797bc0968f6c141c034212ff2d71f0d1f5e35194.zip
Notes
Diffstat (limited to 'graphics/py-gd')
-rw-r--r--graphics/py-gd/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
index 1fb2887e7c61..cd248ee180ff 100644
--- a/graphics/py-gd/Makefile
+++ b/graphics/py-gd/Makefile
@@ -24,11 +24,22 @@ EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
USE_XPM= yes
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,^(gd.*)$$,\1 -I${LOCALBASE}/include/gd -L${LOCALBASE}/lib,g; s,-lttf,,g; s,/usr/X11R6,${X11BASE},g;' \
${WRKSRC}/Setup
+.else
+ ${SED} -i.orig -e 's,^\(gd.*\)$$,\1 -I${LOCALBASE}/include/gd -L${LOCALBASE}/lib,g' \
+ -e 's,-lttf,,g' -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/Setup
+.endif
.if defined(WITHOUT_X11)
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,-lX11 -lXpm,,g' ${WRKSRC}/Setup
+.else
+ ${SED} -i "" -e 's,-lX11 -lXpm,,g' ${WRKSRC}/Setup
+.endif
.endif
pre-build:
@@ -40,4 +51,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/gddemo.py ${EXAMPLE_DIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>