aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-gdchart2
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-30 18:01:33 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-30 18:01:33 +0000
commitfa21d7ef52e286becd403d36fb265b7f77446459 (patch)
treeb328ebf7b78d8adedef4e8b38cdca5a0069a27f8 /graphics/py-gdchart2
parenta88276f01d4575afcf6c4b571d5022f213337654 (diff)
downloadports-fa21d7ef52e286becd403d36fb265b7f77446459.tar.gz
ports-fa21d7ef52e286becd403d36fb265b7f77446459.zip
Notes
Diffstat (limited to 'graphics/py-gdchart2')
-rw-r--r--graphics/py-gdchart2/Makefile29
-rw-r--r--graphics/py-gdchart2/distinfo2
-rw-r--r--graphics/py-gdchart2/files/patch-setup.py15
-rw-r--r--graphics/py-gdchart2/pkg-descr5
-rw-r--r--graphics/py-gdchart2/pkg-plist5
5 files changed, 56 insertions, 0 deletions
diff --git a/graphics/py-gdchart2/Makefile b/graphics/py-gdchart2/Makefile
new file mode 100644
index 000000000000..2f6c27bdf3ae
--- /dev/null
+++ b/graphics/py-gdchart2/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-gdchart2
+# Date created: 2005-06-30
+# Whom: Choe, Cheng-Dae <whitekid@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdchart
+DISTVERSION= 2.0-beta1
+CATEGORIES= graphics python
+MASTER_SITES= http://www.nullcube.com/software/pygdchart2/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pygdchart2
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Python interface to GDChart2
+
+LIB_DEPENDS= gdc.1:${PORTSDIR}/graphics/gdchart
+
+CONFLICTS= ${PYTHON_PKGNAMEPREFIX}gdchart-0.*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gdchart2/distinfo b/graphics/py-gdchart2/distinfo
new file mode 100644
index 000000000000..5a65ad44172c
--- /dev/null
+++ b/graphics/py-gdchart2/distinfo
@@ -0,0 +1,2 @@
+MD5 (pygdchart2.tar.gz) = 9beabe40589d5e567ee090602e4e8336
+SIZE (pygdchart2.tar.gz) = 1947995
diff --git a/graphics/py-gdchart2/files/patch-setup.py b/graphics/py-gdchart2/files/patch-setup.py
new file mode 100644
index 000000000000..673ac1c27202
--- /dev/null
+++ b/graphics/py-gdchart2/files/patch-setup.py
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- setup.py.orig
++++ setup.py
+@@ -1,7 +1,7 @@
+ from distutils.core import setup, Extension
+
+-GDCHART_PATH = "../gdchart0.11.4dev"
+-GD_PATH = "../gd-1.8.4"
++GDCHART_PATH = "%%LOCALBASE%%/include"
++GD_PATH = "%%LOCALBASE%%/lib"
+ setup(
+ name="pygdchart",
+ version="2.0 Beta",
diff --git a/graphics/py-gdchart2/pkg-descr b/graphics/py-gdchart2/pkg-descr
new file mode 100644
index 000000000000..7f52e3033caa
--- /dev/null
+++ b/graphics/py-gdchart2/pkg-descr
@@ -0,0 +1,5 @@
+This is a simple python interface to gdchart which is
+excellent for creating charts and graphs in PNG, JPEG,
+and GIF format.
+
+WWW: http://www.nullcube.com/software/pygdchart2.html
diff --git a/graphics/py-gdchart2/pkg-plist b/graphics/py-gdchart2/pkg-plist
new file mode 100644
index 000000000000..9e7441744d15
--- /dev/null
+++ b/graphics/py-gdchart2/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/gdchart.py
+%%PYTHON_SITELIBDIR%%/_gdchartc.so
+%%PYTHON_SITELIBDIR%%/gdchart.pyc
+%%PYTHON_SITELIBDIR%%/gdchart.pyo