aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-glooey
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-03-20 22:45:05 +0000
committerDiane Bruce <db@FreeBSD.org>2020-03-20 22:45:05 +0000
commit34c7101ea5ac9aeedf7706ceb3f9659230516494 (patch)
tree54dcf5a0ca42c02eebd38a0628ca338308aa2767 /graphics/py-glooey
parenta82adc010b5c9ccfac5fc44e5aafd07faf20f522 (diff)
downloadports-34c7101ea5ac9aeedf7706ceb3f9659230516494.tar.gz
ports-34c7101ea5ac9aeedf7706ceb3f9659230516494.zip
Notes
Diffstat (limited to 'graphics/py-glooey')
-rw-r--r--graphics/py-glooey/Makefile26
-rw-r--r--graphics/py-glooey/distinfo3
-rw-r--r--graphics/py-glooey/pkg-descr20
3 files changed, 49 insertions, 0 deletions
diff --git a/graphics/py-glooey/Makefile b/graphics/py-glooey/Makefile
new file mode 100644
index 000000000000..92f0a718baaa
--- /dev/null
+++ b/graphics/py-glooey/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= glooey
+PORTVERSION= 0.3.0
+CATEGORIES= graphics x11-toolkits python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= Cross-platform windowing and multimedia library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyglet>0:graphics/py-pyglet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vecrec>0:graphics/py-vecrec@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}autoprop>0:devel/py-autoprop@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}debugtools>0:devel/py-debugtools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-glooey/distinfo b/graphics/py-glooey/distinfo
new file mode 100644
index 000000000000..9ae2971f5d04
--- /dev/null
+++ b/graphics/py-glooey/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584708926
+SHA256 (glooey-0.3.0.tar.gz) = dc2e2d6775b5114a0daa03887687e1cdb85219133be501bc0dd7bcb7d8b9ae52
+SIZE (glooey-0.3.0.tar.gz) = 13511446
diff --git a/graphics/py-glooey/pkg-descr b/graphics/py-glooey/pkg-descr
new file mode 100644
index 000000000000..b1f083d272bf
--- /dev/null
+++ b/graphics/py-glooey/pkg-descr
@@ -0,0 +1,20 @@
+Every game needs a user interface that matches its look and feel. The purpose
+of glooey is to help you make such an interface. Towards this end, glooey
+provides 7 powerful placement widgets, a label widget, an image widget,
+3 different button widgets, a text entry widget, a variety of scroll boxes
+and bars, 4 different dialog box widgets, and a variety of other miscellaneous
+widgets. The appearance of any widget can be trivially customized, and
+glooey comes with built-in fantasy, puzzle, and 8-bit themes to prove it
+(and to help you hit the ground running if your game fits one of those genres).
+
+The philosophy behind glooey is that deriving subclasses from a basic set of
+widgets with no default style is the most elegant way to control how
+widgets look. This approach is flexible because subclasses can customize or
+override most aspects of the basic widgets. But it's also surprisingly
+succinct and powerful: specifying a style is usually as simple as setting
+a class variable, and styles can be easily composed using either inner
+classes or previously defined widgets. This philosophy makes glooey easy
+to get started with, and powerful enough to support even the most
+complicated games.
+
+WWW: https://pypi.org/project/glooey