aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graph-core/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:16:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-05 14:16:41 +0000
commite5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c (patch)
tree988c54f8379f3c8aa94a59b5aad09652967cb28b /graphics/py-graph-core/Makefile
parentd6dc2addd21df5c03c224921af6ff1c18f89e667 (diff)
downloadports-e5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c.tar.gz
ports-e5deafa8f4d5a25cdaae1d4b83dbcbeb1e46c84c.zip
Notes
Diffstat (limited to 'graphics/py-graph-core/Makefile')
-rw-r--r--graphics/py-graph-core/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/graphics/py-graph-core/Makefile b/graphics/py-graph-core/Makefile
new file mode 100644
index 000000000000..7b97ab81a0a9
--- /dev/null
+++ b/graphics/py-graph-core/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: py-graph
+# Date created: 2008-08-29
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graph
+PORTVERSION= 1.0.0
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-graph-${PORTVERSION}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= A library for working with graphs in Python
+
+BUILD_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+
+PROJECTHOST= python-graph
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-graph
+
+WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
+
+USE_BZIP2= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>