aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graph-core
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2010-05-12 13:39:30 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2010-05-12 13:39:30 +0000
commit7eb81e0db9b476cf083e4ab4e26ab550b9eca671 (patch)
treed9549ccedd4fdac5e7fa855e8a47150447f5c945 /graphics/py-graph-core
parent336f38fdca2dea308c5b05b2a2ede66d2e5ba276 (diff)
downloadports-7eb81e0db9b476cf083e4ab4e26ab550b9eca671.tar.gz
ports-7eb81e0db9b476cf083e4ab4e26ab550b9eca671.zip
Notes
Diffstat (limited to 'graphics/py-graph-core')
-rw-r--r--graphics/py-graph-core/Makefile53
-rw-r--r--graphics/py-graph-core/distinfo6
-rw-r--r--graphics/py-graph-core/files/patch-setup.py21
-rw-r--r--graphics/py-graph-core/pkg-plist64
4 files changed, 17 insertions, 127 deletions
diff --git a/graphics/py-graph-core/Makefile b/graphics/py-graph-core/Makefile
index 051162d32686..174d89dc53a0 100644
--- a/graphics/py-graph-core/Makefile
+++ b/graphics/py-graph-core/Makefile
@@ -5,60 +5,21 @@
# $FreeBSD$
#
-PORTNAME= graph
-PORTVERSION= 1.6.1
-PORTREVISION= 2
+PORTNAME= graph-core
+PORTVERSION= 1.7.0
CATEGORIES= graphics python
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= python-graph-${PORTVERSION}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= yzlin@FreeBSD.org
-COMMENT= A library for working with graphs in Python
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydot>=0:${PORTSDIR}/graphics/py-pydot
+COMMENT= A library for working with graphs in Python, core module
PROJECTHOST= python-graph
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= python_graph
-
-USE_BZIP2= yes
-
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
-
-TESTFILES= unittests-accessibility.py \
- unittests-cycles.py \
- unittests-digraph.py \
- unittests-filters.py \
- unittests-graph.py \
- unittests-heuristics.py \
- unittests-readwrite.py \
- unittests-searching.py \
- unittests-sorting.py \
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in COPYING Changelog README
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+PYDISTUTILS_PKGNAME= python_graph_core
-# This target is only meant to be used by the port maintainer.
-x-regression-test: install
-.for f in ${TESTFILES}
- @${ECHO} "" >> ${WRKSRC}/tests/${f}
- @${ECHO} "if __name__ == '__main__':" >> ${WRKSRC}/tests/${f}
- @${ECHO} " unittest.main()" >> ${WRKSRC}/tests/${f}
- @${ECHO} "Unit-testing ${f}..."
- @(cd ${WRKSRC}/tests && ${PYTHON_CMD} ${f})
-.endfor
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>
diff --git a/graphics/py-graph-core/distinfo b/graphics/py-graph-core/distinfo
index 23e589b9ce49..29cfa0830b0f 100644
--- a/graphics/py-graph-core/distinfo
+++ b/graphics/py-graph-core/distinfo
@@ -1,3 +1,3 @@
-MD5 (python-graph-1.6.1.tar.bz2) = 4c52cb006e139e7578f9bdf2338d166d
-SHA256 (python-graph-1.6.1.tar.bz2) = 33279db94653f83ba58c3cc114b99c55d9fbd187caeff2c8998e95a36c02487a
-SIZE (python-graph-1.6.1.tar.bz2) = 54402
+MD5 (python-graph-core-1.7.0.tar.gz) = 6f18340e4ed8ba0f5ae13ffcb7bf6b96
+SHA256 (python-graph-core-1.7.0.tar.gz) = 1e7108441161e5eb6aae3dd5219408305998172879793f606d54c796580bb47a
+SIZE (python-graph-core-1.7.0.tar.gz) = 25472
diff --git a/graphics/py-graph-core/files/patch-setup.py b/graphics/py-graph-core/files/patch-setup.py
index 89d543f758fd..6493e52e6717 100644
--- a/graphics/py-graph-core/files/patch-setup.py
+++ b/graphics/py-graph-core/files/patch-setup.py
@@ -1,26 +1,19 @@
+
+$FreeBSD$
+
--- setup.py.orig
+++ setup.py
-@@ -4,12 +4,7 @@
+@@ -3,12 +3,7 @@
+
import os
- import logging
-try:
- from setuptools import setup, find_packages
--except ImportError, ie:
+-except ImportError as ie:
- import ez_setup
- ez_setup.use_setuptools()
- from setuptools import setup, find_packages
+from setuptools import setup, find_packages
# Startup
- appname = "python-graph"
-@@ -40,9 +35,6 @@
- name = appname,
- version = appversion,
- packages = ['pygraph', 'pygraph.algorithms', 'pygraph.algorithms.filters', 'pygraph.algorithms.heuristics', 'pygraph.classes', 'pygraph.readwrite'],
-- data_files = [(docsdir,docsfiles),
-- (datadir,datafiles)],
-- install_requires = ['pydot'],
- author = "Pedro Matiello",
- author_email = "pmatiello@gmail.com",
- description = "A library for working with graphs in Python",
+ appname = "python-graph-core"
diff --git a/graphics/py-graph-core/pkg-plist b/graphics/py-graph-core/pkg-plist
deleted file mode 100644
index 13223b5f9c46..000000000000
--- a/graphics/py-graph-core/pkg-plist
+++ /dev/null
@@ -1,64 +0,0 @@
-%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/critical.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/draw.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawhyper.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ex1.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tls
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graph.xml
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lts2graph.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write.py
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/Changelog
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/api-objects.txt
-%%PORTDOCS%%%%DOCSDIR%%/class-tree.html
-%%PORTDOCS%%%%DOCSDIR%%/crarr.png
-%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
-%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
-%%PORTDOCS%%%%DOCSDIR%%/help.html
-%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.accessibility-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.critical-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.cycles-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Find-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Find.find-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Null-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Null.null-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Radius-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Radius.radius-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.generators-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Chow-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Chow.chow-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Euclidean-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Euclidean.euclidean-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.minmax-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.searching-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.sorting-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.traversal-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils.HeapItem-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils.priority_queue-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Digraph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Digraph.digraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.GraphError-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.InvalidGraphType-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.NodeUnreachable-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Graph.graph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Hypergraph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Hypergraph.hypergraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite.dot-module.html
-%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite.markup-module.html
-%%PORTDOCS%%%%DOCSDIR%%/redirect.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%