aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graphy
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2014-05-10 00:37:43 +0000
committerSahil Tandon <sahil@FreeBSD.org>2014-05-10 00:37:43 +0000
commit4688477405de84fac72f45d3d86cf3863aaaea9d (patch)
treec40b2a28ac545e5535cb60dfd51a80e7e27cc2ce /graphics/py-graphy
parent2eba7789cfdc91f310774946b2eeb67138442774 (diff)
downloadports-4688477405de84fac72f45d3d86cf3863aaaea9d.tar.gz
ports-4688477405de84fac72f45d3d86cf3863aaaea9d.zip
Notes
Diffstat (limited to 'graphics/py-graphy')
-rw-r--r--graphics/py-graphy/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/graphics/py-graphy/Makefile b/graphics/py-graphy/Makefile
index ccab38330938..9222b07d5147 100644
--- a/graphics/py-graphy/Makefile
+++ b/graphics/py-graphy/Makefile
@@ -9,7 +9,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= sahil@FreeBSD.org
-COMMENT= A simple chart library for Python
+COMMENT= Simple chart library for Python
USE_BZIP2= yes
USE_PYTHON_RUN= yes
@@ -20,7 +20,6 @@ PORTEXAMPLES= *
NO_BUILD= yes
NO_INSTALL_MANPAGES= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -31,16 +30,16 @@ post-patch:
${XARGS} ${RM} -rf
do-install:
- @${MKDIR} ${PYTHON_SITELIBDIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}
@(cd ${WRKSRC}/${PORTNAME}/ && \
- ${COPYTREE_SHARE} \* ${PYTHON_SITELIBDIR}/${PORTNAME})
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME})
.if !defined(NOPORTDOCS)
- @${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+ @${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- @${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 555 -d ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+ @${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 555 -d ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.endif
.include <bsd.port.post.mk>