aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imageio
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2016-07-13 02:56:49 +0000
committerKevin Lo <kevlo@FreeBSD.org>2016-07-13 02:56:49 +0000
commit0c263560fd7ffec99c44d0c743c3f57d4239bbd6 (patch)
treea44bc8077c0280b3b22f5e316b09e33234a70da6 /graphics/py-imageio
parentfb4f990a8adc0a6a6b9deddeba0ca59b51bdc9f6 (diff)
Notes
Diffstat (limited to 'graphics/py-imageio')
-rw-r--r--graphics/py-imageio/Makefile24
-rw-r--r--graphics/py-imageio/distinfo3
-rw-r--r--graphics/py-imageio/pkg-descr5
3 files changed, 32 insertions, 0 deletions
diff --git a/graphics/py-imageio/Makefile b/graphics/py-imageio/Makefile
new file mode 100644
index 000000000000..9bcd269b4006
--- /dev/null
+++ b/graphics/py-imageio/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= imageio
+PORTVERSION= 1.5
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Python library for reading and writing image, video formats
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfreeimage.so:graphics/freeimage
+RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
+ ${PYNUMPY}
+
+USES= python zip
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-imageio/distinfo b/graphics/py-imageio/distinfo
new file mode 100644
index 000000000000..bbdb9403abdb
--- /dev/null
+++ b/graphics/py-imageio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468312984
+SHA256 (imageio-1.5.zip) = 37ab7ad6ca37905cee6b3535a0dba21506647d663b4414089b85b20e2b9f985d
+SIZE (imageio-1.5.zip) = 3269874
diff --git a/graphics/py-imageio/pkg-descr b/graphics/py-imageio/pkg-descr
new file mode 100644
index 000000000000..f09381977758
--- /dev/null
+++ b/graphics/py-imageio/pkg-descr
@@ -0,0 +1,5 @@
+Imageio is a Python library that provides an easy interface to read and
+write a wide range of image data, including animated images, volumetric data,
+and scientific formats.
+
+WWW: http://imageio.github.io/