aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imaging/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-11-05 08:02:39 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-11-05 08:02:39 +0000
commit8f20f01502d268605de1af00313876e397fd78bd (patch)
tree78ce8085a5bc4492f51af8555c2925a562df6030 /graphics/py-imaging/Makefile
parentdc1bbf6ac4ee11b6861003cf0783e156e88a51bb (diff)
Notes
Diffstat (limited to 'graphics/py-imaging/Makefile')
-rw-r--r--graphics/py-imaging/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
new file mode 100644
index 000000000000..a2d5c0502608
--- /dev/null
+++ b/graphics/py-imaging/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: PIL
+# Version required: 0.3b2
+# Date created: 02 November 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= Imaging-0.3b2
+PKGNAME= py-imaging-0.3b2
+CATEGORIES= graphics python
+MASTER_SITES= http://www.pythonware.com/downloads/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} pyth151.tgz
+
+MAINTAINER= tg@FreeBSD.ORG
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+DIST_SUBDIR= python
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+WRKSRC= ${WRKDIR}/${DISTNAME}/libImaging
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jpeg=${PREFIX}/lib
+MAKE_FLAGS= OPT="${CFLAGS}"
+
+PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
+PILDIR= ${PYTHONSCRIPTDIR}/site-packages/PIL
+PILDOCDIR= ${PREFIX}/share/doc/PIL
+PILEXDIR= ${PREFIX}/share/examples/PIL
+TKINTERORIG= ${PYTHONSCRIPTDIR}/lib-dynload/_tkinter.so
+
+post-extract:
+ @(cd ${WRKDIR}; ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/pyth151.tgz \
+ Python-1.5.1/Modules/_tkinter.c Python-1.5.1/Modules/tkappinit.c)
+ @${MV} ${WRKDIR}/Python-1.5.1/Modules/* ${WRKSRC}/..
+ @${CP} ${FILESDIR}/Setup ${WRKSRC}/..
+
+post-configure:
+ @(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} -f Makefile.pre.in boot)
+
+post-build:
+ @(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} sharedmods)
+
+do-install:
+ if test -f ${TKINTERORIG}; then \
+ ${MV} ${TKINTERORIG} ${TKINTERORIG}.save; \
+ else true; \
+ fi
+ @(cd ${WRKSRC}/..; ${SETENV} ${MAKE_ENV} ${MAKE} install)
+ @${MKDIR} ${PILDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../PIL/* ${PILDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../PIL.pth ${PILDIR}/..
+ @${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${PILDIR}
+ @${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${PILDIR}
+ @${MKDIR} ${PILDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../README ${PILDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../FORMATS ${PILDOCDIR}
+ @${MKDIR} ${PILEXDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../Scripts/* ${PILEXDIR}
+
+.include <bsd.port.mk>