aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imaging
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-23 02:35:26 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-23 02:35:26 +0000
commitacbbee2bc7634b209abf38ef09ce1f48197a4fe4 (patch)
tree989dd8e1b1e6c8900e5268efdd3d75a25a3b7268 /graphics/py-imaging
parent70cb44a9d71c560e2e4ab944c63d47e386b5f5a1 (diff)
downloadports-acbbee2bc7634b209abf38ef09ce1f48197a4fe4.tar.gz
ports-acbbee2bc7634b209abf38ef09ce1f48197a4fe4.zip
Notes
Diffstat (limited to 'graphics/py-imaging')
-rw-r--r--graphics/py-imaging/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
index 01eff39fde37..05675b900cf6 100644
--- a/graphics/py-imaging/Makefile
+++ b/graphics/py-imaging/Makefile
@@ -30,11 +30,14 @@ PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-OPTIONS= TKINTER "Build with tkinter for X support" on
+OPTIONS_DEFINE= TKINTER
+TKINTER_DESC= tkinter for X support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= TKINTER
-.if !defined(WITHOUT_TKINTER)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTKINTER}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
PLIST_SUB+= TKINTER=""
@@ -42,7 +45,7 @@ PLIST_SUB+= TKINTER=""
PLIST_SUB+= TKINTER="@comment "
.endif
-.if defined(WITHOUT_TKINTER)
+.if ! ${PORT_OPTIONS:MTKINTER}
post-patch:
@${REINPLACE_CMD} -e 's|if _tkinter|if None|g' ${WRKSRC}/setup.py
.endif
@@ -53,9 +56,9 @@ post-install:
.endfor
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Scripts/* ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>