aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-ming/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
commit66acb9cd06907030a13dd56c90708c4cf4861f92 (patch)
tree1b86710ecc3bb60c1a702a6e49a3b7540d0959a4 /graphics/py-ming/Makefile
parent24ebd4cbfc87f39b6d0e861ecc2b1ddf6ef5ac2e (diff)
downloadports-66acb9cd06907030a13dd56c90708c4cf4861f92.tar.gz
ports-66acb9cd06907030a13dd56c90708c4cf4861f92.zip
Notes
Diffstat (limited to 'graphics/py-ming/Makefile')
-rw-r--r--graphics/py-ming/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 5713bd1ae03e..3457cb4ba2bb 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
-PORTREVISION= 1
+PORTVERSION= 0.0.9b
CATEGORIES= graphics python
MASTER_SITES= http://www.opaque.net/ming/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,23 +14,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ${SWIG}:${PORTSDIR}/devel/SWIG-devel
-LIB_DEPENDS= ming.1:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.2:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
-MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
+MD5_FILE= ${.CURDIR}/../ming/distinfo
WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
-MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}" SWIG="${SWIG}"
+MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
-SWIG= swig1.3
-
-EXAMPLES= shape.py test.py
+EXAMPLES= shape.py test.py ../examples/python/*.py
post-extract:
${LN} -sf ../ming.i ${WRKSRC}/
+post-patch:
+ ${PERL} -i -p \
+ -e 's:\.\./common:../../ming/common:g;' \
+ ${WRKSRC}/../examples/python/*
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/${PYTHON_VERSION}/ming