aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-ming
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-18 18:56:39 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-18 18:56:39 +0000
commitd595c88d0b21b9de24a7a4bcd66b9c75625d2efd (patch)
tree28e577663afdf9fc97d9e6707a50a209103f338f /graphics/py-ming
parenta8422448a85510214cf43630283d67bac8707bf0 (diff)
downloadports-d595c88d0b21b9de24a7a4bcd66b9c75625d2efd.tar.gz
ports-d595c88d0b21b9de24a7a4bcd66b9c75625d2efd.zip
Notes
Diffstat (limited to 'graphics/py-ming')
-rw-r--r--graphics/py-ming/Makefile41
-rw-r--r--graphics/py-ming/distinfo3
-rw-r--r--graphics/py-ming/files/patch-Makefile35
-rw-r--r--graphics/py-ming/pkg-plist30
4 files changed, 19 insertions, 90 deletions
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 77fba715e1db..f3b0d9563fb4 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -6,46 +6,25 @@
#
PORTNAME= ming
-PORTVERSION= 0.2a
+PORTVERSION= 0.3.0
CATEGORIES= graphics python
-MASTER_SITES= # none
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= # none
+DISTNAME= ${PORTNAME}-py-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python module for Ming which allows you to create Flash 4/5 movies
-EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/ming:patch
-LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.4:${PORTSDIR}/graphics/ming
-USE_PYTHON= yes
-USE_PERL5_BUILD=yes
-
-MD5_FILE= ${.CURDIR}/../ming/distinfo
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/py_ext
-MAKE_ARGS= PYTHON_VERSION="${PYTHON_VERSION}"
-
-EXAMPLES= ../examples/python/*.py
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/py_ext
-do-extract:
- ${MKDIR} ${WRKDIR}
- ${LN} -s `cd ${PORTSDIR}/graphics/ming && ${MAKE} -V WRKDIR`/* ${WRKDIR}/
-
-post-extract:
- ${LN} -sf ../ming.i ${WRKSRC}/
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
post-patch:
- ${PERL} -i -p \
- -e 's:\.\./common:../../ming/common:g;' \
- ${WRKSRC}/../examples/python/*
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/${PYTHON_VERSION}/ming
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/${PYTHON_VERSION}/ming/
-.endfor
-.endif
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/setup.py
+ @${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/../src
.include <bsd.port.mk>
diff --git a/graphics/py-ming/distinfo b/graphics/py-ming/distinfo
new file mode 100644
index 000000000000..71627ea15f37
--- /dev/null
+++ b/graphics/py-ming/distinfo
@@ -0,0 +1,3 @@
+MD5 (ming-py-0.3.0.tar.gz) = 96d3f42f13d020d907287a640b39ec46
+SHA256 (ming-py-0.3.0.tar.gz) = 507abbfa394bcbe22f3f8eee936b5f8048c957b2b7a2543cfacc00cf68a4c075
+SIZE (ming-py-0.3.0.tar.gz) = 35658
diff --git a/graphics/py-ming/files/patch-Makefile b/graphics/py-ming/files/patch-Makefile
deleted file mode 100644
index 93d22f947949..000000000000
--- a/graphics/py-ming/files/patch-Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
---- Makefile.orig Sat Aug 18 02:05:55 2001
-+++ Makefile Tue Sep 18 14:44:34 2001
-@@ -1,13 +1,13 @@
--PYINCDIR = /usr/local/include/python2.0
--PYLIBDIR = /usr/local/lib/python2.0
-+PYINCDIR = ${LOCALBASE}/include/${PYTHON_VERSION}
-+PYLIBDIR = ${LOCALBASE}/lib/${PYTHON_VERSION}
-
- #PYINCDIR = /usr/include/python1.5
- #PYLIBDIR = /usr/lib/python1.5
-
--all:
-+all: mingcmodule.so
-
- mingcmodule.so: ming_wrap.o
-- gcc -g -Wall -shared -o mingcmodule.so ming_wrap.o -lming
-+ ${CC} -g -Wall -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
-
- mingc.pyd: ming_wrap.o
- dllwrap --dllname mingc.pyd --driver-name gcc --def mingc.def \
-@@ -15,7 +15,7 @@
- --target=i386-mingw32 -Llib/ -lpython15
-
- ming_wrap.o: ming_wrap.c
-- gcc -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
-+ ${CC} ${CFLAGS} -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
-
- ../libming.a:
- cd ..; make static
-@@ -27,4 +27,4 @@
- rm -f mingcmodule.so core *~ *.o ming.pyc
-
- install:
-- cp mingcmodule.so ming.py ${PYLIBDIR}/site-packages
-+ ${BSD_INSTALL_DATA} mingcmodule.so ming.py ${PYLIBDIR}/site-packages
diff --git a/graphics/py-ming/pkg-plist b/graphics/py-ming/pkg-plist
index aee52f009f22..cb96e6f544ad 100644
--- a/graphics/py-ming/pkg-plist
+++ b/graphics/py-ming/pkg-plist
@@ -1,25 +1,7 @@
-lib/%%PYTHON_VERSION%%/site-packages/mingcmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/_mingc.so
lib/%%PYTHON_VERSION%%/site-packages/ming.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/action.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/alphafill.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/animation.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/bitmapxform.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/button.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/cxform.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/drag.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/glyph.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/gradient.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/gradientxform.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/jpegfill.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/keypress.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/morph.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/mousetrack.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/newbutton.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/png.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/pngalpha.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/shape.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/sprite.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/streammp3.py
-%%PORTDOCS%%share/examples/%%PYTHON_VERSION%%/ming/text.py
-%%PORTDOCS%%@dirrm share/examples/%%PYTHON_VERSION%%/ming
-%%PORTDOCS%%@unexec rmdir %D/share/examples/%%PYTHON_VERSION%% 2>/dev/null || true
+lib/%%PYTHON_VERSION%%/site-packages/ming.pyc
+lib/%%PYTHON_VERSION%%/site-packages/ming.pyo
+lib/%%PYTHON_VERSION%%/site-packages/mingc.py
+lib/%%PYTHON_VERSION%%/site-packages/mingc.pyc
+lib/%%PYTHON_VERSION%%/site-packages/mingc.pyo