aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-01-15 18:28:17 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-01-15 18:28:17 +0000
commite6416fb341299cde44ff491d8a104e6e29e3f607 (patch)
tree5e344073f3a7c49381a5ccd5748e0bb9c3c77637 /graphics/py-opengl/Makefile
parent2679664f6a0fd40b3d6d5bc1f9d05f9fa6bf91fe (diff)
downloadports-e6416fb341299cde44ff491d8a104e6e29e3f607.tar.gz
ports-e6416fb341299cde44ff491d8a104e6e29e3f607.zip
Notes
Diffstat (limited to 'graphics/py-opengl/Makefile')
-rw-r--r--graphics/py-opengl/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index e93b95258a80..2d5c52b3ca5d 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= opengl
-PORTVERSION= 1.5.7
+PORTVERSION= 2.0.0.44
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py${PORTNAME}
@@ -17,11 +17,13 @@ MAINTAINER= sobomax@FreeBSD.org
BUILD_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging \
+ swig:${PORTSDIR}/devel/swig11
RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_MESA= yes
@@ -30,9 +32,13 @@ OSMAJOR!= /usr/bin/uname -r | sed -e 's/\..*//'
PLIST_SUB+= OSMAJOR=${OSMAJOR} \
PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
+pre-patch:
+ @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|malloc[.]h|stdlib.h|g'
+
do-configure:
@${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/config.py ${WRKSRC}/Tkinter.py
+ ${WRKSRC}/config/freebsd.cfg ${WRKSRC}/Tkinter.py
post-install:
${LOCALBASE}/bin/tclsh8.3 ${WRKSRC}/register.tcl