aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-07 16:59:55 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-07 16:59:55 +0000
commit91d41c6b521f05579c9f86faffbff3989a139d5a (patch)
tree63d50a51ee1ed224b39f7018cedb04e98b53e8c0 /graphics/py-opengl/Makefile
parenta0bf9458a352d8e8d05128db71fea6edcf06f435 (diff)
downloadports-91d41c6b521f05579c9f86faffbff3989a139d5a.tar.gz
ports-91d41c6b521f05579c9f86faffbff3989a139d5a.zip
Notes
Diffstat (limited to 'graphics/py-opengl/Makefile')
-rw-r--r--graphics/py-opengl/Makefile68
1 files changed, 68 insertions, 0 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
new file mode 100644
index 000000000000..ae645b573f04
--- /dev/null
+++ b/graphics/py-opengl/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: PyOpenGL
+# Version required: 1.5.5
+# Date created: Wed Aug 18 18:49:17 EDT 1999
+# Whom: Randall Hopper <aa8vb@ipass.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= PyOpenGL-1.5.5
+PKGNAME= py-opengl-1.5.5
+CATEGORIES= graphics python
+MASTER_SITES= http://starship.python.net/crew/da/
+
+MAINTAINER= aa8vb@ipass.net
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
+ ${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
+RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+ ${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
+LIB_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3
+
+ALL_TARGET= default
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+OSMAJOR!= /usr/bin/uname -r | sed -e 's/\..*//'
+PLIST_SUB+= OSMAJOR=${OSMAJOR}
+
+#
+# Support for Numeric is compiled in by default.
+#
+WITH_NUMERIC?= yes
+NUMPYDIR= ${LOCALBASE}/lib/python1.5/site-packages/numerical
+
+#
+# The standard setup file
+#
+SETUP_FILES= ${FILESDIR}/Setup.base
+
+#
+# Support for Togl is compiled in by default.
+#
+WITH_TOGL?= yes
+.if defined(WITH_TOGL) && $(WITH_TOGL) == yes
+SETUP_FILES+= ${FILESDIR}/Setup.add.togl
+LIB_DEPENDS+= tk80.1:${PORTSDIR}/x11-toolkits/tk80
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ ${CAT} ${SETUP_FILES} \
+ | ${SED} -e 's|X11BASE|${X11BASE}|g' \
+ -e 's|LOCALBASE|${LOCALBASE}|g' \
+ > ${WRKSRC}/Setup.proto
+
+do-build:
+ @(cd ${WRKSRC} && ${CONFIGURE_ENV} python BUILD.py)
+
+pre-install:
+ @# Remove togl.so so we don't install it; that's the Togl pkg's job
+ ${RM} -f ${WRKSRC}/togl.so
+ find ${WRKDIR} -name '*.so*' | xargs strip
+
+do-install:
+ @(cd ${WRKSRC} && ${CONFIGURE_ENV} python INSTALL.py)
+
+.include <bsd.port.post.mk>