aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-13 01:34:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-13 01:34:53 +0000
commitb550837554d13bec24ebb5ab78d95d769cc2191c (patch)
tree1ab794a2805eb5b21a52a5dbc0b05783ce63cfb8 /graphics/py-opengl/Makefile
parent4c54050fe3563e4da9efae4b74868e2598db0cdf (diff)
Notes
Diffstat (limited to 'graphics/py-opengl/Makefile')
-rw-r--r--graphics/py-opengl/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index f9ca94f87a26..62aac11b0743 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= opengl
-PORTVERSION= 2.0.0.44
+PORTVERSION= 2.0.1.07
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py${PORTNAME}
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyOpenGL-${PORTVERSION:S/.b/b/}
MAINTAINER= ports@FreeBSD.org
@@ -24,26 +24,23 @@ RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
-USE_PERL5_BUILD=yes
USE_REINPLACE= yes
+USE_GL= yes
+USE_MESA= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_MESA= yes
-OSMAJOR!= /usr/bin/uname -r | sed -e 's/\..*//'
-PLIST_SUB+= OSMAJOR=${OSMAJOR} \
- PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
-
-pre-patch:
+post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|malloc[.]h|stdlib.h|g'
- @${CP} ${WRKSRC}/src/Togl-1.5/tkInt8.3.h ${WRKSRC}/src/Togl-1.5/tkInt8.4.h
-
-do-configure:
- @${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/config/freebsd.cfg ${WRKSRC}/Tkinter.py
post-install:
- ${LOCALBASE}/bin/tclsh8.4 ${WRKSRC}/register.tcl
+ @${FIND} ${PYTHON_SITELIBDIR}/OpenGL -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/OpenGL -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>