aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-07 16:59:55 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-07 16:59:55 +0000
commit91d41c6b521f05579c9f86faffbff3989a139d5a (patch)
tree63d50a51ee1ed224b39f7018cedb04e98b53e8c0 /graphics/py-opengl
parenta0bf9458a352d8e8d05128db71fea6edcf06f435 (diff)
downloadports-91d41c6b521f05579c9f86faffbff3989a139d5a.tar.gz
ports-91d41c6b521f05579c9f86faffbff3989a139d5a.zip
Notes
Diffstat (limited to 'graphics/py-opengl')
-rw-r--r--graphics/py-opengl/Makefile68
-rw-r--r--graphics/py-opengl/distinfo1
-rw-r--r--graphics/py-opengl/files/Setup.add.togl22
-rw-r--r--graphics/py-opengl/files/Setup.base71
-rw-r--r--graphics/py-opengl/files/patch-aa11
-rw-r--r--graphics/py-opengl/pkg-comment1
-rw-r--r--graphics/py-opengl/pkg-descr27
-rw-r--r--graphics/py-opengl/pkg-plist84
8 files changed, 285 insertions, 0 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
new file mode 100644
index 000000000000..ae645b573f04
--- /dev/null
+++ b/graphics/py-opengl/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: PyOpenGL
+# Version required: 1.5.5
+# Date created: Wed Aug 18 18:49:17 EDT 1999
+# Whom: Randall Hopper <aa8vb@ipass.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= PyOpenGL-1.5.5
+PKGNAME= py-opengl-1.5.5
+CATEGORIES= graphics python
+MASTER_SITES= http://starship.python.net/crew/da/
+
+MAINTAINER= aa8vb@ipass.net
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
+ ${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
+RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+ ${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
+LIB_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3
+
+ALL_TARGET= default
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+OSMAJOR!= /usr/bin/uname -r | sed -e 's/\..*//'
+PLIST_SUB+= OSMAJOR=${OSMAJOR}
+
+#
+# Support for Numeric is compiled in by default.
+#
+WITH_NUMERIC?= yes
+NUMPYDIR= ${LOCALBASE}/lib/python1.5/site-packages/numerical
+
+#
+# The standard setup file
+#
+SETUP_FILES= ${FILESDIR}/Setup.base
+
+#
+# Support for Togl is compiled in by default.
+#
+WITH_TOGL?= yes
+.if defined(WITH_TOGL) && $(WITH_TOGL) == yes
+SETUP_FILES+= ${FILESDIR}/Setup.add.togl
+LIB_DEPENDS+= tk80.1:${PORTSDIR}/x11-toolkits/tk80
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ ${CAT} ${SETUP_FILES} \
+ | ${SED} -e 's|X11BASE|${X11BASE}|g' \
+ -e 's|LOCALBASE|${LOCALBASE}|g' \
+ > ${WRKSRC}/Setup.proto
+
+do-build:
+ @(cd ${WRKSRC} && ${CONFIGURE_ENV} python BUILD.py)
+
+pre-install:
+ @# Remove togl.so so we don't install it; that's the Togl pkg's job
+ ${RM} -f ${WRKSRC}/togl.so
+ find ${WRKDIR} -name '*.so*' | xargs strip
+
+do-install:
+ @(cd ${WRKSRC} && ${CONFIGURE_ENV} python INSTALL.py)
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-opengl/distinfo b/graphics/py-opengl/distinfo
new file mode 100644
index 000000000000..79a2dcc51e43
--- /dev/null
+++ b/graphics/py-opengl/distinfo
@@ -0,0 +1 @@
+MD5 (PyOpenGL-1.5.5.tar.gz) = 46de994e92f8eae0484b42d558bae97d
diff --git a/graphics/py-opengl/files/Setup.add.togl b/graphics/py-opengl/files/Setup.add.togl
new file mode 100644
index 000000000000..515627ecf0c3
--- /dev/null
+++ b/graphics/py-opengl/files/Setup.add.togl
@@ -0,0 +1,22 @@
+
+#
+# TOGL 1.5b3
+# This is a Tk widget module that lets PyOpenGL draw into a Tkinter window.
+# If you don't want/have togl, comment out all of the following lines
+#
+togl \
+# This must match the name of the Togl source directory
+ -I./Togl-1.5 \
+# These must match the version you have installed
+ -ILOCALBASE/include/tcl8.0 -ILOCALBASE/include/tk8.0 \
+ -LLOCALBASE/lib -ltk80 -ltcl80 \
+# You'll definitely need these (or maybe edit them for MesaGL/MesaGLU:
+ -IX11BASE/include -LX11BASE/lib \
+ -lGLU -lGL \
+# Various combinations of these depending on your platform:
+ -lX11 -lXmu -lXext -lXt \
+# If you don't have this, something is really wrong!
+ -lm \
+# for Linux only?
+# -ldl \
+togl.c # putting this at the end for \ reasons
diff --git a/graphics/py-opengl/files/Setup.base b/graphics/py-opengl/files/Setup.base
new file mode 100644
index 000000000000..307813f557e8
--- /dev/null
+++ b/graphics/py-opengl/files/Setup.base
@@ -0,0 +1,71 @@
+*shared*
+
+###
+#
+# This is the Setup file for the PyOpenGL extensions.
+#
+# It should work with OpenGL 1.0, 1.1, or the corresponding versions
+# of Mesa.
+#
+
+# This module provides most of the interfaces to the standard OpenGL API
+_opengl _openglmodule.c -IX11BASE/include -LX11BASE/lib -lGL
+
+# Some convenience functions contributed by users.
+openglutil openglutil.c -IX11BASE/include -LX11BASE/lib -lGL
+
+#
+# If you have the Numeric extensions installed, make sure the
+# following two modules are uncommented. If you don't, make sure
+# they're commented out.
+#
+# These modules provide a few more features than the two modules
+# above, and significantly more speed in some circumstances
+#
+_opengl_num _opengl_nummodule.c -DNUMERIC \
+ -ILOCALBASE/include/python1.5/numerical \
+ -IX11BASE/include -LX11BASE/lib -lGL
+
+openglutil_num openglutil_num.c -DNUMERIC \
+ -ILOCALBASE/include/python1.5/numerical \
+ -IX11BASE/include -LX11BASE/lib -lGL
+
+# The GLU utility library -- part of most standard OpenGL setups
+_glu _glumodule.c \
+ -IX11BASE/include -LX11BASE/lib -lGLU -lGL -lXext -lX11
+
+# The GLUT toolkit interface
+_glut \
+# You'll definitely need this one:
+ -lglut \
+# You'll definitely need these (or maybe edit them for MesaGL/MesaGLU:
+ -IX11BASE/include -LX11BASE/lib \
+ -lGLU -lGL \
+# Various combinations of these depending on your platform:
+ -lXi -lXmu -lXext -lX11 \
+# on SGI IRIX 6, uncomment the following
+# -lcvt \
+_glutmodule.c # putting this at the end for \ reasons
+
+
+## #
+## # TOGL 1.5b3
+## # This is a Tk widget module that lets PyOpenGL draw into a Tkinter window.
+## # If you don't want/have togl, comment out all of the following lines
+## #
+## togl \
+## # This must match the name of the Togl source directory
+## -I./Togl-1.5 \
+## # These must match the version you have installed
+## -ILOCALBASE/include/tcl8.0 -ILOCALBASE/include/tk8.0 \
+## -LLOCALBASE/lib -ltk80 -ltcl80 \
+## # You'll definitely need these (or maybe edit them for MesaGL/MesaGLU:
+## -IX11BASE/include -LX11BASE/lib \
+## -lGLU -lGL \
+## # Various combinations of these depending on your platform:
+## -lX11 -lXmu -lXext -lXt \
+## # If you don't have this, something is really wrong!
+## -lm \
+## # for Linux only?
+## # -ldl \
+## togl.c # putting this at the end for \ reasons
diff --git a/graphics/py-opengl/files/patch-aa b/graphics/py-opengl/files/patch-aa
new file mode 100644
index 000000000000..c19a89843783
--- /dev/null
+++ b/graphics/py-opengl/files/patch-aa
@@ -0,0 +1,11 @@
+--- Togl-1.5/ORIG/togl.c Fri Aug 21 23:06:00 1998
++++ Togl-1.5/togl.c Wed Aug 18 18:41:24 1999
+@@ -118,7 +118,7 @@
+ #elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==0 && TK_RELEASE_SERIAL==2
+ # include "tkInt8.0p2.h"
+ #else
+- Sorry, you will have to edit togl.c to include the right tkInt.h file
++# include "tkInt.h"
+ #endif
+ #elif defined(WIN32)
+ #if TK_MAJOR_VERSION<8
diff --git a/graphics/py-opengl/pkg-comment b/graphics/py-opengl/pkg-comment
new file mode 100644
index 000000000000..ee305fbf6d9f
--- /dev/null
+++ b/graphics/py-opengl/pkg-comment
@@ -0,0 +1 @@
+An OpenGL (and related library) interface for Python
diff --git a/graphics/py-opengl/pkg-descr b/graphics/py-opengl/pkg-descr
new file mode 100644
index 000000000000..5c8a5570df55
--- /dev/null
+++ b/graphics/py-opengl/pkg-descr
@@ -0,0 +1,27 @@
+An interface between the Python programming language and the OpenGL library
+(and related libraries).
+
+Synopsis
+
+The PyOpenGL package provides interfaces to:
+
+ - The OpenGL library itself, which is a three-dimensional graphical
+ rendering interface. For more information, visit
+ http://www.opengl.org.
+
+ - The GLU library which provides access to routines for doing
+ quadrics, tesselation etc.
+
+ - The GLUT (GL UTilitity) library from Mark Kilgard, which provides a
+ windowing environment.
+
+ - The Togl (Tk/OpenGL) widget from Brian Paul and Ben Benderson (an
+ alternative to GLUT which interfaces to Tk).
+
+The Python bindings offer some value-added tools in addition to the
+standard API, including support for fast processing of arrays of
+coordinates, trackball support, etc.
+
+The PyOpenGL web page is available at:
+
+WWW: http://starship.python.net:9673/crew/da/Code/PyOpenGL
diff --git a/graphics/py-opengl/pkg-plist b/graphics/py-opengl/pkg-plist
new file mode 100644
index 000000000000..506779854df9
--- /dev/null
+++ b/graphics/py-opengl/pkg-plist
@@ -0,0 +1,84 @@
+lib/python1.5/site-packages/OpenGL/GLUT/glutconst.py
+lib/python1.5/site-packages/OpenGL/GLUT/__init__.py
+lib/python1.5/site-packages/OpenGL/GL/glconst-1.0.py
+lib/python1.5/site-packages/OpenGL/GL/glconst.py
+lib/python1.5/site-packages/OpenGL/GL/wglconst.py
+lib/python1.5/site-packages/OpenGL/GL/__init__.py
+lib/python1.5/site-packages/OpenGL/GLU/gluconst-1.0.py
+lib/python1.5/site-packages/OpenGL/GLU/gluconst.py
+lib/python1.5/site-packages/OpenGL/GLU/__init__.py
+lib/python1.5/site-packages/OpenGL/Demo/da/dots.py
+lib/python1.5/site-packages/OpenGL/Demo/da/__init__.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/triangle.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/1crn.pdb
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/1crn.vert
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/1crn.xyzr
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/Geometry.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/NumericPDB.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/OglFrame.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/README
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/test.ppm
+lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface/1crn.face
+lib/python1.5/site-packages/OpenGL/Demo/dek/MandelImage.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/PILNumeric.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/README
+lib/python1.5/site-packages/OpenGL/Demo/dek/texturesurf.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/texturesurf2.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/tile.py
+lib/python1.5/site-packages/OpenGL/Demo/dek/image.ppm
+lib/python1.5/site-packages/OpenGL/Demo/dek/__init__.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/Images/cowbaby.ppm
+lib/python1.5/site-packages/OpenGL/Demo/srenner/Images/textile.ppm
+lib/python1.5/site-packages/OpenGL/Demo/srenner/att_obj.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/compass.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/cursor.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/objex.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/oglpm.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/ogltex.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/README
+lib/python1.5/site-packages/OpenGL/Demo/srenner/README~
+lib/python1.5/site-packages/OpenGL/Demo/srenner/renderer.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/room.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/sropengl.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/tablet.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/attention.py
+lib/python1.5/site-packages/OpenGL/Demo/srenner/trees.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/__init__.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/checker.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/cone.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/conechecker.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/conesave.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/demo.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/first.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/fog.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/Line.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/logo.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/lorentz.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/pick.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/poly.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/text.py
+lib/python1.5/site-packages/OpenGL/Demo/tom/arraytest.py
+lib/python1.5/site-packages/OpenGL/Demo/__init__.py
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/openglutil_num.so
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/openglutil.so
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/_openglmodule.so
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/_opengl_nummodule.so
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/_glutmodule.so
+lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%/_glumodule.so
+lib/python1.5/site-packages/OpenGL/shared/__init__.py
+lib/python1.5/site-packages/OpenGL/Tk/__init__.py
+lib/python1.5/site-packages/OpenGL/__init__.py
+@dirrm lib/python1.5/site-packages/OpenGL/GLUT
+@dirrm lib/python1.5/site-packages/OpenGL/GL
+@dirrm lib/python1.5/site-packages/OpenGL/GLU
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/da
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/dek/OglSurface
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/dek
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/srenner/Images
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/srenner
+@dirrm lib/python1.5/site-packages/OpenGL/Demo/tom
+@dirrm lib/python1.5/site-packages/OpenGL/Demo
+@dirrm lib/python1.5/site-packages/OpenGL/shared/freebsd%%OSMAJOR%%
+@dirrm lib/python1.5/site-packages/OpenGL/shared
+@dirrm lib/python1.5/site-packages/OpenGL/Tk
+@dirrm lib/python1.5/site-packages/OpenGL