aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-13 01:34:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-13 01:34:53 +0000
commitb550837554d13bec24ebb5ab78d95d769cc2191c (patch)
tree1ab794a2805eb5b21a52a5dbc0b05783ce63cfb8 /graphics/py-opengl
parent4c54050fe3563e4da9efae4b74868e2598db0cdf (diff)
downloadports-b550837554d13bec24ebb5ab78d95d769cc2191c.tar.gz
ports-b550837554d13bec24ebb5ab78d95d769cc2191c.zip
Notes
Diffstat (limited to 'graphics/py-opengl')
-rw-r--r--graphics/py-opengl/Makefile27
-rw-r--r--graphics/py-opengl/distinfo4
-rw-r--r--graphics/py-opengl/files/patch-ac38
-rw-r--r--graphics/py-opengl/files/patch-config::freebsd.cfg27
4 files changed, 26 insertions, 70 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index f9ca94f87a26..62aac11b0743 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= opengl
-PORTVERSION= 2.0.0.44
+PORTVERSION= 2.0.1.07
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py${PORTNAME}
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyOpenGL-${PORTVERSION:S/.b/b/}
MAINTAINER= ports@FreeBSD.org
@@ -24,26 +24,23 @@ RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
-USE_PERL5_BUILD=yes
USE_REINPLACE= yes
+USE_GL= yes
+USE_MESA= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_MESA= yes
-OSMAJOR!= /usr/bin/uname -r | sed -e 's/\..*//'
-PLIST_SUB+= OSMAJOR=${OSMAJOR} \
- PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
-
-pre-patch:
+post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|malloc[.]h|stdlib.h|g'
- @${CP} ${WRKSRC}/src/Togl-1.5/tkInt8.3.h ${WRKSRC}/src/Togl-1.5/tkInt8.4.h
-
-do-configure:
- @${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/config/freebsd.cfg ${WRKSRC}/Tkinter.py
post-install:
- ${LOCALBASE}/bin/tclsh8.4 ${WRKSRC}/register.tcl
+ @${FIND} ${PYTHON_SITELIBDIR}/OpenGL -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PYTHON_SITELIBDIR}/OpenGL -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/graphics/py-opengl/distinfo b/graphics/py-opengl/distinfo
index 505ee9560d7c..35f62ee7622e 100644
--- a/graphics/py-opengl/distinfo
+++ b/graphics/py-opengl/distinfo
@@ -1,2 +1,2 @@
-MD5 (PyOpenGL-2.0.0.44.tar.gz) = 87066d1ebce1ecda2f562182332c658b
-SIZE (PyOpenGL-2.0.0.44.tar.gz) = 1281640
+MD5 (PyOpenGL-2.0.1.07.tar.gz) = 02e4331778fad4da7549ff1585a7a4a4
+SIZE (PyOpenGL-2.0.1.07.tar.gz) = 1884617
diff --git a/graphics/py-opengl/files/patch-ac b/graphics/py-opengl/files/patch-ac
deleted file mode 100644
index c88c2b3211c9..000000000000
--- a/graphics/py-opengl/files/patch-ac
+++ /dev/null
@@ -1,38 +0,0 @@
-
-$FreeBSD$
-
---- setup/togl_setup.py 2003/01/14 17:31:36 1.1
-+++ setup/togl_setup.py 2003/01/14 17:37:16
-@@ -40,7 +40,7 @@
- sources = [os.path.join('src',Togl,'togl.c')]
-
- include_dirs.append(os.path.join('src',Togl))
-- include_dirs.append(os.path.join(tk.getvar('tk_library'), '..', '..', 'include'))
-+ include_dirs.append(tk.getvar('tk_library').replace('/lib/', '/include/'))
-
- lib_dirs.append(os.path.normpath(os.path.join(tk.getvar('tk_library'), '..')))
-
-@@ -53,12 +53,12 @@
- libs.append('tcl' + string.replace(tk.getvar('tcl_version'), '.', ''))
- libs.append('tk' + string.replace(tk.getvar('tk_version'), '.', ''))
- else:
-- include_dirs.append(os.path.normpath(os.path.join(tk.getvar('tcl_library'), '..', '..', 'include')))
-+ include_dirs.append(tk.getvar('tcl_library').replace('/lib/', '/include/'))
-
- lib_dirs.append(os.path.normpath(os.path.join(tk.getvar('tcl_library'), '..')))
-
-- libs.append('tcl' + tk.getvar('tcl_version'))
-- libs.append('tk' + tk.getvar('tk_version'))
-+ libs.append('tcl' + string.replace(tk.getvar('tcl_version'),'.',''))
-+ libs.append('tk' + string.replace(tk.getvar('tk_version'),'.',''))
-
- # rest of this function was inspired by build_ext.py , build_extensions()
-
-@@ -91,6 +91,7 @@
- extra_postargs=extra_compile_args)
-
- # link all together
-+ extra_link_args = ['-Wl,-E']
- build_ext.compiler.link_shared_object (
- objects,
- output_filename,
diff --git a/graphics/py-opengl/files/patch-config::freebsd.cfg b/graphics/py-opengl/files/patch-config::freebsd.cfg
index abdb50ef0162..3618ad54abf9 100644
--- a/graphics/py-opengl/files/patch-config::freebsd.cfg
+++ b/graphics/py-opengl/files/patch-config::freebsd.cfg
@@ -1,16 +1,13 @@
-
-$FreeBSD$
-
---- config/freebsd.cfg 2003/01/14 17:28:11 1.1
-+++ config/freebsd.cfg 2003/01/14 17:29:05
+--- config/freebsd.cfg.orig Thu May 13 09:25:15 2004
++++ config/freebsd.cfg Thu May 13 09:25:37 2004
@@ -11,8 +11,8 @@
- [General]
- build_togl=1
- gl_platform=GLX
--include_dirs=/usr/include:/usr/local/include:/usr/X11/include
--library_dirs=/usr/lib:/usr/local/lib:/usr/X11/lib
-+include_dirs=/usr/include:%%LOCALBASE%%l/include:%%X11BASE%%/include
-+library_dirs=/usr/lib:%%LOCALBASE%%/lib:%%X11BASE%%/lib
-
- ; a sys.pathsep separated list of the libs needed when linking GL
- [GL]
+ [General]
+ build_togl=1
+ gl_platform=GLX
+-include_dirs=/usr/include:/usr/local/include:/usr/X11/include:/usr/X11R6/include
+-library_dirs=/usr/lib:/usr/local/lib:/usr/X11/lib:/usr/X11R6/lib
++include_dirs=/usr/include:%%LOCALBASE%%/include:%%X11BASE%%/include
++library_dirs=/usr/lib:%%LOCALBASE%%/lib:%%X11BASE%%/lib
+
+ ; a os.pathsep separated list of the libs needed when linking GL
+ [GL]