aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-poppler-qt4/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-02-04 13:37:15 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-02-04 13:37:15 +0000
commit4c7d30bb708caa0cb93b401f96679728a9f52974 (patch)
treed3572a824910587e038d1100b5972b19f37005aa /graphics/py-poppler-qt4/Makefile
parentdbf5f956b89ab67ab031eafbe3508f2a7632ee42 (diff)
downloadports-4c7d30bb708caa0cb93b401f96679728a9f52974.tar.gz
ports-4c7d30bb708caa0cb93b401f96679728a9f52974.zip
Switch ports to use USE_PYQT=<foo> instead of using RUN_- and BUILD_DEPENDS
pyqt.mk provides USE_PYQT=<list> to depend on its components. Convert the ports not yet using it to it. Reviewed by: rakuco, mat Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9261
Notes
Notes: svn path=/head/; revision=433310
Diffstat (limited to 'graphics/py-poppler-qt4/Makefile')
-rw-r--r--graphics/py-poppler-qt4/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/graphics/py-poppler-qt4/Makefile b/graphics/py-poppler-qt4/Makefile
index e206128907a2..262eff8888d4 100644
--- a/graphics/py-poppler-qt4/Makefile
+++ b/graphics/py-poppler-qt4/Makefile
@@ -14,14 +14,10 @@ COMMENT= Python bindings for the Poppler-Qt4 PDF rendering library
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
-BUILD_DEPENDS= sip:devel/py-sip \
- ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}qt4-xml>=0:textproc/py-qt4-xml
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}qt4-xml>=0:textproc/py-qt4-xml
-USES= pkgconfig python
+USES= pkgconfig pyqt:4 python
+USE_PYQT= gui xml sip_build
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>