aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyproj
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2019-06-27 03:37:10 +0000
committerWen Heping <wen@FreeBSD.org>2019-06-27 03:37:10 +0000
commit3d23ba68ab99fb4d59e9795ce691e40be3d48c8b (patch)
tree9d7639e045bd1b558843fd036fa2fa9922c9400b /graphics/py-pyproj
parent81f468837bda92e07f4bb7b261840c87179d2aaa (diff)
- Update to 6.1.0 and fix some ports
- Add missing DEPENDS - Add TEST_TARGET - Take maintainership PR: 237932, 238795 Submitted by: wenheping2000@hotmail.com,rhurlin@gwdg.de Approved by: maintainer(timeout, > 30 days), portmgr@(implicit, fix build) Exp-run by: antoine@ Thanks to: antoine@, sunpoet@, rhurlin@gwdg.de
Notes
Notes: svn path=/head/; revision=505194
Diffstat (limited to 'graphics/py-pyproj')
-rw-r--r--graphics/py-pyproj/Makefile17
-rw-r--r--graphics/py-pyproj/distinfo6
-rw-r--r--graphics/py-pyproj/pkg-descr2
3 files changed, 15 insertions, 10 deletions
diff --git a/graphics/py-pyproj/Makefile b/graphics/py-pyproj/Makefile
index 3eb493ac930d..aedc476570a9 100644
--- a/graphics/py-pyproj/Makefile
+++ b/graphics/py-pyproj/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pyproj
-PORTVERSION= 1.9.6
+PORTVERSION= 2.1.3
CATEGORIES= graphics python geography
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,14 +16,17 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libproj.so:graphics/proj
USES= python
-USE_PYTHON= distutils autoplist concurrent
+USE_PYTHON= autoplist concurrent cython distutils
MAKE_ENV= PROJ_DIR=${LOCALBASE}
PORTDOCS= *
-PORTDOCS1= Changelog README.md docs/*
-PORTEXAMPLES= datum_shift.py geodtest.py sample.out \
- test.py test2.py test_datum.py test_transform.py
+PORTDOCS1= README.md docs/*
+PORTEXAMPLES= sample.out \
+ test.py test_awips221.py test_crs.py test_datadir.py \
+ test_datum.py test_datum_shift.py test_doctest_wrapper.py \
+ test_exception_logging.py test_geod.py test_pickle.py \
+ test_transform.py test_transformer.py
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -32,7 +35,9 @@ post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS1:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs/ && \
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR} "! -name .buildinfo" )
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/py-pyproj/distinfo b/graphics/py-pyproj/distinfo
index f87e4943e698..349ae523a2ca 100644
--- a/graphics/py-pyproj/distinfo
+++ b/graphics/py-pyproj/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550151151
-SHA256 (pyproj-1.9.6.tar.gz) = e0c02b1554b20c710d16d673817b2a89ff94738b0b537aead8ecb2edc4c4487b
-SIZE (pyproj-1.9.6.tar.gz) = 2797999
+TIMESTAMP = 1558185597
+SHA256 (pyproj-2.1.3.tar.gz) = 99c52788b01a7bb9a88024bf4d40965c0a66a93d654600b5deacf644775f424d
+SIZE (pyproj-2.1.3.tar.gz) = 521154
diff --git a/graphics/py-pyproj/pkg-descr b/graphics/py-pyproj/pkg-descr
index fd9a16dbf203..caa05e40f95b 100644
--- a/graphics/py-pyproj/pkg-descr
+++ b/graphics/py-pyproj/pkg-descr
@@ -4,7 +4,7 @@ Performs cartographic transformations and geodetic computations.
The Proj class can convert from geographic (longitude,latitude)
to native map projection (x,y) coordinates and vice versa, or
-from one map projection coordinate system directly to another.
+from one map projection coordinate system directly to another.
The module variable pj_list is a dictionary containing all the
available projections and their descriptions.