aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-rasterio
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-08 20:46:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-08 20:46:34 +0000
commit38fe411b5e061b8918594039d0f97b1351566183 (patch)
tree449a91468ba2ba0b6f55ee914d26178dda613278 /graphics/py-rasterio
parent1d07f8fbb7031992b3f1531fd3d4fb146c20ed02 (diff)
downloadports-38fe411b5e061b8918594039d0f97b1351566183.tar.gz
ports-38fe411b5e061b8918594039d0f97b1351566183.zip
Add py-rasterio 1.1.4
Rasterio reads and writes geospatial raster data. Geographic information systems use GeoTIFF and other formats to organize and store gridded, or raster, datasets. Rasterio reads and writes these formats and provides a Python API based on N-D arrays. WWW: https://github.com/mapbox/rasterio
Notes
Notes: svn path=/head/; revision=534419
Diffstat (limited to 'graphics/py-rasterio')
-rw-r--r--graphics/py-rasterio/Makefile31
-rw-r--r--graphics/py-rasterio/distinfo3
-rw-r--r--graphics/py-rasterio/pkg-descr7
3 files changed, 41 insertions, 0 deletions
diff --git a/graphics/py-rasterio/Makefile b/graphics/py-rasterio/Makefile
new file mode 100644
index 000000000000..5a6d672ebc1c
--- /dev/null
+++ b/graphics/py-rasterio/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rasterio
+PORTVERSION= 1.1.4
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fast and direct raster I/O for use with Numpy and SciPy
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= gdal>=1.11:graphics/gdal \
+ ${PYNUMPY}
+RUN_DEPENDS= gdal>=1.11:graphics/gdal \
+ ${PYTHON_PKGNAMEPREFIX}affine>=0:math/py-affine@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=4.0<8:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-plugins>=0:devel/py-click-plugins@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cligj>=0.5:devel/py-cligj@${PY_FLAVOR} \
+ ${PY_ENUM34} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}snuggs>=1.4.1:math/py-snuggs@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-rasterio/distinfo b/graphics/py-rasterio/distinfo
new file mode 100644
index 000000000000..6254be369ef7
--- /dev/null
+++ b/graphics/py-rasterio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588930303
+SHA256 (rasterio-1.1.4.tar.gz) = 5d7393f3a690a91813022452022df1d5a3a2c732019f24f2bd0b051fd47a03c1
+SIZE (rasterio-1.1.4.tar.gz) = 2176246
diff --git a/graphics/py-rasterio/pkg-descr b/graphics/py-rasterio/pkg-descr
new file mode 100644
index 000000000000..cb51afdf3012
--- /dev/null
+++ b/graphics/py-rasterio/pkg-descr
@@ -0,0 +1,7 @@
+Rasterio reads and writes geospatial raster data.
+
+Geographic information systems use GeoTIFF and other formats to organize and
+store gridded, or raster, datasets. Rasterio reads and writes these formats and
+provides a Python API based on N-D arrays.
+
+WWW: https://github.com/mapbox/rasterio