aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-rasterio
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-17 18:29:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-17 18:29:06 +0000
commita130e412837577b42b1fbc737f2c48511ccabd02 (patch)
treeb0b02c2bec5e4ceebfdcf2a5427b1bfda19f7df2 /graphics/py-rasterio
parente73a23b70746921551eb39bbf90de5cb20bf49b0 (diff)
downloadports-a130e412837577b42b1fbc737f2c48511ccabd02.tar.gz
ports-a130e412837577b42b1fbc737f2c48511ccabd02.zip
Add PLOT and S3 options
Notes
Notes: svn path=/head/; revision=535609
Diffstat (limited to 'graphics/py-rasterio')
-rw-r--r--graphics/py-rasterio/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/graphics/py-rasterio/Makefile b/graphics/py-rasterio/Makefile
index 740df26d1141..2dbe9eec3fca 100644
--- a/graphics/py-rasterio/Makefile
+++ b/graphics/py-rasterio/Makefile
@@ -28,4 +28,11 @@ RUN_DEPENDS= gdal>=1.11:graphics/gdal \
USES= compiler:c++11-lang python
USE_PYTHON= autoplist concurrent cython distutils
+OPTIONS_DEFINE= PLOT S3
+PLOT_DESC= Plotting support
+S3_DESC= Amazon S3 support
+
+PLOT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR}
+S3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.2.4:www/py-boto3@${PY_FLAVOR}
+
.include <bsd.port.mk>