aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-soya3d/files
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-09 00:17:17 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-09 00:17:17 +0000
commitada16c01ece321041b825e913b76a1a12761cbc0 (patch)
treea6decdd95e973cb684266590e35791e3770360f3 /graphics/py-soya3d/files
parent3ed936d756a57f7a23fd2774a9a248cf29da16ba (diff)
downloadports-ada16c01ece321041b825e913b76a1a12761cbc0.tar.gz
ports-ada16c01ece321041b825e913b76a1a12761cbc0.zip
Notes
Diffstat (limited to 'graphics/py-soya3d/files')
-rw-r--r--graphics/py-soya3d/files/patch-_ode.c13
-rw-r--r--graphics/py-soya3d/files/patch-_soya.c13
-rw-r--r--graphics/py-soya3d/files/patch-sdlconst.c13
-rw-r--r--graphics/py-soya3d/files/patch-setup.py34
4 files changed, 73 insertions, 0 deletions
diff --git a/graphics/py-soya3d/files/patch-_ode.c b/graphics/py-soya3d/files/patch-_ode.c
new file mode 100644
index 000000000000..bc3b6a0523a0
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-_ode.c
@@ -0,0 +1,13 @@
+--- _ode.c.old Wed Oct 5 02:50:09 2005
++++ _ode.c Wed Oct 5 02:50:18 2005
+@@ -10,8 +10,8 @@
+ #include "math.h"
+ #include "GL/glew.h"
+ #include "ode/ode.h"
+-#include "SDL/SDL_endian.h"
+-#include "SDL/SDL.h"
++#include "SDL11/SDL_endian.h"
++#include "SDL11/SDL.h"
+ #include "chunk.h"
+ #include "matrix.h"
+ #include "cal3d_wrapper.h"
diff --git a/graphics/py-soya3d/files/patch-_soya.c b/graphics/py-soya3d/files/patch-_soya.c
new file mode 100644
index 000000000000..c9912a91537a
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-_soya.c
@@ -0,0 +1,13 @@
+--- _soya.c.old Wed Oct 5 00:23:48 2005
++++ _soya.c Wed Oct 5 00:24:03 2005
+@@ -6,8 +6,8 @@
+ #define PY_LONG_LONG LONG_LONG
+ #endif
+ #include "GL/glew.h"
+-#include "SDL/SDL_endian.h"
+-#include "SDL/SDL.h"
++#include "SDL11/SDL_endian.h"
++#include "SDL11/SDL.h"
+ #include "chunk.h"
+ #include "matrix.h"
+ #include "cal3d_wrapper.h"
diff --git a/graphics/py-soya3d/files/patch-sdlconst.c b/graphics/py-soya3d/files/patch-sdlconst.c
new file mode 100644
index 000000000000..b190a021df5a
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-sdlconst.c
@@ -0,0 +1,13 @@
+--- sdlconst.c.old Wed Oct 5 02:49:32 2005
++++ sdlconst.c Wed Oct 5 02:49:42 2005
+@@ -8,8 +8,8 @@
+ #include "stdlib.h"
+ #include "string.h"
+ #include "math.h"
+-#include "SDL/SDL_endian.h"
+-#include "SDL/SDL.h"
++#include "SDL11/SDL_endian.h"
++#include "SDL11/SDL.h"
+
+
+ typedef struct {PyObject **p; char *s;} __Pyx_InternTabEntry; /*proto*/
diff --git a/graphics/py-soya3d/files/patch-setup.py b/graphics/py-soya3d/files/patch-setup.py
new file mode 100644
index 000000000000..e5d2f141392e
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-setup.py
@@ -0,0 +1,34 @@
+--- setup.py.old Wed Oct 5 00:05:48 2005
++++ setup.py Wed Oct 5 02:47:23 2005
+@@ -63,10 +63,10 @@
+ from config import *
+
+ if sys.platform[:3] == "win":
+- LIBS = ["m", "glew32", "SDL", "SDL_mixer", "freetype", "cal3d", "stdc++"]
++ LIBS = ["m", "glew32", "SDL-1.1", "SDL_mixer", "freetype", "cal3d", "stdc++"]
+ else:
+ #LIBS = ["m", "GLEW", "GL", "GLU", "SDL", "SDL_mixer", "freetype", "cal3d", "stdc++"]
+- LIBS = ["m", "GLEW", "SDL", "freetype", "cal3d", "stdc++"]
++ LIBS = ["m", "GLEW", "SDL-1.1", "freetype", "cal3d", "stdc++"]
+
+ SOYA_PYREX_SOURCES = ["_soya.pyx", "matrix.c", "chunk.c" ]
+ SOYA_C_SOURCES = ["_soya.c" , "matrix.c", "chunk.c" ]
+@@ -97,14 +97,14 @@
+ print "ODE and OPCODE have already been compiled; if you want to recompile them do: cd %s ; make clean" % ODE_DIR
+ else:
+ print "Building ODE and OPCODE from %s" % ODE_DIR
+- do("cd %s ; make clean" % ODE_DIR)
+- do("cd %s ; make configure" % ODE_DIR)
+- do("cd %s ; make" % ODE_DIR)
++ do("cd %s ; gmake clean" % ODE_DIR)
++ do("cd %s ; gmake configure" % ODE_DIR)
++ do("cd %s ; gmake" % ODE_DIR)
+ print "ODE and OPCODE built successfully !"
+
+ elif "sdist" in sys.argv:
+ # Clean ODE, to remove configuration files and binaries
+- do("cd %s ; make clean" % ODE_DIR)
++ do("cd %s ; gmake clean" % ODE_DIR)
+
+
+ if HAVE_PYREX: