aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-soya3d
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-24 23:48:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-24 23:48:19 +0000
commitdade8ed37c8a72394e1cabb3ce7157011a6f12b4 (patch)
treebfea47f9009bc3300afbeade1e71ba9c306bc5e6 /graphics/py-soya3d
parentc30b1b80dee8845455693ebc065f10b4f73d0ebc (diff)
Notes
Diffstat (limited to 'graphics/py-soya3d')
-rw-r--r--graphics/py-soya3d/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 51a82a5ef870..a8fe9f4a1ce5 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -29,12 +29,11 @@ USE_SDL= sdl
LDFLAGS+= -L${LOCALBASE}/lib -lGLU
-MANDIR= ${WRKDIR}/${DISTNAME}/manpage/man1
-INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
SOYATUTVER= 0.14
OPTIONS_DEFINE= DOCS EXAMPLES
+PLIST_FILES= man/man1/soya_editor.1.gz
PORTDOCS= *
PORTEXAMPLES= *
@@ -56,20 +55,19 @@ post-patch:
's|/usr/include|${LOCALBASE}/include|g' ${WRKSRC}/setup.py
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/soya/*.so
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/tutorial/* ${STAGEDIR}${EXAMPLESDIR}
${FIND} ${STAGEDIR}${EXAMPLESDIR}/* -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
.endif
-
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for FILE in AUTHORS README
+. for FILE in AUTHORS README
@${INSTALL_DATA} ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/${FILE} ${STAGEDIR}${DOCSDIR}
-.endfor
-
-.for FILE in ${MAN1}
- ${INSTALL_MAN} ${MANDIR}/${FILE} ${STAGEDIR}${PREFIX}/man/man1
-.endfor
+. endfor
+.endif
+ ${INSTALL_MAN} ${WRKSRC}/manpage/man1/soya_editor.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.post.mk>