aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-willow
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-27 19:56:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-27 19:56:04 +0000
commit2e34e84ff6b08356a992e962e14691cb68e2d461 (patch)
tree456e23a342184e1a17b6d328989679f459177aab /graphics/py-willow
parenta18bc34a0f04cd56a452cd376628e1abb34e4e06 (diff)
downloadports-2e34e84ff6b08356a992e962e14691cb68e2d461.tar.gz
ports-2e34e84ff6b08356a992e962e14691cb68e2d461.zip
Notes
Diffstat (limited to 'graphics/py-willow')
-rw-r--r--graphics/py-willow/Makefile33
-rw-r--r--graphics/py-willow/distinfo3
-rw-r--r--graphics/py-willow/pkg-descr10
3 files changed, 46 insertions, 0 deletions
diff --git a/graphics/py-willow/Makefile b/graphics/py-willow/Makefile
new file mode 100644
index 000000000000..2f160f71ae08
--- /dev/null
+++ b/graphics/py-willow/Makefile
@@ -0,0 +1,33 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= willow
+PORTVERSION= 1.1
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Willow-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Wrapper that combines multiple Python image libraries into one API
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= PILLOW WAND OPENCV
+OPTIONS_DEFAULT=PILLOW
+OPENCV_DESC= Use OpenCV as backend
+PILLOW_DESC= Use Pillow as backend
+WAND_DESC= Use Wand as backend
+
+OPENCV_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opencv>=0:graphics/py-opencv@${PY_FLAVOR}
+PILLOW_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+WAND_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wand>=0:graphics/py-wand@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-willow/distinfo b/graphics/py-willow/distinfo
new file mode 100644
index 000000000000..fc207e0d5e27
--- /dev/null
+++ b/graphics/py-willow/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548503185
+SHA256 (Willow-1.1.tar.gz) = 818ee11803c90a0a6d49c94b0453d6266be1ef83ae00de72731c45fae4d3e78c
+SIZE (Willow-1.1.tar.gz) = 101827
diff --git a/graphics/py-willow/pkg-descr b/graphics/py-willow/pkg-descr
new file mode 100644
index 000000000000..534cb23c97c1
--- /dev/null
+++ b/graphics/py-willow/pkg-descr
@@ -0,0 +1,10 @@
+Willow is a simple image library that combines the APIs of Pillow, Wand and
+OpenCV. It converts the image between the libraries when necessary.
+
+Willow currently has basic resize and crop operations, face and feature
+detection and animated GIF support. New operations and library integrations can
+also be easily implemented.
+
+It is written in pure-Python.
+
+WWW: https://github.com/wagtail/Willow