aboutsummaryrefslogtreecommitdiff
path: root/graphics/pyggel/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-04-06 22:56:23 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-04-06 22:56:23 +0000
commit334db61689ae56c781ac73214cd4c409546bfd51 (patch)
tree79b111c4083c7c29b516f4b40ea22c08b09dae36 /graphics/pyggel/Makefile
parentda205434495b41b9e216df043c0cae77b2be1b00 (diff)
downloadports-334db61689ae56c781ac73214cd4c409546bfd51.tar.gz
ports-334db61689ae56c781ac73214cd4c409546bfd51.zip
Notes
Diffstat (limited to 'graphics/pyggel/Makefile')
-rw-r--r--graphics/pyggel/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/graphics/pyggel/Makefile b/graphics/pyggel/Makefile
new file mode 100644
index 000000000000..7deefb39fb59
--- /dev/null
+++ b/graphics/pyggel/Makefile
@@ -0,0 +1,57 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyggel
+PORTVERSION= 0.08
+DISTVERSIONSUFFIX= -alpha4c
+CATEGORIES= graphics python
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME:U}-V${DISTVERSION}${DISTVERSIONSUFFIX}
+DIST_SUBDIR= python
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Python Graphical Game Engine and Libraries
+
+LICENSE= LGPL3 Public_Domain
+LICENSE_COMB= dual
+LICENSE_NAME_Public_Domain= Public Domain
+LICENSE_TEXT_Public_Domain= Public Domain
+LICENSE_PERMS_Public_Domain=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYGAME} \
+ ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
+ ${PYTHON_PKGNAMEPREFIX}imaging>=0:${PORTSDIR}/graphics/py-imaging
+
+USES= dos2unix zip
+DOS2UNIX_GLOB= *.mtl *.py *.txt
+USE_PYTHON= 2
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+PORTDOCS= Readme.txt
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data_files =|#data_files =|' \
+ ${WRKSRC}/setup.py
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @(cd ${WRKSRC}/examples_and_tutorials && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${EXAMPLESDIR}/examples_and_tutorials)
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${EXAMPLESDIR})
+. for f in test_FBO test_camera test_gui test_mesh test_particle test_texture_swap
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f}.py ${STAGEDIR}${EXAMPLESDIR})
+. endfor
+.endif
+
+.include <bsd.port.mk>