aboutsummaryrefslogtreecommitdiff
path: root/graphics/pygts
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-22 22:00:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-22 22:00:30 +0000
commitd52322e58c2f74ccafadc8c5b086bd4290c839fa (patch)
treebd1ada1f62a38f093b66816cc90ce351c95f35d7 /graphics/pygts
parentb77bd2c353af2e5321399c5d6efdd394558910f8 (diff)
downloadports-d52322e58c2f74ccafadc8c5b086bd4290c839fa.tar.gz
ports-d52322e58c2f74ccafadc8c5b086bd4290c839fa.zip
Notes
Diffstat (limited to 'graphics/pygts')
-rw-r--r--graphics/pygts/Makefile21
-rw-r--r--graphics/pygts/distinfo3
-rw-r--r--graphics/pygts/pkg-descr5
-rw-r--r--graphics/pygts/pkg-plist4
4 files changed, 33 insertions, 0 deletions
diff --git a/graphics/pygts/Makefile b/graphics/pygts/Makefile
new file mode 100644
index 000000000000..0db66bfd2de4
--- /dev/null
+++ b/graphics/pygts/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: pygts
+# Date created: 17 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pygts
+PORTVERSION= 0.1.4
+CATEGORIES= graphics python
+MASTER_SITES= SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python binding for GNU Triangulated Surface(GTS) Library
+
+LIB_DEPENDS= gts.5:${PORTSDIR}/graphics/gts
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/pygts/distinfo b/graphics/pygts/distinfo
new file mode 100644
index 000000000000..3fae0e8061c9
--- /dev/null
+++ b/graphics/pygts/distinfo
@@ -0,0 +1,3 @@
+MD5 (pygts-0.1.4.tar.gz) = 1b91daaf0d55722d956193c5aca27931
+SHA256 (pygts-0.1.4.tar.gz) = 3efbc3a774a42d06820f43761be339283b429310e9ec2f55ca176565991afbab
+SIZE (pygts-0.1.4.tar.gz) = 98478
diff --git a/graphics/pygts/pkg-descr b/graphics/pygts/pkg-descr
new file mode 100644
index 000000000000..8d576967922d
--- /dev/null
+++ b/graphics/pygts/pkg-descr
@@ -0,0 +1,5 @@
+PyGTS is a python package used to construct, manipulate, and perform
+computations on 3D triangulated surfaces. It is a hand-crafted and
+pythonic binding for the GNU Triangulated Surface (GTS) Library.
+
+WWW: http://pygts.sf.net
diff --git a/graphics/pygts/pkg-plist b/graphics/pygts/pkg-plist
new file mode 100644
index 000000000000..c8cd5bc4bda2
--- /dev/null
+++ b/graphics/pygts/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/gts.py
+%%PYTHON_SITELIBDIR%%/gts.pyc
+%%PYTHON_SITELIBDIR%%/gts.pyo
+%%PYTHON_SITELIBDIR%%/_gts.so