aboutsummaryrefslogtreecommitdiff
path: root/graphics/qcomicbook
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2005-05-27 21:38:42 +0000
committerPatrick Li <pat@FreeBSD.org>2005-05-27 21:38:42 +0000
commit3f9322712a9781e51c0c4cca36b85318a164413d (patch)
tree875b1332e0ae8e8161c0d2d82a617831c052e241 /graphics/qcomicbook
parent267cb82866ca9f1141a39f81b0b30de9a3e05a71 (diff)
downloadports-3f9322712a9781e51c0c4cca36b85318a164413d.tar.gz
ports-3f9322712a9781e51c0c4cca36b85318a164413d.zip
Notes
Diffstat (limited to 'graphics/qcomicbook')
-rw-r--r--graphics/qcomicbook/Makefile23
-rw-r--r--graphics/qcomicbook/distinfo4
-rw-r--r--graphics/qcomicbook/files/patch-src-imgarchivesink.cpp10
-rw-r--r--graphics/qcomicbook/files/patch-src-thumbnail.cpp10
4 files changed, 33 insertions, 14 deletions
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index c82e50f30919..df1068771991 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qcomicbook
-PORTVERSION= 0.2.0
+PORTVERSION= 0.2.1
CATEGORIES= graphics
MASTER_SITES= http://linux.bydg.org/~yogin/
@@ -18,21 +18,20 @@ RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
USE_X_PREFIX= yes
USE_QT_VER= 3
-
-GNU_CONFIGURE= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+=--with-Qt-dir="${X11BASE}"
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-Qt-dir="${QT_PREFIX}"
+
+MAN1= qcomicbook.1
+
# Luckily, QT apps on FreeBSD don't compile against
# pthread by default. That might *gasp* make them work!
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
-MAN1= qcomicbook.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Configure fails on FreeBSD 4.x"
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|="failure"|=""|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/qcomicbook/distinfo b/graphics/qcomicbook/distinfo
index 6966b200a376..b94fe7a79601 100644
--- a/graphics/qcomicbook/distinfo
+++ b/graphics/qcomicbook/distinfo
@@ -1,2 +1,2 @@
-MD5 (qcomicbook-0.2.0.tar.gz) = c7b4e120218cdd5d94c010fe4f98fc59
-SIZE (qcomicbook-0.2.0.tar.gz) = 189285
+MD5 (qcomicbook-0.2.1.tar.gz) = 78cb4ac0433af583dc0254f65caf290d
+SIZE (qcomicbook-0.2.1.tar.gz) = 190757
diff --git a/graphics/qcomicbook/files/patch-src-imgarchivesink.cpp b/graphics/qcomicbook/files/patch-src-imgarchivesink.cpp
new file mode 100644
index 000000000000..fe64d3d88510
--- /dev/null
+++ b/graphics/qcomicbook/files/patch-src-imgarchivesink.cpp
@@ -0,0 +1,10 @@
+--- src/imgarchivesink.cpp.orig Mon May 16 00:16:43 2005
++++ src/imgarchivesink.cpp Fri May 20 00:41:12 2005
+@@ -18,6 +18,7 @@
+ #include <qfileinfo.h>
+ #include <qfile.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
diff --git a/graphics/qcomicbook/files/patch-src-thumbnail.cpp b/graphics/qcomicbook/files/patch-src-thumbnail.cpp
new file mode 100644
index 000000000000..5c36e132c311
--- /dev/null
+++ b/graphics/qcomicbook/files/patch-src-thumbnail.cpp
@@ -0,0 +1,10 @@
+--- src/thumbnail.cpp.orig Sat Apr 2 19:59:03 2005
++++ src/thumbnail.cpp Fri May 20 00:51:33 2005
+@@ -11,6 +11,7 @@
+ */
+
+ #include "thumbnail.h"
++#include <sys/types.h>
+ #include <utime.h>
+
+ int Thumbnail::thwidth = 100;