aboutsummaryrefslogtreecommitdiff
path: root/graphics/qcread
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1998-11-16 20:38:21 +0000
committerBill Fumerola <billf@FreeBSD.org>1998-11-16 20:38:21 +0000
commitb9d97678ce67893dfad3262eed442e6817a02cf4 (patch)
tree1dc34bebf1fad51e4d878cfa85d6cd84fd9081ab /graphics/qcread
parent9ea8461c82f62fcb03198e370e58e85dff39deef (diff)
downloadports-b9d97678ce67893dfad3262eed442e6817a02cf4.tar.gz
ports-b9d97678ce67893dfad3262eed442e6817a02cf4.zip
Notes
Diffstat (limited to 'graphics/qcread')
-rw-r--r--graphics/qcread/Makefile25
-rw-r--r--graphics/qcread/distinfo1
-rw-r--r--graphics/qcread/files/patch-aa26
-rw-r--r--graphics/qcread/pkg-comment1
-rw-r--r--graphics/qcread/pkg-descr11
-rw-r--r--graphics/qcread/pkg-plist2
6 files changed, 66 insertions, 0 deletions
diff --git a/graphics/qcread/Makefile b/graphics/qcread/Makefile
new file mode 100644
index 000000000000..8560298cd0f0
--- /dev/null
+++ b/graphics/qcread/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: qcread
+# Version required: 0.3
+# Date created: 23 August 1998
+# Whom: Bill Fumerola <billf@chc-chimes.com>
+#
+# $Id: $
+#
+
+DISTNAME= qcread-0.3
+CATEGORIES= graphics
+MASTER_SITES= ftp://phobos.illtel.denver.co.us/pub/qcread/ \
+ http://phobos.illtel.denver.co.us/pub/qcread/
+
+MAINTAINER= billf@FreeBSD.ORG
+
+post-extract:
+
+ ${CP} -r ${WRKSRC}/gnu-getopt/. ${WRKSRC}
+
+do-install:
+
+ ${INSTALL} ${COPY} -o root -g wheel -m 644 ${WRKSRC}/qcam.conf ${PREFIX}/etc
+ ${INSTALL_PROGRAM} ${WRKSRC}/qcread ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/qcread/distinfo b/graphics/qcread/distinfo
new file mode 100644
index 000000000000..027263ad5bc5
--- /dev/null
+++ b/graphics/qcread/distinfo
@@ -0,0 +1 @@
+MD5 (qcread-0.3.tar.gz) = c491b64c31d8751cca2b217663167560
diff --git a/graphics/qcread/files/patch-aa b/graphics/qcread/files/patch-aa
new file mode 100644
index 000000000000..d809957c3654
--- /dev/null
+++ b/graphics/qcread/files/patch-aa
@@ -0,0 +1,26 @@
+--- Makefile.old Sun Aug 23 21:51:14 1998
++++ Makefile Sun Aug 23 21:53:23 1998
+@@ -9,17 +9,17 @@
+
+ # for Linux
+ #
+-CFLAGS = -O -DLinux
+-INCLUDES = cqc.h
+-OBJS = cqc.o
++#CFLAGS = -O -DLinux
++#INCLUDES = cqc.h
++#OBJS = cqc.o
+ #
+ # end Linux options
+
+ ## for FreeBSD
+ ##
+-#CFLAGS = -g -O -Ignu-getopt -DFreeBSD
+-#INCLUDES = cqc.h gnu-getopt/getopt.h
+-#OBJS = cqc.o gnu-getopt/getopt.o gnu-getopt/getopt1.o
++CFLAGS = -g -O -I. -DFreeBSD
++INCLUDES = cqc.h getopt.h
++OBJS = cqc.o getopt.o getopt1.o
+ ##
+ ## end FreeBSD options
+
diff --git a/graphics/qcread/pkg-comment b/graphics/qcread/pkg-comment
new file mode 100644
index 000000000000..e2cf0e3b15b3
--- /dev/null
+++ b/graphics/qcread/pkg-comment
@@ -0,0 +1 @@
+supports both color and B&W parallel-port Connectix QuickCam for PC
diff --git a/graphics/qcread/pkg-descr b/graphics/qcread/pkg-descr
new file mode 100644
index 000000000000..1e5c32f4b400
--- /dev/null
+++ b/graphics/qcread/pkg-descr
@@ -0,0 +1,11 @@
+This program supports both color and B&W parallel-port Connectix QuickCam
+for PC All modes are supported except color QuickCam "thousands colors"
+compressed download and 640x480 "billions colors" mode. "Thousands" is
+unsupported because of the lack of information and will be added if
+Connectix will give the documentation on it to developers in the same or
+similar way, the documentation on other modes was given that made this
+program possible. "Billions colors" will be supported in later releases.
+
+http://www.illtel.com/pub/qcread/README.html
+
+Bill Fumerola <billf@chc-chimes.com>
diff --git a/graphics/qcread/pkg-plist b/graphics/qcread/pkg-plist
new file mode 100644
index 000000000000..ccb84814dd64
--- /dev/null
+++ b/graphics/qcread/pkg-plist
@@ -0,0 +1,2 @@
+bin/qcread
+etc/qcam.conf