aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-12-20 20:51:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-12-20 20:51:04 +0000
commitd9576019a173d5c7ffaa2e8cde05191675646094 (patch)
tree748a2d542c63d1cfc41456a8c3cc9701ef7b6df6 /graphics/qgis/Makefile
parent4eb7961c0d7c82485b76183c4162e4314b9d2150 (diff)
downloadports-d9576019a173d5c7ffaa2e8cde05191675646094.tar.gz
ports-d9576019a173d5c7ffaa2e8cde05191675646094.zip
Notes
Diffstat (limited to 'graphics/qgis/Makefile')
-rw-r--r--graphics/qgis/Makefile30
1 files changed, 11 insertions, 19 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 965677c70e2d..b115216656ac 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= qgis
-PORTVERSION= 0.7.4
-PORTREVISION= 5
+PORTVERSION= 0.11.0
CATEGORIES= graphics geography
-MASTER_SITES= SF
+MASTER_SITES= http://download.osgeo.org/qgis/src/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= dyeske@gmail.com
COMMENT= Geographical Information System (GIS) data viewer
@@ -18,19 +18,14 @@ LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
proj:${PORTSDIR}/graphics/proj \
gsl.12:${PORTSDIR}/math/gsl \
gdal:${PORTSDIR}/graphics/gdal
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-BROKEN= Does not build with geos 3.x
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
-
-USE_AUTOTOOLS= libtool:15
-USE_GMAKE= yes
-USE_FREETYPE= yes
-USE_PERL5_BUILD=yes
-USE_QT_VER= 3
+USE_BISON= build
+USE_CMAKE= yes
+USE_QT_VER= 4
USE_SQLITE= yes
-MAN1= qgis.1
+CMAKE_USE_PTHREAD= yes
+CMAKE_ENV+= QMAKESPEC=${QMAKESPEC}
+QT_COMPONENTS= qmake gui moc rcc uic svg xml network sql linguist
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-qtdir=${QTDIR}
@@ -51,15 +46,12 @@ GRASS_INST_DIR= grass
.if defined(WITH_GRASS)
CONFIGURE_ARGS+=--with-grass=${LOCALBASE}/${GRASS_INST_DIR}
-RUN_DEPENDS+=${LOCALBASE}/lib/gdalplugins/gdal_GRASS.so:${PORTSDIR}/graphics/gdal-grass
-PLIST_SUB+= GRASS=""
-.else
-PLIST_SUB+= GRASS="@comment "
+RUN_DEPENDS+= ${LOCALBASE}/lib/gdalplugins/gdal_GRASS.so:${PORTSDIR}/graphics/gdal-grass
.endif
.if defined(WITH_POSTGIS)
CONFIGURE_ARGS+=--with-postgresql
-BUILD_DEPENDS+=${LOCALBASE}/share/postgis:${PORTSDIR}/databases/postgis
+BUILD_DEPENDS+= ${LOCALBASE}/share/postgis:${PORTSDIR}/databases/postgis
PLIST_SUB+= PGSQL=""
.else
CONFIGURE_ARGS+=--without-postgresql