aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-29 01:37:51 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-29 01:37:51 +0000
commit84e38f41551b443fe742143c83d5d5931bdc03be (patch)
treede4ba37532c7a9a6003049923ba5c29ffcbb1707 /graphics/qgis
parent4c012c4d458fae0352a2b489f2a41cfe25022db6 (diff)
downloadports-84e38f41551b443fe742143c83d5d5931bdc03be.tar.gz
ports-84e38f41551b443fe742143c83d5d5931bdc03be.zip
Notes
Diffstat (limited to 'graphics/qgis')
-rw-r--r--graphics/qgis/Makefile5
-rw-r--r--graphics/qgis/files/patch-cmake-Python.cmake10
2 files changed, 12 insertions, 3 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index a88aaa5c6b2a..39ee0699d6a3 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qgis
PORTVERSION= 1.4.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/qgis/src/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -37,7 +37,7 @@ USE_LDCONFIG= yes
OPTIONS= GRASS "Enable GRASS support" Off \
POSTGIS "Enable PostGIS support" Off \
- PYTHON "Enable Python (broken with sip-4.10)" Off
+ PYTHON "Enable Python (broken with sip-4.10)" On
.include <bsd.port.pre.mk>
@@ -66,7 +66,6 @@ PLIST_SUB+= PGSQL="@comment "
.if defined(WITHOUT_PYTHON)
PLIST_SUB+= QGIS_PYTHON="@comment "
.else
-IGNORE= doesn't compile with devel/py-sip>=4.10
PLIST_SUB+= QGIS_PYTHON=""
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sip>=4.8.2:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.5.4:${PORTSDIR}/x11-toolkits/py-qt4-gui \
diff --git a/graphics/qgis/files/patch-cmake-Python.cmake b/graphics/qgis/files/patch-cmake-Python.cmake
new file mode 100644
index 000000000000..068e7eb9410d
--- /dev/null
+++ b/graphics/qgis/files/patch-cmake-Python.cmake
@@ -0,0 +1,10 @@
+--- cmake/Python.cmake.orig 2010-04-28 13:11:28.000000000 +0800
++++ cmake/Python.cmake 2010-04-28 13:12:18.000000000 +0800
+@@ -150,6 +150,7 @@
+ # minimal version is 4.7 (to support universal builds)
+ SET (SIP_MIN_VERSION 040700)
+ TRY_RUN_PYTHON (RES "import sip\nprint '%x' % sip.SIP_VERSION" SIP_VERSION)
++ SET (SIP_VERSION 041000)
+ IF (SIP_VERSION EQUAL "${SIP_MIN_VERSION}" OR SIP_VERSION GREATER "${SIP_MIN_VERSION}")
+ SET (SIP_IS_GOOD TRUE)
+ ENDIF (SIP_VERSION EQUAL "${SIP_MIN_VERSION}" OR SIP_VERSION GREATER "${SIP_MIN_VERSION}")