aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-08-16 00:05:53 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-08-16 00:05:53 +0000
commite726c6178fc10fcce1b6796eb362aaa853e05a6a (patch)
tree7ec4705b70a9cf0a9e27493c027aa6d027d3e257 /graphics/qgis
parenta0a8e4e20f12270cebfd8386080521533672b79d (diff)
downloadports-e726c6178fc10fcce1b6796eb362aaa853e05a6a.tar.gz
ports-e726c6178fc10fcce1b6796eb362aaa853e05a6a.zip
Notes
Diffstat (limited to 'graphics/qgis')
-rw-r--r--graphics/qgis/Makefile13
-rw-r--r--graphics/qgis/files/patch-gcc4287
-rw-r--r--graphics/qgis/pkg-plist8
3 files changed, 95 insertions, 13 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index ee8f4374554a..7bc111afa32f 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -9,11 +9,10 @@ PORTNAME= qgis
PORTVERSION= 0.7.4
PORTREVISION= 3
CATEGORIES= graphics geography
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
-MASTER_SITE_SUBDIR=${PORTNAME}
+MASTER_SITES= SF
-MAINTAINER= lrntct@gmail.com
-COMMENT= A Geographical Information System (GIS) data viewer
+MAINTAINER= dyeske@gmail.com
+COMMENT= Geographical Information System (GIS) data viewer
LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
proj:${PORTSDIR}/graphics/proj \
@@ -30,17 +29,13 @@ MAN1= qgis.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-qtdir=${QTDIR}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
OPTIONS= GRASS "Enable GRASS support" Off \
POSTGIS "Enable PostGIS support" Off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD versions prior to 5
-.endif
-
.if !defined (QTDIR)
QTDIR= ${QT_PREFIX}
.endif
diff --git a/graphics/qgis/files/patch-gcc42 b/graphics/qgis/files/patch-gcc42
new file mode 100644
index 000000000000..b292e9efefc7
--- /dev/null
+++ b/graphics/qgis/files/patch-gcc42
@@ -0,0 +1,87 @@
+--- src/qgsproject.h 2005-05-11 19:21:56.000000000 -0800
++++ src2/qgsproject.h 2007-08-14 00:23:04.000000000 -0800
+@@ -95,9 +95,9 @@
+ write()
+ */
+ //@{
+- bool QgsProject::dirty() const;
++ bool dirty() const;
+
+- void QgsProject::dirty( bool b );
++ void dirty( bool b );
+ //@}
+
+
+--- src/qgsrasterlayerproperties.h 2005-07-30 21:03:14.000000000 -0800
++++ src2/qgsrasterlayerproperties.h 2007-08-14 00:29:06.000000000 -0800
+@@ -69,7 +69,7 @@
+ /** \brief slot executed when the three band radio button is pressed. */
+ void rbtnThreeBand_toggled( bool );
+ /** \brief slot executed when user wishes to refresh raster histogram */
+- void QgsRasterLayerProperties::pbnHistRefresh_clicked();
++ void pbnHistRefresh_clicked();
+ /** Override the SRS specified when the layer was loaded */
+ void pbnChangeSpatialRefSys_clicked();
+
+--- src/qgsprojectproperties.h 2005-10-23 16:00:18.000000000 -0800
++++ src2/qgsprojectproperties.h 2007-08-14 00:32:22.000000000 -0800
+@@ -60,7 +60,7 @@
+ /*! Accessor for projection */
+ QString projectionWKT();
+ /*! Indicates that the projection switch is on */
+- bool QgsProjectProperties::isProjected();
++ bool isProjected();
+ public slots:
+ /*!
+ * Slot called when a new button (unit) is selected
+
+--- src/qgslabel.h.orig 2005-06-03 01:42:55.000000000 -0800
++++ src/qgslabel.h 2007-08-14 02:12:34.000000000 -0800
+@@ -91,7 +91,7 @@
+ void addRequiredFields ( std::list<int> *fields );
+
+ //! Available vector fields
+- std::vector<QgsField> & QgsLabel::fields ( void );
++ std::vector<QgsField> & fields ( void );
+
+ //! Pointer to default attributes
+ QgsLabelAttributes *layerAttributes ( void );
+
+--- providers/gpx/qgsgpxprovider.h.orig 2005-02-11 14:36:49.000000000 -0900
++++ providers/gpx/qgsgpxprovider.h 2007-08-14 12:03:47.000000000 -0800
+@@ -142,7 +142,7 @@
+ const std::map<QString, QString>& attrs);
+
+ /** Adds one feature (used by addFeatures()) */
+- bool QgsGPXProvider::addFeature(QgsFeature* f);
++ bool addFeature(QgsFeature* f);
+
+ /**Returns the default value for attribute @c attr for feature @c f. */
+ QString getDefaultValue(const QString& attr, QgsFeature* f);
+
+--- plugins/georeferencer/datapointacetate.h.orig 2005-05-01 12:23:17.000000000 -0800
++++ plugins/georeferencer/datapointacetate.h 2007-08-14 12:34:48.000000000 -0800
+@@ -13,7 +13,7 @@
+ class DataPointAcetate : public QgsAcetateObject {
+ public:
+
+- DataPointAcetate::DataPointAcetate(const QgsPoint& pixelCoords,
++ DataPointAcetate(const QgsPoint& pixelCoords,
+ const QgsPoint& mapCoords)
+ // UGLY!
+ : QgsAcetateObject(const_cast<QgsPoint&>(pixelCoords)),
+
+--- plugins/grid_maker/graticulecreator.h.orig 2005-05-29 12:04:47.000000000 -0800
++++ plugins/grid_maker/graticulecreator.h 2007-08-14 13:13:03.000000000 -0800
+@@ -19,8 +19,8 @@
+ double theXEndPointDouble,
+ double theYEndPointDouble);
+ ~GraticuleCreator() {};
+- DBFHandle GraticuleCreator::createDbf (QString theDbfName ) ;
+- SHPHandle GraticuleCreator::createShapeFile(QString theFileName );
++ DBFHandle createDbf (QString theDbfName ) ;
++ SHPHandle createShapeFile(QString theFileName );
+ void writeDbfRecord (DBFHandle theDbfHandle, int theRecordIdInt, QString theLabel) ;
+ void writePoint(SHPHandle theShapeHandle, int theRecordInt, double theXDouble, double y );
+ //! Writes a WGS 84 .prj file for the generated grid
+
diff --git a/graphics/qgis/pkg-plist b/graphics/qgis/pkg-plist
index fa65f5432c5b..b06b6fb0fe62 100644
--- a/graphics/qgis/pkg-plist
+++ b/graphics/qgis/pkg-plist
@@ -586,9 +586,9 @@ share/aclocal/qgis.m4
@dirrm %%DATADIR%%/doc/plugins/geoprocessing
@dirrm %%DATADIR%%/doc/plugins
@dirrm %%DATADIR%%/doc
-@dirrm %%DATADIR%%/grass/config
-@dirrm %%DATADIR%%/grass/modules
-@dirrm %%DATADIR%%/grass
+%%GRASS%%@dirrm %%DATADIR%%/grass/config
+%%GRASS%%@dirrm %%DATADIR%%/grass/modules
+%%GRASS%%@dirrm %%DATADIR%%/grass
@dirrm %%DATADIR%%/i18n
@dirrm %%DATADIR%%/images/developers
@dirrm %%DATADIR%%/images/icons
@@ -603,7 +603,7 @@ share/aclocal/qgis.m4
@dirrm %%DATADIR%%/svg/north_arrows
@dirrm %%DATADIR%%/svg/symbol
@dirrm %%DATADIR%%/svg
-@dirrm %%DATADIR%%/themes/default/grass
+%%GRASS%%@dirrm %%DATADIR%%/themes/default/grass
@dirrm %%DATADIR%%/themes/default
@dirrm %%DATADIR%%/themes/nkids
@dirrm %%DATADIR%%/themes