aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-30 14:27:27 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-30 14:27:27 +0000
commitafb550e3cf83ca6a9d25a40d91f5208b3c36f9f2 (patch)
treefb95bc5acb82022c6c68c02f6e263d6524f02ae6 /graphics/qgis
parent258a4596278aa7d7052491adbf5e259c8c73465f (diff)
Notes
Diffstat (limited to 'graphics/qgis')
-rw-r--r--graphics/qgis/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index e1fd096bb751..0964eb67bb92 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qgis
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/qgis/src/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -26,7 +27,7 @@ USE_QT_VER= 4
USE_SQLITE= yes
CMAKE_USE_PTHREAD= yes
CMAKE_ENV+= QMAKESPEC=${QMAKESPEC}
-QT_COMPONENTS= gui svg xml network sql linguist \
+QT_COMPONENTS= gui svg xml network sql designer linguist_build \
qmake_build moc_build rcc_build uic_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -36,7 +37,7 @@ USE_LDCONFIG= yes
OPTIONS= GRASS "Enable GRASS support" Off \
POSTGIS "Enable PostGIS support" Off \
- PYTHON "Enable Python support" On
+ PYTHON "Enable Python (broken with sip-4.10)" Off
.include <bsd.port.pre.mk>
@@ -65,6 +66,7 @@ PLIST_SUB+= PGSQL="@comment "
.if defined(WITHOUT_PYTHON)
PLIST_SUB+= QGIS_PYTHON="@comment "
.else
+IGNORE= doesn't compile with devel/py-sip>=4.10
PLIST_SUB+= QGIS_PYTHON=""
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sip>=4.8.2:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-gui>=4.5.4:${PORTSDIR}/x11-toolkits/py-qt4-gui \