aboutsummaryrefslogtreecommitdiff
path: root/graphics/qglviewer/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 08:56:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 08:56:41 +0000
commit9be9c4c1dafe17e16a81322515a375b6574e2bb7 (patch)
tree9ae73276b422d1766d18a0fdeeb964c5f2073690 /graphics/qglviewer/Makefile
parentd140c906251172c4ac876b6be49313c67918650f (diff)
downloadports-9be9c4c1dafe17e16a81322515a375b6574e2bb7.tar.gz
ports-9be9c4c1dafe17e16a81322515a375b6574e2bb7.zip
Notes
Diffstat (limited to 'graphics/qglviewer/Makefile')
-rw-r--r--graphics/qglviewer/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/graphics/qglviewer/Makefile b/graphics/qglviewer/Makefile
deleted file mode 100644
index baaea04ebcb1..000000000000
--- a/graphics/qglviewer/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: qglviewer
-# Date created: Dec 18, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= qglviewer
-PORTVERSION= 1.4
-PORTREVISION= 8
-CATEGORIES= graphics
-MASTER_SITES= http://www.gris.uni-tuebingen.de/grisalt/projects/qglviewer/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Use OpenGL to play around with three dimensional scenes
-
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
-
-USE_AUTOTOOLS= libtool
-USE_QT_VER= 3
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-
-QTCPPFLAGS+= ${PTHREAD_CFLAGS}
-QTCFGLIBS+= ${PTHREAD_LIBS}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lqt"|-lqt-mt ${PTHREAD_LIBS}"|g ; \
- s|-lqt -lqgl"|-lqt-mt -lqtgl ${PTHREAD_LIBS}"|g ; \
- s|/moc|/${MOC:T}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|^SUBDIRS =.*$$|SUBDIRS = src include|g ; \
- s| install-pkgdocDATA||g' ${WRKSRC}/Makefile.in
-
-pre-build:
- -@${RM} ${WRKSRC}/src/QCameraKeyPathEditor.h
- -@${RM} ${WRKSRC}/src/QLightSourceEditor.h
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/html/*.css ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/html/*.html ${DOCSDIR}/html
-.endif
-
-.include <bsd.port.mk>