aboutsummaryrefslogtreecommitdiff
path: root/graphics/qiviewer
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2016-08-23 06:57:24 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2016-08-23 06:57:24 +0000
commit6eaf6b05cbe72371fc2001af583d223fdb24c7b7 (patch)
tree4a782259169ca1c82d6c8949d6cd73c18c2edf22 /graphics/qiviewer
parent0e40f4eef56f1da55d1699baf56d7ffd64b4aeae (diff)
Notes
Diffstat (limited to 'graphics/qiviewer')
-rw-r--r--graphics/qiviewer/Makefile2
-rw-r--r--graphics/qiviewer/files/patch-main.cpp13
2 files changed, 14 insertions, 1 deletions
diff --git a/graphics/qiviewer/Makefile b/graphics/qiviewer/Makefile
index 59bb982c3740..b92d5acf06c7 100644
--- a/graphics/qiviewer/Makefile
+++ b/graphics/qiviewer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qiviewer
PORTVERSION= 0.5.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
diff --git a/graphics/qiviewer/files/patch-main.cpp b/graphics/qiviewer/files/patch-main.cpp
new file mode 100644
index 000000000000..e33b65228af9
--- /dev/null
+++ b/graphics/qiviewer/files/patch-main.cpp
@@ -0,0 +1,13 @@
+--- main.cpp.orig 2011-05-19 03:38:25 UTC
++++ main.cpp
+@@ -115,6 +115,10 @@ int main(int argc, char *argv[])
+
+ else if (next_option == -1)
+ {
++ // Strip file://, added by some file browsers
++ if ( memcmp(argv[1], "file://", 7) == 0 )
++ memmove(argv[1], argv[1]+7, strlen(argv[1]) - 6);
++ puts(argv[1]);
+ MainWindow imageViewer;
+ if (QApplication::arguments().size() > 1)
+ imageViewer.openImageFromCommandLine(QApplication::arguments());