aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-10-13 23:15:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-10-13 23:15:50 +0000
commitecda38b0a51979110b18b1bcd5f03f5b6a55e13a (patch)
tree6e4bc973485641dceb988b7456b64a08077dafe0 /graphics/qt4-imageformats
parent28bc26a55d939847edf4effb4c33cf5f20d879f0 (diff)
downloadports-ecda38b0a51979110b18b1bcd5f03f5b6a55e13a.tar.gz
ports-ecda38b0a51979110b18b1bcd5f03f5b6a55e13a.zip
Notes
Diffstat (limited to 'graphics/qt4-imageformats')
-rw-r--r--graphics/qt4-imageformats/Makefile5
-rw-r--r--graphics/qt4-imageformats/files/patch-git_ccd1b2ee35
2 files changed, 3 insertions, 37 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index f473fe8345cc..1641fbd10e16 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -18,6 +18,8 @@ USE_QT4= qmake_build moc_build rcc_build corelib gui svg xml
QT_NONSTANDARD= yes
QT_DIST= yes
+USES= pkgconfig
+
HAS_CONFIGURE= yes
ALL_TARGET= first
@@ -40,9 +42,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-NO_STAGE= yes
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
diff --git a/graphics/qt4-imageformats/files/patch-git_ccd1b2ee b/graphics/qt4-imageformats/files/patch-git_ccd1b2ee
deleted file mode 100644
index a545ee951984..000000000000
--- a/graphics/qt4-imageformats/files/patch-git_ccd1b2ee
+++ /dev/null
@@ -1,35 +0,0 @@
-commit ccd1b2ee01c193cd157978c1f9f08f87d0f9c94b
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Fri May 10 01:40:23 2013 +0300
-
- Check that 3DNow! instructions are supported before including mm3dnow.h.
-
- Include mm3dnow.h the way we already include the (S)SSE{3,4} and AVX
- instruction headers: by checking that the compiler is set to support those
- instructions besides verifying that QT_HAVE_3DNOW evalues to true (which
- only means the compiler supported them when the build was being configured).
-
- This has not caused a problem in most cases so far because GCC protects its
- mm3dnow.h header with an #ifdef __3dNOW__ (contrary to what it does on, say,
- pmmintrin.h). clang's mm3dnow.h, on the other hand, does not have that check
- and can fail if -march is set to, for example, i386 or i486.
-
- Not backported from qt5 because qtbase because qsimd_p.h does not include
- the 3DNow! headers after commit a1b30b49ef09bef2e97b9a0622bf7ad622678fee.
-
- Change-Id: I15ab5e936c71c55f89c3f25777ab27fbd262e9cd
- Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-
-diff --git a/src/corelib/tools/qsimd_p.h b/src/corelib/tools/qsimd_p.h
-index 87e26e1..6a32e8f 100644
---- ./src/corelib/tools/qsimd_p.h
-+++ ./src/corelib/tools/qsimd_p.h
-@@ -199,7 +199,7 @@ QT_BEGIN_HEADER
- #endif
-
- // 3D now intrinsics
--#if defined(QT_HAVE_3DNOW)
-+#if defined(QT_HAVE_3DNOW) && (defined(__3dNOW__) || defined(Q_CC_MSVC))
- #include <mm3dnow.h>
- #endif
-