aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
commit7d5e6b666c579d543fbf4c0996e309e23de8e02e (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /graphics/qt4-imageformats
parentb60b2bc8f43a72af43a1f5ff0df9828880c2b7a8 (diff)
downloadports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.tar.gz
ports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.zip
Notes
Diffstat (limited to 'graphics/qt4-imageformats')
-rw-r--r--graphics/qt4-imageformats/Makefile24
-rw-r--r--graphics/qt4-imageformats/pkg-descr12
2 files changed, 10 insertions, 26 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 1641fbd10e16..8088c2eea1d6 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -3,23 +3,21 @@
PORTNAME= imageformats
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= graphics
+CATEGORIES= graphics
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt imageformat plugins for GIF, JPEG, MNG and SVG
+COMMENT= Qt plugins for several image formats
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- mng:${PORTSDIR}/graphics/libmng \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libmng.so:${PORTSDIR}/graphics/libmng \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
+USES= pkgconfig
USE_QT4= qmake_build moc_build rcc_build corelib gui svg xml
-QT_NONSTANDARD= yes
QT_DIST= yes
-USES= pkgconfig
-
HAS_CONFIGURE= yes
ALL_TARGET= first
@@ -42,12 +40,10 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+ ${LN} -sf ${MOC} ${WRKSRC}/bin/moc
+ ${LN} -sf ${RCC} ${WRKSRC}/bin/rcc
.include <bsd.port.mk>
diff --git a/graphics/qt4-imageformats/pkg-descr b/graphics/qt4-imageformats/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/graphics/qt4-imageformats/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html