aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-imageformats
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
commit43902f6ecc0189b88ec79a03b8b0b39425aa18dd (patch)
tree5b488e99af499ef5ed89d0b90cc3f0f14b1f1ad4 /graphics/qt4-imageformats
parent5534788943950923c05e59a02337cde792233450 (diff)
downloadports-43902f6ecc0189b88ec79a03b8b0b39425aa18dd.tar.gz
ports-43902f6ecc0189b88ec79a03b8b0b39425aa18dd.zip
Notes
Diffstat (limited to 'graphics/qt4-imageformats')
-rw-r--r--graphics/qt4-imageformats/Makefile29
-rw-r--r--graphics/qt4-imageformats/pkg-descr2
-rw-r--r--graphics/qt4-imageformats/pkg-plist27
3 files changed, 31 insertions, 27 deletions
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 4fdfb4e9eaf1..9c21375da7ac 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -8,7 +8,6 @@
PORTNAME= imageformats
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 0
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
@@ -34,23 +33,27 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/dbus src/network src/opengl src/phonon \
- src/qt3support src/script src/sql src/testlib \
- src/tools src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
-EXTRACT_AFTER_ARGS= |${TAR} -xf -
+ src/activeqt src/dbus src/multimedia src/network src/opengl \
+ src/openvg src/phonon src/qt3support src/s60installs \
+ src/s60main src/script src/scripttools src/sql src/testlib \
+ src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../..
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
.include <bsd.port.mk>
diff --git a/graphics/qt4-imageformats/pkg-descr b/graphics/qt4-imageformats/pkg-descr
index efc79b9aaf24..36bc69717e98 100644
--- a/graphics/qt4-imageformats/pkg-descr
+++ b/graphics/qt4-imageformats/pkg-descr
@@ -9,4 +9,4 @@ the application programmer with a single, common API for all operating systems.
The native C APIs are encapsulated in a set of well-designed, fully
object-oriented C++ classes.
-WWW: http://www.trolltech.com/products/qt/index.html
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/graphics/qt4-imageformats/pkg-plist b/graphics/qt4-imageformats/pkg-plist
index 1b01f5eb0bca..5040b1e318f7 100644
--- a/graphics/qt4-imageformats/pkg-plist
+++ b/graphics/qt4-imageformats/pkg-plist
@@ -1,13 +1,14 @@
-lib/qt4/plugins/imageformats/libqgif.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqgif.so.debug
-lib/qt4/plugins/imageformats/libqjpeg.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqjpeg.so.debug
-lib/qt4/plugins/imageformats/libqmng.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqmng.so.debug
-lib/qt4/plugins/imageformats/libqsvg.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqsvg.so.debug
-lib/qt4/plugins/imageformats/libqtiff.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqtiff.so.debug
-lib/qt4/plugins/imageformats/libqico.so
-%%DEBUG%%lib/qt4/plugins/imageformats/libqico.so.debug
-@dirrmtry lib/qt4/plugins/imageformats
+%%QT_PLUGINDIR_REL%%/imageformats/libqgif.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqgif.so.debug
+%%QT_PLUGINDIR_REL%%/imageformats/libqjpeg.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqjpeg.so.debug
+%%QT_PLUGINDIR_REL%%/imageformats/libqmng.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqmng.so.debug
+%%QT_PLUGINDIR_REL%%/imageformats/libqsvg.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqsvg.so.debug
+%%QT_PLUGINDIR_REL%%/imageformats/libqtiff.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqtiff.so.debug
+%%QT_PLUGINDIR_REL%%/imageformats/libqico.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/imageformats/libqico.so.debug
+@dirrm %%QT_PLUGINDIR_REL%%/imageformats
+@dirrmtry %%QT_PLUGINDIR_REL%%