aboutsummaryrefslogtreecommitdiff
path: root/graphics/qtgtl
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2009-12-08 12:00:52 +0000
committerDima Panov <fluffy@FreeBSD.org>2009-12-08 12:00:52 +0000
commitd9b7c5c724fbde5a25c15d594ec886ab24422c13 (patch)
tree842c5e9d4baefdb32195ccdb06819c859b86d73e /graphics/qtgtl
parent4439b5857f9bece90e1d4058709ffa51f7ddfb93 (diff)
Notes
Diffstat (limited to 'graphics/qtgtl')
-rw-r--r--graphics/qtgtl/Makefile31
-rw-r--r--graphics/qtgtl/distinfo3
-rw-r--r--graphics/qtgtl/pkg-descr18
-rw-r--r--graphics/qtgtl/pkg-plist15
4 files changed, 67 insertions, 0 deletions
diff --git a/graphics/qtgtl/Makefile b/graphics/qtgtl/Makefile
new file mode 100644
index 000000000000..451d37ff62e5
--- /dev/null
+++ b/graphics/qtgtl/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: qtgtl
+# Date created: 28 September 2009
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+# $FreeBSD$
+
+PORTNAME= qtgtl
+PORTVERSION= 0.9.0
+CATEGORIES= graphics devel
+MASTER_SITES= http://www.opengtl.org/download/
+DISTNAME= libQtGTL-${PORTVERSION}
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= Qt bindings for the Graphics Transformation Languages
+
+LIB_DEPENDS= GTLCore.0:${PORTSDIR}/graphics/opengtl
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|set(QTGTL_LIB_SOVERSION.*|set(QTGTL_LIB_SOVERSION "0")|' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${PATCH_WRKSRC}/QtGTL/CMakeLists.txt \
+ ${PATCH_WRKSRC}/QtShiva/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/graphics/qtgtl/distinfo b/graphics/qtgtl/distinfo
new file mode 100644
index 000000000000..1f5ef2161bd9
--- /dev/null
+++ b/graphics/qtgtl/distinfo
@@ -0,0 +1,3 @@
+MD5 (libQtGTL-0.9.0.tar.bz2) = 9a6b817496cee29bd11b641110ae775e
+SHA256 (libQtGTL-0.9.0.tar.bz2) = 24f782fe795ad02bd9719828477a63736fa8108b16dafa599ac68d503076dccd
+SIZE (libQtGTL-0.9.0.tar.bz2) = 17934
diff --git a/graphics/qtgtl/pkg-descr b/graphics/qtgtl/pkg-descr
new file mode 100644
index 000000000000..dc62596f782f
--- /dev/null
+++ b/graphics/qtgtl/pkg-descr
@@ -0,0 +1,18 @@
+The Graphics Transformation Languages is a set of libraries for using and
+integrating transformation algorithms (such as filter or color conversion) in
+graphics applications.
+The goal is to provide the tools, languages and libraries to create generic
+transformation for graphics. Those transformations could then be used by
+different programs (Krita, The Gimp, CinePaint, gegl...).
+
+Currently the focus is on developing two languages, designed for two different
+implementations.
+- OpenCTL which is a GPL compatible of the Color Transformation Language, this
+ language is dedicated at transforming the value of a single pixel (for
+ instance brightness adjustement or desaturate). CTL is designed to be part of
+ the Color Management process.
+- OpenShiva is inspired by Adobe's Hydra language from the AIF Toolkit, Shiva
+ is a language that apply a kernel-like transformations on an image, that means
+ it works using more than one pixel.
+
+WWW: http://opengtl.org
diff --git a/graphics/qtgtl/pkg-plist b/graphics/qtgtl/pkg-plist
new file mode 100644
index 000000000000..770bf72236e3
--- /dev/null
+++ b/graphics/qtgtl/pkg-plist
@@ -0,0 +1,15 @@
+include/QtGTL/QImageBuffer.h
+include/QtGTL/QImageImage.h
+include/QtShiva/KernelParametersWidget.h
+include/QtShiva/ParametersWidgetBase.h
+include/QtShiva/SourceParametersWidget.h
+lib/libQtGTL.so
+lib/libQtGTL.so.0
+lib/libQtGTL.so.0.9.0
+lib/libQtShiva.so
+lib/libQtShiva.so.0
+lib/libQtShiva.so.0.9.0
+libdata/pkgconfig/QtGTL.pc
+libdata/pkgconfig/QtShiva.pc
+@dirrm include/QtShiva
+@dirrm include/QtGTL