aboutsummaryrefslogtreecommitdiff
path: root/graphics/qtutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-05 16:34:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-05 16:34:28 +0000
commit9cb98c1f1fc0cfc5b398fc310fa863f724353d7a (patch)
tree10290d408b57afc0d5aec65cf0138f4486e6267b /graphics/qtutils
parent81c9323df7338462d1735d80a077b9566e2ea5be (diff)
Notes
Diffstat (limited to 'graphics/qtutils')
-rw-r--r--graphics/qtutils/Makefile43
-rw-r--r--graphics/qtutils/distinfo3
-rw-r--r--graphics/qtutils/files/patch-src-usage_qtconv.c62
-rw-r--r--graphics/qtutils/files/patch-src-usage_qtsg.c47
-rw-r--r--graphics/qtutils/files/patch-src-usage_qtsplit.c42
-rw-r--r--graphics/qtutils/pkg-descr8
-rw-r--r--graphics/qtutils/pkg-plist6
7 files changed, 0 insertions, 211 deletions
diff --git a/graphics/qtutils/Makefile b/graphics/qtutils/Makefile
deleted file mode 100644
index f31684a4b77d..000000000000
--- a/graphics/qtutils/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: qtutils
-# Date created: Sep 5, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= qtutils
-PORTVERSION= 0.0.6
-PORTREVISION= 5
-CATEGORIES= graphics
-MASTER_SITES= http://www.flyn.org/projects/qtutils/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= QuickTime Utilities
-
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
- quicktime.0:${PORTSDIR}/multimedia/libquicktime
-
-BROKEN= Does not build
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
-USE_GNOME= glib12
-USE_GETOPT_LONG=yes
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-
-MAN1= qtconv.1 qtsg.1 qtsplit.1
-
-CPPFLAGS= -I${LOCALBASE}/include `${GLIB_CONFIG} --cflags gthread`
-LDFLAGS= -L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-g -Wall|@CFLAGS@|g ; \
- s|-lglib||g ; \
- s|-lpthread||g ; \
- s|-ldl||g' ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's|quicktime/quicktime.h|lqt/quicktime.h|' ${WRKSRC}/src/*.c
-
-.include <bsd.port.mk>
diff --git a/graphics/qtutils/distinfo b/graphics/qtutils/distinfo
deleted file mode 100644
index 6e3cd458768d..000000000000
--- a/graphics/qtutils/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (qtutils-0.0.6.tar.gz) = 0f9d3e5da8277bfaa87068d6ef397ff0
-SHA256 (qtutils-0.0.6.tar.gz) = 2263ca3bb2207d78c52243d7239c9757fab7385e039b72ebb8aaf4a329651a72
-SIZE (qtutils-0.0.6.tar.gz) = 195295
diff --git a/graphics/qtutils/files/patch-src-usage_qtconv.c b/graphics/qtutils/files/patch-src-usage_qtconv.c
deleted file mode 100644
index 849b1c597d6f..000000000000
--- a/graphics/qtutils/files/patch-src-usage_qtconv.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- src/usage_qtconv.c.orig Wed Oct 15 14:54:23 2003
-+++ src/usage_qtconv.c Wed Oct 15 14:56:10 2003
-@@ -1,36 +1,35 @@
--char *usage_qtconv = "
-+char *usage_qtconv = ""
-
-- _________________________________________________________________
-+ "_________________________________________________________________"
-
-- Table of Contents
-+ "Table of Contents"
-
-- qtconv [option]...
-+ "qtconv [option]..."
-
-- -h, --help
-- Print a list of options
-+ "-h, --help"
-+ "Print a list of options"
-
-- -a, --audio=codec
-- Set target audio codec
-+ "-a, --audio=codec"
-+ "Set target audio codec"
-
-- -v, --video=codec
-- Set target video codec
-+ "-v, --video=codec"
-+ "Set target video codec"
-
-- -i, --input=path
-- Set the input QuickTime file
-+ "-i, --input=path"
-+ "Set the input QuickTime file"
-
-- -o, --output=path
-- Set the output QuickTime file
-+ "-o, --output=path"
-+ "Set the output QuickTime file"
-
-- -q, --quality=int
-- Set the quality used for JPEG or MJPA encoding
-+ "-q, --quality=int"
-+ "Set the quality used for JPEG or MJPA encoding"
-
-- -c, --cpus=int
-- Set the number of CPUs to use for MJPA encoding
-+ "-c, --cpus=int"
-+ "Set the number of CPUs to use for MJPA encoding"
-
--References
-+"References"
-
-- Visible links
-- Hidden links:
-- 1. file://localhost/tmp/xmlto.UQmNyB/usage_wrapper_qtconv.proc#id2752075
-- 2. file://localhost/tmp/xmlto.UQmNyB/usage_wrapper_qtconv.proc#id2750574
--";
-+ "Visible links"
-+ "Hidden links:"
-+ "1. file://localhost/tmp/xmlto.UQmNyB/usage_wrapper_qtconv.proc#id2752075"
-+ "2. file://localhost/tmp/xmlto.UQmNyB/usage_wrapper_qtconv.proc#id2750574";
diff --git a/graphics/qtutils/files/patch-src-usage_qtsg.c b/graphics/qtutils/files/patch-src-usage_qtsg.c
deleted file mode 100644
index 3a4eb8a115d2..000000000000
--- a/graphics/qtutils/files/patch-src-usage_qtsg.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/usage_qtsg.c.orig Sat Jun 8 12:39:00 2002
-+++ src/usage_qtsg.c Wed Oct 15 14:53:16 2003
-@@ -1,27 +1,26 @@
--char *usage_qtsg = "
-+char *usage_qtsg = ""
-
-- _________________________________________________________________
-+ "_________________________________________________________________"
-
-- Table of Contents
-+ "Table of Contents"
-
-- qtsg [option]... image...
-+ "qtsg [option]... image..."
-
-- -o, --output=path
-- The path to the QuickTime output
-+ "-o, --output=path"
-+ "The path to the QuickTime output"
-
-- -a, --audio=path
-- The path to the Ogg Vorbis encoded soundtrack
-+ "-a, --audio=path"
-+ "The path to the Ogg Vorbis encoded soundtrack"
-
-- -c, --acodec=codec
-- Audio codec to use in output
-+ "-c, --acodec=codec"
-+ "Audio codec to use in output"
-
-- -r, --rate=rate
-- Frame rate of output video
-+ "-r, --rate=rate"
-+ "Frame rate of output video"
-
--References
-+"References"
-
-- Visible links
-- Hidden links:
-- 1. file://localhost/tmp/xmlto.HiIPRu/usage_wrapper_qtsg.proc#id2752075
-- 2. file://localhost/tmp/xmlto.HiIPRu/usage_wrapper_qtsg.proc#id2750577
--";
-+ "Visible links"
-+ "Hidden links:"
-+ "1. file://localhost/tmp/xmlto.HiIPRu/usage_wrapper_qtsg.proc#id2752075"
-+ "2. file://localhost/tmp/xmlto.HiIPRu/usage_wrapper_qtsg.proc#id2750577";
diff --git a/graphics/qtutils/files/patch-src-usage_qtsplit.c b/graphics/qtutils/files/patch-src-usage_qtsplit.c
deleted file mode 100644
index 41ae1d677100..000000000000
--- a/graphics/qtutils/files/patch-src-usage_qtsplit.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/usage_qtsplit.c.orig Wed Oct 15 14:57:09 2003
-+++ src/usage_qtsplit.c Wed Oct 15 14:58:40 2003
-@@ -1,24 +1,23 @@
--char *usage_qtsplit = "
-+char *usage_qtsplit = ""
-
-- _________________________________________________________________
-+ "_________________________________________________________________"
-
-- Table of Contents
-+ "Table of Contents"
-
-- qtsg [option]...
-+ "qtsg [option]..."
-
-- -i, --input=path
-- The path to the QuickTime input
-+ "-i, --input=path"
-+ "The path to the QuickTime input"
-
-- -o, --output=path
-- The path to the QuickTime output (should contain %d)
-+ "-o, --output=path"
-+ "The path to the QuickTime output (should contain %d)"
-
-- -s, --size=int
-- The maximum size of the split files
-+ "-s, --size=int"
-+ "The maximum size of the split files"
-
--References
-+"References"
-
-- Visible links
-- Hidden links:
-- 1. file://localhost/tmp/xmlto.Mjwffz/usage_wrapper_qtsplit.proc#id2754184
-- 2. file://localhost/tmp/xmlto.Mjwffz/usage_wrapper_qtsplit.proc#id2750586
--";
-+ "Visible links"
-+ "Hidden links:"
-+ "1. file://localhost/tmp/xmlto.Mjwffz/usage_wrapper_qtsplit.proc#id2754184"
-+ "2. file://localhost/tmp/xmlto.Mjwffz/usage_wrapper_qtsplit.proc#id2750586";
diff --git a/graphics/qtutils/pkg-descr b/graphics/qtutils/pkg-descr
deleted file mode 100644
index a21dc9c717ae..000000000000
--- a/graphics/qtutils/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Qtutils is a collection of command line programs for manipulating QuickTime
-videos. It includes, among other things, qtconv, which allows one to change
-the codec used by a QT file, qtsplit, which splits a QT file into several
-smaller QT files, and qtsg, which creates a QT slideshow from a series of
-images and a soundtrack. A script named vcdize also allows you to create
-VCDs or SVCDs out of QuickTime sources.
-
-WWW: http://www.flyn.org/projects/qtutils/index.html
diff --git a/graphics/qtutils/pkg-plist b/graphics/qtutils/pkg-plist
deleted file mode 100644
index 7bea0b963ba7..000000000000
--- a/graphics/qtutils/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/mpegize
-bin/qtconv
-bin/qtsg
-bin/qtsplit
-bin/screenqt
-bin/vcdize