aboutsummaryrefslogtreecommitdiff
path: root/graphics/qtutils
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 03:57:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-05 03:57:58 +0000
commiteda5b04d83733af7bbe2c84a7ae0ab77c9f8ccec (patch)
tree9767bb4eb5b503c176ab51d9a83e0d4217bdd8ff /graphics/qtutils
parentef21ecebedb516895db8945de2373d446c6d4464 (diff)
downloadports-eda5b04d83733af7bbe2c84a7ae0ab77c9f8ccec.tar.gz
ports-eda5b04d83733af7bbe2c84a7ae0ab77c9f8ccec.zip
Notes
Diffstat (limited to 'graphics/qtutils')
-rw-r--r--graphics/qtutils/Makefile35
-rw-r--r--graphics/qtutils/distinfo1
-rw-r--r--graphics/qtutils/pkg-comment1
-rw-r--r--graphics/qtutils/pkg-descr8
-rw-r--r--graphics/qtutils/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/graphics/qtutils/Makefile b/graphics/qtutils/Makefile
new file mode 100644
index 000000000000..61e0d884314c
--- /dev/null
+++ b/graphics/qtutils/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: qtutils
+# Date created: Sep 5, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= qtutils
+PORTVERSION= 0.0.6
+CATEGORIES= graphics
+MASTER_SITES= http://www.flyn.org/projects/qtutils/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
+ quicktime:${PORTSDIR}/graphics/libquicktime \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= qtconv.1 qtsg.1 qtsplit.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" \
+ -e "s,-lglib,-lglib12,g" -e "s,-ldl,,g" ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/qtutils/distinfo b/graphics/qtutils/distinfo
new file mode 100644
index 000000000000..ff648defa187
--- /dev/null
+++ b/graphics/qtutils/distinfo
@@ -0,0 +1 @@
+MD5 (qtutils.tar.gz) = 0f9d3e5da8277bfaa87068d6ef397ff0
diff --git a/graphics/qtutils/pkg-comment b/graphics/qtutils/pkg-comment
new file mode 100644
index 000000000000..46e5c7aa6c54
--- /dev/null
+++ b/graphics/qtutils/pkg-comment
@@ -0,0 +1 @@
+QuickTime Utilities
diff --git a/graphics/qtutils/pkg-descr b/graphics/qtutils/pkg-descr
new file mode 100644
index 000000000000..d9b1ed9b8974
--- /dev/null
+++ b/graphics/qtutils/pkg-descr
@@ -0,0 +1,8 @@
+Qtutils is a collection of command line programs for manipulating QuickTime
+videos. It includes, among other things, qtconv, which allows one to change
+the codec used by a QT file, qtsplit, which splits a QT file into several
+smaller QT files, and qtsg, which creates a QT slideshow from a series of
+images and a soundtrack. A script named vcdize also allows you to create
+VCDs or SVCDs out of QuickTime sources.
+
+WWW: http://www.flyn.org/#id2755780
diff --git a/graphics/qtutils/pkg-plist b/graphics/qtutils/pkg-plist
new file mode 100644
index 000000000000..7bea0b963ba7
--- /dev/null
+++ b/graphics/qtutils/pkg-plist
@@ -0,0 +1,6 @@
+bin/mpegize
+bin/qtconv
+bin/qtsg
+bin/qtsplit
+bin/screenqt
+bin/vcdize