aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat-gui
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-16 10:30:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-16 10:30:29 +0000
commite0510c4400069b1a721e1d47071a9670565a9fac (patch)
tree65b4fc1303be3fd589ca1fbcb68f59b10c7e191e /graphics/quat-gui
parentae3ea9e54b11b7efcebafba42d907ab124435105 (diff)
downloadports-e0510c4400069b1a721e1d47071a9670565a9fac.tar.gz
ports-e0510c4400069b1a721e1d47071a9670565a9fac.zip
Notes
Diffstat (limited to 'graphics/quat-gui')
-rw-r--r--graphics/quat-gui/Makefile75
-rw-r--r--graphics/quat-gui/pkg-plist27
2 files changed, 44 insertions, 58 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 283133119a2b..d8a925df037c 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -1,61 +1,74 @@
-# New ports collection makefile for: quat-gui
-# Date created: 2 May 2002
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= quat
PORTVERSION= 1.20
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
-MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
+#MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
+MASTER_SITES= http://www.sourcefiles.org/Graphics/Fractals/
PKGNAMESUFFIX= -gui
-DISTNAME= quat-${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Three-dimensional fractal creator (X11 GUI)
+COMMENT= Three-dimensional fractal creator (X11 GUI)
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LICENSE= GPLv2 # (or later)
+
+LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
+
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
+
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
USE_XORG= xext
USE_GL= gl glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lXext -lGL" FLUID="${LOCALBASE}/bin/fluid"
-CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CONFIGURE_ENV= FLUID="${LOCALBASE}/bin/fluid"
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc
+MAKE_JOBS_SAFE= yes
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CFLAGS+= -O3 -ffast-math
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+
+PORTDOCS= *
+PLIST_FILES= bin/quat
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "You can enable additional compilation optimizations"
- @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+DESKTOP_ENTRIES="Quat" "3D Fractal Generator" "" "${PORTNAME}" "" ""
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CFLAGS+= -O3 -ffast-math
.endif
post-patch:
@${REINPLACE_CMD} -E -e \
- 's|^...CFLAGS=|#CFLAGS=|; \
- s|^...CXXFLAGS=|#CXXFLAGS=|' \
+ 's,-(march=pentium|O3|ffast-math),,g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -E -e 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
+ @${REINPLACE_CMD} -E -e \
+ 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
${WRKSRC}/gui/Makefile.in
- @${REINPLACE_CMD} -e 's|#include <FL/fl_file_chooser.H>|#include <FL/Fl_File_Chooser.H>|' \
+ @${REINPLACE_CMD} -e \
+ 's|<FL/fl_file_chooser.H>|<FL/Fl_File_Chooser.H>| ; \
+ s|/doc/quat/|/doc/${UNIQUENAME}/|' \
${WRKSRC}/gui/MainWindow.cxx
# disable data file installation since distfile does not do
# The Right Thing(TM)
@${REINPLACE_CMD} -E -e \
- 's|^(install-data-am:).*$$|\1|' \
+ 's|^(install-data-am:).*$$|\1| ; \
+ s|^(SUBDIRS.*)doc|\1|' \
${WRKSRC}/Makefile.in
-.ifdef NOPORTDOCS
- @${REINPLACE_CMD} '/install-data-am:/s/install-pkgdataDATA//' \
+ @${REINPLACE_CMD} -e \
+ 's|@PACKAGE@|${UNIQUENAME}|' \
${WRKSRC}/doc/Makefile.in
-.endif
-post-configure:
- @${REINPLACE_CMD} -E -e \
- 's|^(pkgdatadir).*$$|\1=${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}|' \
- ${WRKSRC}/doc/Makefile
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endif
.include <bsd.port.mk>
diff --git a/graphics/quat-gui/pkg-plist b/graphics/quat-gui/pkg-plist
index b14216ad9253..e69de29bb2d1 100644
--- a/graphics/quat-gui/pkg-plist
+++ b/graphics/quat-gui/pkg-plist
@@ -1,27 +0,0 @@
-bin/quat
-%%PORTDOCS%%share/quat-gui/Dendr_st.jpg
-%%PORTDOCS%%share/quat-gui/ce.png
-%%PORTDOCS%%share/quat-gui/chart_de.png
-%%PORTDOCS%%share/quat-gui/chart_us.png
-%%PORTDOCS%%share/quat-gui/ex_1.jpg
-%%PORTDOCS%%share/quat-gui/ex_2.jpg
-%%PORTDOCS%%share/quat-gui/ex_3.jpg
-%%PORTDOCS%%share/quat-gui/gpl.html
-%%PORTDOCS%%share/quat-gui/ie.png
-%%PORTDOCS%%share/quat-gui/oe.png
-%%PORTDOCS%%share/quat-gui/ote.png
-%%PORTDOCS%%share/quat-gui/quat-de-1.html
-%%PORTDOCS%%share/quat-gui/quat-de-2.html
-%%PORTDOCS%%share/quat-gui/quat-de-3.html
-%%PORTDOCS%%share/quat-gui/quat-de-4.html
-%%PORTDOCS%%share/quat-gui/quat-de-5.html
-%%PORTDOCS%%share/quat-gui/quat-de.html
-%%PORTDOCS%%share/quat-gui/quat-us-1.html
-%%PORTDOCS%%share/quat-gui/quat-us-2.html
-%%PORTDOCS%%share/quat-gui/quat-us-3.html
-%%PORTDOCS%%share/quat-gui/quat-us-4.html
-%%PORTDOCS%%share/quat-gui/quat-us-5.html
-%%PORTDOCS%%share/quat-gui/quat-us.html
-%%PORTDOCS%%share/quat-gui/quat.png
-%%PORTDOCS%%share/quat-gui/ve.png
-%%PORTDOCS%%@dirrm share/quat-gui