aboutsummaryrefslogtreecommitdiff
path: root/graphics/quesoglc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-05 22:47:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-05 22:47:22 +0000
commitc1e7bbb21edf1c953fdae3bf0f5b0821f32b0c8a (patch)
treec92c7c8d1b7b63ead617e68f7a1880677ad1a850 /graphics/quesoglc
parent7da6474727e138fe0913ebba368c6773a1fda279 (diff)
downloadports-c1e7bbb21edf1c953fdae3bf0f5b0821f32b0c8a.tar.gz
ports-c1e7bbb21edf1c953fdae3bf0f5b0821f32b0c8a.zip
Notes
Diffstat (limited to 'graphics/quesoglc')
-rw-r--r--graphics/quesoglc/Makefile41
-rw-r--r--graphics/quesoglc/distinfo3
-rw-r--r--graphics/quesoglc/files/patch-include-GL-glew.h10
-rw-r--r--graphics/quesoglc/pkg-descr26
-rw-r--r--graphics/quesoglc/pkg-plist9
5 files changed, 89 insertions, 0 deletions
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
new file mode 100644
index 000000000000..d607caa3a6ad
--- /dev/null
+++ b/graphics/quesoglc/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: quesoglc
+# Date created: 04 Jun 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quesoglc
+PORTVERSION= 0.7.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Free implementation of the OpenGL Character Renderer
+
+LIB_DEPENDS= fribidi.0:${PORTSDIR}/converters/fribidi \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_GL= gl glu glut
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+# needs GLEW MX (multiple rendering contexts), so system glew won't go
+CONFIGURE_ARGS= --without-glew --with-fribidi
+
+PORTDOCS= README
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/quesoglc/distinfo b/graphics/quesoglc/distinfo
new file mode 100644
index 000000000000..b7bb1cb7d488
--- /dev/null
+++ b/graphics/quesoglc/distinfo
@@ -0,0 +1,3 @@
+MD5 (quesoglc-0.7.2.tar.bz2) = 1c8d394d4f41fa0c5b08eb7ead73c4ef
+SHA256 (quesoglc-0.7.2.tar.bz2) = 54fef2ee685172df344d06ff4699a441143b87abed0d514524adc4f89ba4c931
+SIZE (quesoglc-0.7.2.tar.bz2) = 664466
diff --git a/graphics/quesoglc/files/patch-include-GL-glew.h b/graphics/quesoglc/files/patch-include-GL-glew.h
new file mode 100644
index 000000000000..a5e01115890f
--- /dev/null
+++ b/graphics/quesoglc/files/patch-include-GL-glew.h
@@ -0,0 +1,10 @@
+--- include/GL/glew.h.orig 2008-06-04 23:03:01.000000000 +0400
++++ include/GL/glew.h 2009-06-04 19:34:51.000000000 +0400
+@@ -2412,7 +2412,6 @@
+ #ifdef GLEW_APIENTRY_DEFINED
+ #undef GLEW_APIENTRY_DEFINED
+ #undef APIENTRY
+-#undef GLAPIENTRY
+ #endif
+
+ #ifdef GLEW_CALLBACK_DEFINED
diff --git a/graphics/quesoglc/pkg-descr b/graphics/quesoglc/pkg-descr
new file mode 100644
index 000000000000..519776dd3b6e
--- /dev/null
+++ b/graphics/quesoglc/pkg-descr
@@ -0,0 +1,26 @@
+The OpenGL Character Renderer (GLC) is a state machine that provides
+OpenGL programs with character rendering services via an application
+programming interface (API).
+
+The character rendering services provided by GLC has some significant
+advantages over platform specific interface such as GLX or WGL:
+
+1. The GLC API is platform independent. Since most nontrivial GL
+ applications render characters, GLC is an important step toward the
+ goal of truly portable GL applications.
+2. The GLC is simpler to use. Only two lines of GLC commands are
+ required to prepare for rendering characters.
+3. GLC provides more ways to exploit the rendering power of OpenGL.
+ For example, a glyph can be drawn as a bitmap, a set of lines, a
+ set of triangles, or a textured rectangle.
+4. GLC provides better support for glyph transformations. For
+ example, GLC supports rotated text, which is unavailable in GLX.
+5. GLC provides better support for the large coded character set
+ defined by the standards ISO/IEC 10646:2003 and Unicode 4.0.1
+
+QuesoGLC is a free (as in free speech) implementation of the GLC.
+QuesoGLC is based on the FreeType library, provides Unicode support
+and is designed to be easily ported to any platform that supports
+both FreeType and the OpenGL API.
+
+WWW: http://quesoglc.sourceforge.net/
diff --git a/graphics/quesoglc/pkg-plist b/graphics/quesoglc/pkg-plist
new file mode 100644
index 000000000000..b11d603c83ff
--- /dev/null
+++ b/graphics/quesoglc/pkg-plist
@@ -0,0 +1,9 @@
+include/GL/glc.h
+lib/libGLC.a
+lib/libGLC.la
+lib/libGLC.so
+lib/libGLC.so.0
+libdata/pkgconfig/quesoglc.pc
+@dirrm libdata/pkgconfig
+@dirrm libdata
+@dirrm include/GL