aboutsummaryrefslogtreecommitdiff
path: root/graphics/qvplay
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-18 03:42:57 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-18 03:42:57 +0000
commitacb6175813e2b18fb31ac765a6018873607ed8c9 (patch)
tree1b18d2e419a5325dfc30b81a8353df2d109b436f /graphics/qvplay
parent8a1efb02be02501977004eb5029d28e1dcc21448 (diff)
Notes
Diffstat (limited to 'graphics/qvplay')
-rw-r--r--graphics/qvplay/Makefile38
-rw-r--r--graphics/qvplay/files/patch-aa26
-rw-r--r--graphics/qvplay/files/pkg-message.in1
-rw-r--r--graphics/qvplay/pkg-descr16
-rw-r--r--graphics/qvplay/pkg-plist11
5 files changed, 30 insertions, 62 deletions
diff --git a/graphics/qvplay/Makefile b/graphics/qvplay/Makefile
index bc8b017b2bc1..fdd65ed56d0c 100644
--- a/graphics/qvplay/Makefile
+++ b/graphics/qvplay/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: qvplay
-# Date created: 2 May 1997
-# Whom: Jun-ichiro itojun Itoh <itojun@itojun.org>
-#
+# Created by: Jun-ichiro itojun Itoh <itojun@itojun.org>
# $FreeBSD$
-#
PORTNAME= qvplay
PORTVERSION= 0.95
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.asahi-net.or.jp/~xg2k-hys/
@@ -17,25 +14,34 @@ WRKSRC= ${WRKDIR}/QVplay095/obj/FreeBSD
GNU_CONFIGURE= yes
-MAN1= qvplay.1 qvrec.1 qvalldel.1
+PLIST_FILES= bin/qvalldel \
+ bin/qvplay \
+ bin/qvrec
-MYPORTDOCS= FAQ.txt HISTORY PROTOCOL.txt PROTOCOL.eng \
- README README.eng README.FreeBSD
-SUB_FILES= pkg-message
+MAN1= qvalldel.1 qvplay.1 qvrec.1
-pre-patch:
+PORTDOCS= FAQ.txt HISTORY PROTOCOL.eng PROTOCOL.txt \
+ README README.FreeBSD README.eng
+
+.include <bsd.port.options.mk>
+
+post-patch:
@${MKDIR} ${WRKSRC}
+ @${REINPLACE_CMD} \
+ -e 's|/usr/local/bin|$${PREFIX}/bin|' \
+ -e 's|/usr/local/man/man1|$${PREFIX}/man/man1|' \
+ -e 's|$$(INSTALL_PROGRAM) -o root -g bin -m 444 $$(MAN1) $$(mandir)/$$(MAN1)|$$(INSTALL_DATA) $$(MAN1) $$(mandir)/$$(MAN1)|' \
+ -e 's|$$(INSTALL_PROGRAM) -o root -g bin -m 444 $$(MAN2) $$(mandir)/$$(MAN2)|$$(INSTALL_DATA) $$(MAN2) $$(mandir)/$$(MAN2)|' \
+ -e 's|$$(INSTALL_PROGRAM) -o root -g bin -m 444 $$(MAN3) $$(mandir)/$$(MAN3)|$$(INSTALL_DATA) $$(MAN3) $$(mandir)/$$(MAN3)|' \
+ ${WRKSRC}/../../src/Makefile.in
pre-configure:
- @( cd ${WRKDIR}/QVplay095; ./setup FreeBSD )
+ @(cd ${WRKDIR}/QVplay095; ./setup FreeBSD)
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in ${MYPORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/../../${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/../../|} ${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/qvplay/files/patch-aa b/graphics/qvplay/files/patch-aa
deleted file mode 100644
index 651b84fc73d2..000000000000
--- a/graphics/qvplay/files/patch-aa
+++ /dev/null
@@ -1,26 +0,0 @@
---- ../../src/Makefile.in.orig Tue Aug 29 20:00:58 2000
-+++ ../../src/Makefile.in Wed Jan 10 03:59:59 2001
-@@ -10,8 +10,8 @@
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
--bindir = /usr/local/bin
--mandir = /usr/local/man/man1
-+bindir = @prefix@/bin
-+mandir = @prefix@/man/man1
-
- SRCS1 = tty.c command.c command1.c getuint.c jpeg.c ppm.c bmp.c qvplay.c
- OBJS1 = tty.o command.o command1.o getuint.o jpeg.o ppm.o bmp.o qvplay.o
-@@ -55,9 +55,9 @@
- $(INSTALL_PROGRAM) -s -o root -g uucp -m 2755 $(PROG1) $(bindir)/$(PROG1)
- $(INSTALL_PROGRAM) -s -o root -g uucp -m 2755 $(PROG2) $(bindir)/$(PROG2)
- $(INSTALL_PROGRAM) -s -o root -g uucp -m 2755 $(PROG3) $(bindir)/$(PROG3)
-- $(INSTALL_PROGRAM) -o root -g bin -m 444 $(MAN1) $(mandir)/$(MAN1)
-- $(INSTALL_PROGRAM) -o root -g bin -m 444 $(MAN2) $(mandir)/$(MAN2)
-- $(INSTALL_PROGRAM) -o root -g bin -m 444 $(MAN3) $(mandir)/$(MAN3)
-+ $(INSTALL_DATA) $(MAN1) $(mandir)/$(MAN1)
-+ $(INSTALL_DATA) $(MAN2) $(mandir)/$(MAN2)
-+ $(INSTALL_DATA) $(MAN3) $(mandir)/$(MAN3)
- depend: .depend
- .depend:
- mkdep $(SRCS1)
diff --git a/graphics/qvplay/files/pkg-message.in b/graphics/qvplay/files/pkg-message.in
deleted file mode 100644
index e9347015ee7f..000000000000
--- a/graphics/qvplay/files/pkg-message.in
+++ /dev/null
@@ -1 +0,0 @@
-Documents for qvplay can be found at: %%DOCSDIR%%
diff --git a/graphics/qvplay/pkg-descr b/graphics/qvplay/pkg-descr
index af37c12ca419..13bdc9af293d 100644
--- a/graphics/qvplay/pkg-descr
+++ b/graphics/qvplay/pkg-descr
@@ -1,13 +1,13 @@
qvplay
- Downloading tool for Casio QV series digital camera.
- Known to work with:
- - Casio QV-10/10A/11/100
- - Casio QV-30/300
- (The word "plus" in the US product name "Casio QV-10*plus*"
- means bundled kit, so you need not to worry about the word "plus")
+ Downloading tool for Casio QV series digital camera.
+ Known to work with:
+ - Casio QV-10/10A/11/100
+ - Casio QV-30/300
+ (The word "plus" in the US product name "Casio QV-10*plus*"
+ means bundled kit, so you need not to worry about the word "plus")
AUTHOR CONTACT
- Ken-ichi Hayashi <xg2k-hys@asahi-net.or.jp>
- Jun-ichiro itojun Itoh <itojun@itojun.org>
+ Ken-ichi Hayashi <xg2k-hys@asahi-net.or.jp>
+ Jun-ichiro itojun Itoh <itojun@itojun.org>
WWW: http://www.asahi-net.or.jp/~xg2k-hys/index-e.html
diff --git a/graphics/qvplay/pkg-plist b/graphics/qvplay/pkg-plist
deleted file mode 100644
index c25f2f03f58f..000000000000
--- a/graphics/qvplay/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/qvalldel
-bin/qvplay
-bin/qvrec
-%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY
-%%PORTDOCS%%%%DOCSDIR%%/PROTOCOL.eng
-%%PORTDOCS%%%%DOCSDIR%%/PROTOCOL.txt
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
-%%PORTDOCS%%%%DOCSDIR%%/README.eng
-%%PORTDOCS%%@dirrm %%DOCSDIR%%