aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee-devel
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-01-28 00:49:11 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-01-28 00:49:11 +0000
commit0cb3aa37ee7b3b44ddb60df034b35cf938bfcc10 (patch)
tree791180497e478f71f81928aed02ead82c13da87e /graphics/rawtherapee-devel
parentc583202bfbffcaf7bfaa58d36e71d9fb44d0dc54 (diff)
downloadports-0cb3aa37ee7b3b44ddb60df034b35cf938bfcc10.tar.gz
ports-0cb3aa37ee7b3b44ddb60df034b35cf938bfcc10.zip
Notes
Diffstat (limited to 'graphics/rawtherapee-devel')
-rw-r--r--graphics/rawtherapee-devel/Makefile111
-rw-r--r--graphics/rawtherapee-devel/distinfo6
-rw-r--r--graphics/rawtherapee-devel/files/ReleaseInfo.cmake4
-rw-r--r--graphics/rawtherapee-devel/files/patch-CMakeLists.txt13
-rw-r--r--graphics/rawtherapee-devel/files/patch-rtengine_imagedata.cc11
-rw-r--r--graphics/rawtherapee-devel/files/patch-rtengine_improcfun.h14
-rw-r--r--graphics/rawtherapee-devel/files/patch-rtengine_opthelper.h2
-rw-r--r--graphics/rawtherapee-devel/files/patch-rtgui_cachemanager.cc11
-rw-r--r--graphics/rawtherapee-devel/files/patch-rtgui_soundman.cc22
-rw-r--r--graphics/rawtherapee-devel/files/rawtherapee.in8
-rw-r--r--graphics/rawtherapee-devel/pkg-message1
-rw-r--r--graphics/rawtherapee-devel/pkg-plist53
12 files changed, 122 insertions, 134 deletions
diff --git a/graphics/rawtherapee-devel/Makefile b/graphics/rawtherapee-devel/Makefile
index dc41b0890e10..52726ad67fb2 100644
--- a/graphics/rawtherapee-devel/Makefile
+++ b/graphics/rawtherapee-devel/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= rawtherapee
-PORTVERSION= 4.2.99.git000
-PORTREVISION= 2
+PORTVERSION= 5.0
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= http://rawtherapee.com/shared/source/
+DISTVERSIONSUFFIX= -gtk3
PKGNAMESUFFIX= -devel
MAINTAINER= mandree@FreeBSD.org
@@ -13,103 +14,101 @@ COMMENT= Powerful RAW image processing application
LICENSE= GPLv3
-LIB_DEPENDS= \
- libcanberra.so:audio/libcanberra \
+LIB_DEPENDS= libcanberra-gtk.so:audio/libcanberra \
libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libexpat.so:textproc/expat2 \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
- libgtkmm-3.0.so:x11-toolkits/gtkmm30 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libiptcdata.so:graphics/libiptcdata \
liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png \
libsigc-2.0.so:devel/libsigc++20 \
libtiff.so:graphics/tiff
-USE_GITHUB= yes
-GH_TUPLE= Beep6581:RawTherapee:70a79772
-
-USES= cmake:outsource compiler:c++11-lib desktop-file-utils dos2unix gettext-runtime jpeg pkgconfig tar:xz
+USES= cmake:outsource compiler:gcc-c++11-lib desktop-file-utils dos2unix \
+ jpeg localbase:ldflags pkgconfig tar:xz
DOS2UNIX_REGEX= .*\.(cc|h)
-USE_GNOME= atkmm cairo cairomm glibmm pangomm gtk30
-USE_XORG+= x11
+LDFLAGS+= -Wl,--as-needed # fontconfig, freetype, gettext, libX11
+USE_GNOME= gtkmm30
USE_LDCONFIG= yes
-USE_BINUTILS= yes
-CFLAGS+= -I${LOCALBASE}/include -fPIC
-CXXFLAGS+= -I${LOCALBASE}/include -fPIC
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
-CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+# The -D_GLIBCXX_USE_C99 works around stoi not being defined
+# by default because the GCC headers believe FreeBSD insufficiently C99
+# compliant.
+CFLAGS+= -I${LOCALBASE}/include -fPIC -D_GLIBCXX_USE_C99 -Wno-deprecated-declarations -Wno-unused-result
+LDFLAGS+= -lpthread
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
-DCREDITSDIR="${DOCSDIR}" \
-DLICENCEDIR="${DOCSDIR}" \
-DDESKTOPDIR="${DESKTOPDIR}" \
-DDATADIR="${DATADIR}" \
- -DCACHE_NAME_SUFFIX=""
-SUB_FILES= rawtherapee
-SUB_LIST= RTDIR="${RTDIR}"
+ -DCACHE_NAME_SUFFIX="" \
+ -Wno-dev \
+ -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW
+# 3.4.x: CMAKE_EXE_LINKER_FLAGS is not passed to TRY_COMPILE by default
+# any more. The CMP0056 policy must be explicitly set to NEW to ensure
+# linker flags are passed. Else -lomp is not found with clang.
+# See: https://cmake.org/cmake/help/v3.4/policy/CMP0056.html
+
INSTALLS_ICONS= yes
+.if defined(PACKAGE_BUILDING) && empty(CFLAGS:M-march*)
+CMAKE_ARGS+= -DPROC_TARGET_NUMBER="1"
+.endif
+
RTDIR= ${PREFIX}/libdata/${PORTNAME}
OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP NATIVE
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS OPENMP
-OPENMP_DESC= Enable multicore processing using OpenMP
+OPENMP_DESC= Enable multicore processing using OpenMP (amd64)
OPTIMIZED_CFLAGS_DESC= Use extra compiler optimizations (requires SSE2 support)
NATIVE_DESC= Use -march=native for compilation (do not use for generic packages!)
OPENMP_CMAKE_BOOL= OPTION_OMP
-.if defined(PACKAGE_BUILDING)
-CMAKE_ARGS+= -DPROC_TARGET_NUMBER="1"
-.endif
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -funroll-loops -msse2 \
+ ${OPTIMIZED_CFLAGS_CFLAGS_${CHOSEN_COMPILER_TYPE}}
+OPTIMIZED_CFLAGS_CFLAGS_gcc= -fexpensive-optimizations
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "i386"
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -funroll-loops -msse2
-CXXFLAGS+= -O3 -funroll-loops -msse2
-.endif
-.endif
+# -------------------------------------------------------------------
+#
.if ${PORT_OPTIONS:MNATIVE}
CMAKE_ARGS+= -DPROC_TARGET_NUMBER="2"
.endif
-.if ${ARCH} == amd64 && ${COMPILER_TYPE} == clang
-# Enable OpenMP support with Clang 3.9.
-BUILD_DEPENDS+= clang39:devel/llvm39
+.if !empty(PORT_OPTIONS:MOPENMP) && ${ARCH} == "amd64"
LIB_DEPENDS+= libomp.so.0:devel/openmp
-
-CPP= clang-cpp39
-CC= clang39
-CXX= clang++39
-
-# FIXME: At least in 3.7.0 and 3.7.1, Clang doesn't find libomp.so
-# itself. Furthermore, there may be a regression in 3.7.1 because we now
-# need to explicitly link to libm.so as well.
-OPENMP_FLAGS= -L${LOCALBASE}/lib -lm -lomp
+OPENMP_FLAGS= -lm -lomp
LDFLAGS+= ${OPENMP_FLAGS}
+.endif
-# In cmake, the CMP0056 policy must be explicitly set to NEW to ensure
-# linker flags are passed.
-# See: https://cmake.org/cmake/help/v3.4/policy/CMP0056.html
-CMAKE_ARGS+= -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW
+.if defined(WITH_DEBUG)
+CMAKE_BUILD_TYPE= RelWithDebInfo
+STRIP=
.endif
+# -------------------------------------------------------------------
+
+.include <bsd.port.pre.mk>
+
+# Workaround: this needs to be late because Mk/Uses/compiler.mk tramples
+# over previously set values with gcc-libc++-configure as of r432539.
+# GCC 4.9 doesn't generate usable code on FreeBSD 11.0.
+USE_GCC= 5+
+
post-patch:
- @${REINPLACE_CMD} -e 's#<auto_ptr.h>#<memory>#g' \
- ${WRKSRC}/rtgui/darkframe.h \
- ${WRKSRC}/rtgui/flatfield.h \
- ${WRKSRC}/rtgui/icmpanel.h
@${REINPLACE_CMD} -e 's#DESTINATION "$${CMAKE_INSTALL_PREFIX}/share/man/man1"#DESTINATION "${MANPREFIX}/man/man1/"#' \
${WRKSRC}/CMakeLists.txt
- ${RM} ${WRKSRC}/rtengine/dcraw.patch \
- ${WRKSRC}/rtengine/dcraw.c
-.ifdef(USE_GITHUB)
-pre-configure:
- ${CP} ${FILESDIR}/ReleaseInfo.cmake ${WRKSRC}/
-.endif
+# paranoia: run rawtherapee --help to be sure it finds all its
+# shared libraries (this hinges on proper RPATH setting and propagation)
+post-install:
+ ${SETENV} LANG= LC_ALL=C LANGUAGE= DISPLAY= HOME=/dev/null ${STAGEDIR}${PREFIX}/bin/rawtherapee --help 2>&1 \
+ | ${EGREP} -q "RawTherapee, version ${PKGVERSION:C/_.*//:C/,.*//}|cannot open display:"
.include <bsd.port.post.mk>
diff --git a/graphics/rawtherapee-devel/distinfo b/graphics/rawtherapee-devel/distinfo
index 4d160323f6f6..8acad474da5e 100644
--- a/graphics/rawtherapee-devel/distinfo
+++ b/graphics/rawtherapee-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483122272
-SHA256 (Beep6581-RawTherapee-4.2.99.git000-70a79772_GH0.tar.gz) = da065b11ad1e48bd6cb545a7b936f2d4640290d93f456cab5b2380ef9fa51f9b
-SIZE (Beep6581-RawTherapee-4.2.99.git000-70a79772_GH0.tar.gz) = 25829053
+TIMESTAMP = 1485205646
+SHA256 (rawtherapee-5.0-gtk3.tar.xz) = 25c6bb738535d1efa905bd21fb732bdea352d589d9740a730ec409a49e7eacd8
+SIZE (rawtherapee-5.0-gtk3.tar.xz) = 10442940
diff --git a/graphics/rawtherapee-devel/files/ReleaseInfo.cmake b/graphics/rawtherapee-devel/files/ReleaseInfo.cmake
deleted file mode 100644
index 445d58e9d6f5..000000000000
--- a/graphics/rawtherapee-devel/files/ReleaseInfo.cmake
+++ /dev/null
@@ -1,4 +0,0 @@
-set(GIT_BRANCH gtk3)
-set(GIT_VERSION 4.2.1466)
-set(GIT_CHANGESET 4fadc499d05246513f8228b518b06066e23e1c98)
-set(GIT_TAGDISTANCE 1466)
diff --git a/graphics/rawtherapee-devel/files/patch-CMakeLists.txt b/graphics/rawtherapee-devel/files/patch-CMakeLists.txt
deleted file mode 100644
index 2eb2b560ce07..000000000000
--- a/graphics/rawtherapee-devel/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
-# This is required so that the RPATH information for libgcc/libgomp is
-# not stripped during CMake's install phase: -- mandree
-
---- CMakeLists.txt.orig 2016-12-30 15:28:53 UTC
-+++ CMakeLists.txt
-@@ -12,6 +12,7 @@ if(${CMAKE_EXTRA_GENERATOR} MATCHES "Ecl
- endif()
-
- PROJECT(RawTherapee)
-+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
-
- # the default target is 'Debug'
- if (CMAKE_BUILD_TYPE STREQUAL "")
diff --git a/graphics/rawtherapee-devel/files/patch-rtengine_imagedata.cc b/graphics/rawtherapee-devel/files/patch-rtengine_imagedata.cc
new file mode 100644
index 000000000000..7190bb595dcd
--- /dev/null
+++ b/graphics/rawtherapee-devel/files/patch-rtengine_imagedata.cc
@@ -0,0 +1,11 @@
+--- rtengine/imagedata.cc.orig 2017-01-26 22:12:23 UTC
++++ rtengine/imagedata.cc
+@@ -444,7 +444,7 @@ void ImageData::extractInfo ()
+ if (baseIsoTag) {
+ std::string isoData = baseIsoTag->valueToString();
+ if (isoData.size() > 1) {
+- iso_speed = stoi(isoData);
++ iso_speed = std::stoi(isoData);
+ }
+ }
+ }
diff --git a/graphics/rawtherapee-devel/files/patch-rtengine_improcfun.h b/graphics/rawtherapee-devel/files/patch-rtengine_improcfun.h
deleted file mode 100644
index 39275d147b3f..000000000000
--- a/graphics/rawtherapee-devel/files/patch-rtengine_improcfun.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./rtengine/improcfun.h.orig 2012-01-31 05:00:05.000000000 +0400
-+++ ./rtengine/improcfun.h 2012-03-31 11:46:27.000000000 +0400
-@@ -19,6 +19,11 @@
- #ifndef _IMPROCFUN_H_
- #define _IMPROCFUN_H_
-
-+#include <sys/param.h>
-+#if __FreeBSD_version <= 704100 || (__FreeBSD_version >= 800000 && __FreeBSD_version < 802502) || (__FreeBSD_version >= 900000 && __FreeBSD_version < 900027)
-+#define log2(x) (log(x) / M_LN2)
-+#endif
-+
- #include "imagefloat.h"
- #include "image16.h"
- #include "image8.h"
diff --git a/graphics/rawtherapee-devel/files/patch-rtengine_opthelper.h b/graphics/rawtherapee-devel/files/patch-rtengine_opthelper.h
index 8021a6b548c4..c52f76d46296 100644
--- a/graphics/rawtherapee-devel/files/patch-rtengine_opthelper.h
+++ b/graphics/rawtherapee-devel/files/patch-rtengine_opthelper.h
@@ -1,4 +1,4 @@
---- rtengine/opthelper.h.orig 2017-01-05 02:25:57 UTC
+--- rtengine/opthelper.h.orig 2017-01-26 22:12:23 UTC
+++ rtengine/opthelper.h
@@ -69,7 +69,7 @@
#define ALIGNED64
diff --git a/graphics/rawtherapee-devel/files/patch-rtgui_cachemanager.cc b/graphics/rawtherapee-devel/files/patch-rtgui_cachemanager.cc
new file mode 100644
index 000000000000..6c3af1cc09e5
--- /dev/null
+++ b/graphics/rawtherapee-devel/files/patch-rtgui_cachemanager.cc
@@ -0,0 +1,11 @@
+--- rtgui/cachemanager.cc.orig 2017-01-26 22:12:22 UTC
++++ rtgui/cachemanager.cc
+@@ -36,7 +36,7 @@ namespace
+ {
+
+ constexpr auto cacheDirMode = 511;
+-constexpr auto cacheDirs = { "profiles", "images", "aehistograms", "embprofiles", "data" };
++constexpr const char *cacheDirs[] = { "profiles", "images", "aehistograms", "embprofiles", "data" };
+
+ }
+
diff --git a/graphics/rawtherapee-devel/files/patch-rtgui_soundman.cc b/graphics/rawtherapee-devel/files/patch-rtgui_soundman.cc
new file mode 100644
index 000000000000..43207b8d4f21
--- /dev/null
+++ b/graphics/rawtherapee-devel/files/patch-rtgui_soundman.cc
@@ -0,0 +1,22 @@
+--- rtgui/soundman.cc.orig 2017-01-26 22:12:22 UTC
++++ rtgui/soundman.cc
+@@ -24,9 +24,7 @@
+ #ifdef WIN32
+ #include <windows.h>
+ #include <mmsystem.h>
+-#endif
+-
+-#ifdef __linux__
++#elif !defined(__APPLE__)
+ #include <canberra-gtk.h>
+ #endif
+
+@@ -67,7 +65,7 @@ void SoundManager::playSoundAsync(const
+ wchar_t *wfilename = (wchar_t*)g_utf8_to_utf16 (sound.c_str(), -1, NULL, NULL, NULL);
+ PlaySoundW(wfilename, NULL, sndParam);
+ g_free( wfilename );
+-#elif defined(__linux__)
++#elif !defined(__APPLE__)
+ ca_context_play(ca_gtk_context_get(), 0, CA_PROP_EVENT_ID, sound.c_str(), CA_PROP_MEDIA_FILENAME, sound.c_str(), NULL);
+ #endif
+ }
diff --git a/graphics/rawtherapee-devel/files/rawtherapee.in b/graphics/rawtherapee-devel/files/rawtherapee.in
deleted file mode 100644
index 3e625f01ab39..000000000000
--- a/graphics/rawtherapee-devel/files/rawtherapee.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/csh
-#
-# $FreeBSD$
-
-set RTH = "%%RTDIR%%/rth"
-set CONFDIR = "%%RTDIR%%"
-
-exec "${RTH}" ${CONFDIR}
diff --git a/graphics/rawtherapee-devel/pkg-message b/graphics/rawtherapee-devel/pkg-message
index ccb1877aaf65..ac0e1ed156a7 100644
--- a/graphics/rawtherapee-devel/pkg-message
+++ b/graphics/rawtherapee-devel/pkg-message
@@ -10,4 +10,3 @@ remove older cache directories.
Also, after configurations have been moved to the new version's
directory, older $HOME/.config/RawTherapee* directories may be removed.
======================================================================
-
diff --git a/graphics/rawtherapee-devel/pkg-plist b/graphics/rawtherapee-devel/pkg-plist
index 3f1e44955163..88a8b6612ab0 100644
--- a/graphics/rawtherapee-devel/pkg-plist
+++ b/graphics/rawtherapee-devel/pkg-plist
@@ -18,10 +18,12 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/dcpprofiles/Canon EOS 400D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 40D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 450D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 50D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 550D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 5D Mark III.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 5D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 6D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 7D Mark II.dcp
%%DATADIR%%/dcpprofiles/Canon EOS 7D.dcp
%%DATADIR%%/dcpprofiles/Canon EOS D60.dcp
%%DATADIR%%/dcpprofiles/Canon EOS Digital Rebel XSi.dcp
@@ -37,9 +39,10 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/dcpprofiles/Fujifilm FinePix S9500.dcp
%%DATADIR%%/dcpprofiles/Fujifilm X-E1.dcp
%%DATADIR%%/dcpprofiles/Fujifilm X-E2.dcp
-%%DATADIR%%/dcpprofiles/Fujifilm X-T1.dcp
+%%DATADIR%%/dcpprofiles/FUJIFILM X-Pro2.dcp
+%%DATADIR%%/dcpprofiles/FUJIFILM X-T1.dcp
%%DATADIR%%/dcpprofiles/Fujifilm X-T10.dcp
-%%DATADIR%%/dcpprofiles/Fujifilm X100T.dcp
+%%DATADIR%%/dcpprofiles/FUJIFILM X100T.dcp
%%DATADIR%%/dcpprofiles/Leaf Aptus 75.dcp
%%DATADIR%%/dcpprofiles/Nikon D200.dcp
%%DATADIR%%/dcpprofiles/Nikon D300.dcp
@@ -48,14 +51,17 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/dcpprofiles/Nikon D3S.dcp
%%DATADIR%%/dcpprofiles/Nikon D50.dcp
%%DATADIR%%/dcpprofiles/Nikon D5100.dcp
+%%DATADIR%%/dcpprofiles/NIKON D600.dcp
%%DATADIR%%/dcpprofiles/Nikon D700.dcp
%%DATADIR%%/dcpprofiles/Nikon D7000.dcp
-%%DATADIR%%/dcpprofiles/Nikon D7200.dcp
-%%DATADIR%%/dcpprofiles/Nikon D750.dcp
+%%DATADIR%%/dcpprofiles/NIKON D7200.dcp
+%%DATADIR%%/dcpprofiles/NIKON D750.dcp
%%DATADIR%%/dcpprofiles/Nikon D800.dcp
+%%DATADIR%%/dcpprofiles/NIKON D810.dcp
%%DATADIR%%/dcpprofiles/Olympus E-1.dcp
%%DATADIR%%/dcpprofiles/Olympus E-510.dcp
%%DATADIR%%/dcpprofiles/Olympus E-520.dcp
+%%DATADIR%%/dcpprofiles/OLYMPUS E-M10.dcp
%%DATADIR%%/dcpprofiles/Olympus E-M5.dcp
%%DATADIR%%/dcpprofiles/Olympus E-P2.dcp
%%DATADIR%%/dcpprofiles/Olympus XZ-1.dcp
@@ -67,18 +73,21 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/dcpprofiles/Panasonic DMC-G5.dcp
%%DATADIR%%/dcpprofiles/Panasonic DMC-GH1.dcp
%%DATADIR%%/dcpprofiles/Panasonic DMC-GH2.dcp
-%%DATADIR%%/dcpprofiles/Pentax K-5 II.dcp
-%%DATADIR%%/dcpprofiles/Pentax K-5.dcp
+%%DATADIR%%/dcpprofiles/PENTAX K-5 II.dcp
+%%DATADIR%%/dcpprofiles/PENTAX K-5.dcp
%%DATADIR%%/dcpprofiles/Pentax K-r.dcp
-%%DATADIR%%/dcpprofiles/Pentax K10D.dcp
+%%DATADIR%%/dcpprofiles/PENTAX K10D.dcp
%%DATADIR%%/dcpprofiles/Pentax K200D.dcp
-%%DATADIR%%/dcpprofiles/Ricoh Pentax K-3.dcp
+%%DATADIR%%/dcpprofiles/RICOH PENTAX K-1.dcp
+%%DATADIR%%/dcpprofiles/RICOH PENTAX K-3.dcp
%%DATADIR%%/dcpprofiles/Sony DSLR-A700.dcp
%%DATADIR%%/dcpprofiles/Sony DSLR-A900.dcp
-%%DATADIR%%/dcpprofiles/Sony ILCE-6000.dcp
-%%DATADIR%%/dcpprofiles/Sony ILCE-7M2.dcp
+%%DATADIR%%/dcpprofiles/SONY ILCE-6000.dcp
+%%DATADIR%%/dcpprofiles/SONY ILCE-7M2.dcp
%%DATADIR%%/dcpprofiles/Sony NEX-5N.dcp
%%DATADIR%%/dcpprofiles/Sony SLT-A55V.dcp
+%%DATADIR%%/dcpprofiles/SONY SLT-A99V.dcp
+%%DATADIR%%/dcpprofiles/YI TECHNOLOGY M1.dcp
%%DATADIR%%/iccprofiles/input/Canon EOS 20D.icc
%%DATADIR%%/iccprofiles/input/Canon EOS 40D.icc
%%DATADIR%%/iccprofiles/input/Canon EOS 450D.icc
@@ -867,28 +876,4 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/themes/RawTherapee-GTK3-_19.css
%%DATADIR%%/themes/TooWaBlue-Dark-GTK3-20_.css
%%DATADIR%%/themes/TooWaBlue-GTK3-20_.css
-%%DATADIR%%/themes/images/svg/twb/checkbox-checked-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/checkbox-checked.svg
-%%DATADIR%%/themes/images/svg/twb/checkbox-inconsistent-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/checkbox-inconsistent.svg
-%%DATADIR%%/themes/images/svg/twb/checkbox-unchecked-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/checkbox-unchecked.svg
-%%DATADIR%%/themes/images/svg/twb/radio-checked-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/radio-checked.svg
-%%DATADIR%%/themes/images/svg/twb/radio-inconsistent-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/radio-inconsistent.svg
-%%DATADIR%%/themes/images/svg/twb/radio-unchecked-disabled.svg
-%%DATADIR%%/themes/images/svg/twb/radio-unchecked.svg
-%%DATADIR%%/themes/images/twb/checkbox-checked-disabled.png
-%%DATADIR%%/themes/images/twb/checkbox-checked.png
-%%DATADIR%%/themes/images/twb/checkbox-inconsistent-disabled.png
-%%DATADIR%%/themes/images/twb/checkbox-inconsistent.png
-%%DATADIR%%/themes/images/twb/checkbox-unchecked-disabled.png
-%%DATADIR%%/themes/images/twb/checkbox-unchecked.png
-%%DATADIR%%/themes/images/twb/radio-checked-disabled.png
-%%DATADIR%%/themes/images/twb/radio-checked.png
-%%DATADIR%%/themes/images/twb/radio-inconsistent-disabled.png
-%%DATADIR%%/themes/images/twb/radio-inconsistent.png
-%%DATADIR%%/themes/images/twb/radio-unchecked-disabled.png
-%%DATADIR%%/themes/images/twb/radio-unchecked.png
%%DATADIR%%/themes/system.iconset