aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-06-15 20:15:31 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-06-15 20:15:31 +0000
commit3cf326c833a4e8be89a7039fbe1e487cd263ab67 (patch)
treea963a69be14d0b28490d42f265be22dfb32df8f5 /graphics/rawtherapee/Makefile
parent3ae7902d7aa7e80e5179dc0056a739982e04b1b3 (diff)
downloadports-3cf326c833a4e8be89a7039fbe1e487cd263ab67.tar.gz
ports-3cf326c833a4e8be89a7039fbe1e487cd263ab67.zip
Notes
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 0f22a8007c96..62796d6c36ef 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -17,9 +17,10 @@ LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
lcms2:${PORTSDIR}/graphics/lcms2 \
png15:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
- sigc-2.0:${PORTSDIR}/devel/libsigc++20
+ sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
+ canberra-gtk3:${PORTSDIR}/audio/libcanberra-gtk3
-USES= cmake pkgconfig
+USES= cmake:outsource pkgconfig
MAKE_JOBS_SAFE= yes
USE_XZ= yes
USE_GNOME= gtk20 glib20
@@ -56,6 +57,12 @@ post-patch:
@${REINPLACE_CMD} -e 's#DESTINATION "$${CMAKE_INSTALL_PREFIX}/share/man/man1"#DESTINATION "${MANPREFIX}/man/man1/"#' \
${WRKSRC}/CMakeLists.txt
+# paranoia: run rawtherapee --help to be sure it finds all its
+# shared libraries (this hinges on proper RPATH setting and propagation)
+post-build:
+ ${PREFIX}/bin/rawtherapee --help 2>&1 \
+ | ${EGREP} -q "RawTherapee, version ${PKGVERSION:C/_.*//:C/,.*//}"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "i386"