aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2011-08-01 07:55:34 +0000
committerStanislav Sedov <stas@FreeBSD.org>2011-08-01 07:55:34 +0000
commit4bfa1d79aa51f05d0cab7d8f69ae169c1dac0dcd (patch)
tree5dbd081686ef1d03d77eeb7e60d72a3714e45b4f /graphics/rawtherapee/Makefile
parent06fe66c1e70f441abd544803b3b69011fd662565 (diff)
downloadports-4bfa1d79aa51f05d0cab7d8f69ae169c1dac0dcd.tar.gz
ports-4bfa1d79aa51f05d0cab7d8f69ae169c1dac0dcd.zip
Notes
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 9cf868fd52f2..1e69500036a7 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -7,11 +7,9 @@
PORTNAME= rawtherapee
PORTVERSION= 3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
-MASTER_SITES= http://www.rawtherapee.com/
-DISTNAME= ${PORTNAME}${PORTVERSION:S,.,,g}src
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
MAINTAINER= stas@FreeBSD.org
COMMENT= A powerful RAW image processing application
@@ -19,21 +17,29 @@ COMMENT= A powerful RAW image processing application
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
+ lcms2.2:${PORTSDIR}/graphics/lcms2 \
png:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ sigc-2.0:${PORTSDIR}/devel/libsigc++20
USE_CMAKE= yes
-USE_GNOME= gtk20 glib20
+USE_BZIP2= yes
+USE_GNOME= gtk20 glib20 pkgconfig
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CMAKE_ENV= CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
+CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
+ -DCREDITSDIR="${DOCSDIR}" \
+ -DLICENCEDIR="${DOCSDIR}" \
+ -DDESKTOPDIR="${DESKTOPDIR}" \
+ -DDATADIR="${DATADIR}"
SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
+INSTALLS_ICONS= yes
+LICENSE= GPLv3
-WRKSRC= ${WRKDIR}/RawTherapee${PORTVERSION:S,.,,g}
RTDIR= ${PREFIX}/libdata/${PORTNAME}
OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
@@ -47,12 +53,4 @@ CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
.endif
.endif
-do-install:
- ${INSTALL_DATA} ${WRKSRC}/rtengine/librtengine.so ${PREFIX}/lib
- ${MKDIR} ${RTDIR}/
- ${INSTALL_PROGRAM} ${WRKSRC}/rtgui/rth ${RTDIR}/
- (cd ${WRKSRC}/release && ${COPYTREE_SHARE} \* ${RTDIR}/)
- ${INSTALL_DATA} ${WRKSRC}/options.lin ${RTDIR}/options
- ${INSTALL_SCRIPT} ${WRKDIR}/rawtherapee ${PREFIX}/bin/
-
.include <bsd.port.post.mk>